Change the default resample-method to speex-float-N (N > 1) in daemon.conf

Bug #1741045 reported by Amr Ibrahim on 2018-01-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
PulseAudio
Fix Released
Unknown
pulseaudio (Ubuntu)
Wishlist
Unassigned

Bug Description

I suggest changing the default resample-method to speex-float-10, instead of speex-float-1, which is the current default now, in /etc/pulse/daemon.conf.

It would look like this in daemon.conf:
resample-method = speex-float-10

I have always done that since at least 12.04 LTS. I was not satisfied with the sound quality in Ubuntu compared to Windows, so I changed the resample-method.

In my day-to-day usage, it gives better sound quality without sacrificing CPU power.

I have not tried other resample methods. Maybe there are better options I don't know about.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: pulseaudio 1:10.0-2ubuntu3
ProcVersionSignature: Ubuntu 4.13.0-19.22-generic 4.13.13
Uname: Linux 4.13.0-19-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.6
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: amr 1696 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Wed Jan 3 14:37:25 2018
InstallationDate: Installed on 2017-10-02 (92 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Beta amd64 (20170930)
SourcePackage: pulseaudio
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/08/2011
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F2
dmi.board.name: GA-78LMT-S2P
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF2:bd04/08/2011:svnGigabyteTechnologyCo.,Ltd.:pnGA-78LMT-S2P:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-78LMT-S2P:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-78LMT-S2P
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
modified.conffile..etc.pulse.daemon.conf: [modified]
mtime.conffile..etc.pulse.daemon.conf: 2017-10-05T12:39:48.718018

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :
description: updated
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

It appears the default of speex-float-1 is chosen by upstream (?... although commented out):
https://cgit.freedesktop.org/pulseaudio/pulseaudio/tree/src/daemon/daemon.conf.in

More information:
http://manpages.ubuntu.com/manpages/artful/en/man5/pulse-daemon.conf.5.html

I'm not familiar with these options so would not second-guess upstream about the best default just yet. Please log a bug directly with them and let's see what they say:
https://bugs.freedesktop.org/enter_bug.cgi?product=PulseAudio

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
Revision history for this message
In , Amr Ibrahim (amribrahim1987) wrote :

I suggest changing the default resample-method to speex-float-10, instead of speex-float-1, which is the current default now, in /etc/pulse/daemon.conf.

In my day-to-day usage, it gives better sound quality without sacrificing CPU power.

I have always done that since at least 2012. I was not satisfied with the sound quality in Ubuntu compared to Windows, so I changed the resample-method.

It would look like this in daemon.conf:
resample-method = speex-float-10

I have not tried other resample methods. Maybe there are better options I don't know about.

Changed in pulseaudio (Ubuntu):
status: Incomplete → New
Changed in pulseaudio:
importance: Unknown → Wishlist
status: Unknown → Confirmed
Changed in pulseaudio (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
status: Confirmed → New
Revision history for this message
adasiko (adasiko256) wrote :
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

That seems to show speex-float-1 performing quite well: https://imgur.com/a/jtIEj

summary: - Change the default resample-method to speex-float-10 in daemon.conf
+ Change the default resample-method to speex-float-N (N > 1) in
+ daemon.conf
Revision history for this message
In , Gitlab-migration (gitlab-migration) wrote :

-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/issues/310.

Changed in pulseaudio:
status: Confirmed → Unknown
Changed in pulseaudio:
importance: Wishlist → Unknown
status: Unknown → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

Upstream bug comment

'Now there is resample-method setting "auto" which seems to be the default.'

Is the problem still existing on recent Ubuntu versions with the auto value?

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
Revision history for this message
Jarno Suni (jarnos) wrote :

Well, how are you supposed to know, which resample method is actually used?

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

I had already changed the resample-method to soxr-mq, and am satisfied with the result. I don't know how to judge which is better, auto or soxr-mq?

Revision history for this message
Sebastien Bacher (seb128) wrote :

unsure, you are the one who reported an issue/request for change, do you think you request has been addressed or do you still think changing would be better?

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

I changed the resample-method to soxr-hq, and I'll be testing it for some time. According to the manpage of pulse-daemon.conf "the Soxr resamplers generally offer better quality at less CPU compared to other resamplers, such as speex". So far I think it gives better sound quality than speex-float-1 and auto.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.