muted output becomes volume == 0 on session restart

Bug #173212 reported by James Westby on 2007-12-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Low
Unassigned

Bug Description

Hi,

If I leave the mixer muted (with the mute control, rather than zeroing the volume)
when I logout, when I next log in the volume is set to 0.

I am able to unmute the sound by raising the volume using the slider
or the mouse wheel.

Steps to reproduce:
1. Have audio output at e.g. 50%
2. Mute the output, check that the volume slider is still shown at the same level.
3. Restart the session.
4. Note that the output no longer has the mute checkbox on, but the volume is
at 0%.

I believe this inconsistency is a bug.

I only see it on my snd_emu10k1 system, not on my snd_hda_intel system.

I have seen this problem since gutsy, but the symptoms changed slightly,
presumably with the move to pulseaudio.

Thanks,

James

Pedro Villavicencio (pedro) wrote :

Thank you for your comments. This does not appear to be a bug report and we are closing it. We appreciate the difficulties you are facing, but it would make more sense to raise your question in the support tracker. https://answers.launchpad.net/ubuntu

Changed in gnome-media:
status: New → Invalid
James Westby (james-w) wrote :

I am not sure why you are claiming it is not a bug report, it certainly seems like
a bug to me, could you please explain?

I am setting the status back to new. If you need some more information to
convince you of why it is a bug then please set to incomplete. If you have
a good reason why this behaviour is correct then please set to Invalid again
and accept my apologies.

Thanks,

James

Changed in gnome-media:
status: Invalid → New
Sebastien Bacher (seb128) wrote :

the bug lack basic informations like the version of ubuntu you are using for one thing. Could you also try if that's specific to the applet or happens when using the mixer for example?

James Westby (james-w) wrote :

Hi,

Sorry for the delay, some hardware trouble meant that I couldn't test the bug.

I am using gutsy.

Your question about whether it is specific to the applet has pointed me to some
more information. If I right-click on the applet and open the volume control
the master channel is not muted, but is set to zero volume. The applet
is shows that there is volume, it is just that master is muted.

Also, testing on another system it appears as though the problem is specific
to the driver. I can't replicate the issue on my laptop (snd_hda_intel), and
so it may be specific to snd_emu10k1.

Please let me know if I can provide any more information.

Thanks,

James

Sebastien Bacher (seb128) wrote :

does anybody still get the issue in hardy or intrepid?

Changed in gnome-media:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
James Westby (james-w) wrote :

Hi Sebastien,

I still get this, but the symptom has changed slightly, I the "Mute"
option in the context menu is now no longer selected, but selecting
and un-selecting it have no effect.

Thanks,

James

description: updated
James Westby (james-w) on 2008-11-18
description: updated
description: updated
Sebastien Bacher (seb128) wrote :

the issue seems rather a driver or alsa one

Changed in gnome-media:
assignee: desktop-bugs → nobody
status: Incomplete → New

Got similar issue with audigy 2zs + nForce 2 400 Ultra. Mute microphone makes its volume 0, not actually mutes it. But when unmuted its volume stays at level 0, but not restores level before mute.

Daniel T Chen (crimsun) on 2009-01-25
Changed in alsa-lib:
status: New → Confirmed

This problem is still present in the latest builds of 9.10 for some people (see http://ubuntuforums.org/showthread.php?p=7405750#post7405750)

Sorry, looks like we are facing a different problem actually. I apologise for my previous comment, and will file a new bug.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers