distorted sound through IEC958

Bug #172654 reported by Sami Haahtinen on 2007-11-28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)

Bug Description

Binary package hint: pulseaudio

All sound that comes through pulseaudio to the speakers connected to a docking station is distorted. The output has a high pitch in it. Without pulseaudio output is normal. The internal headphone plug is not affected by this (and it doesn't use IEC958 for output)

Computer is a Dell Latitude D610 with ICH6 sound chip.

So far I've tested that the problem is not in my configuration by going around pulseaudio either by setting the default gstreamer output to alsasink and by using vlc to output directly to alsa output. Both gstreamer pipelines and vlc are affected if the output is redirected to pulseaudio.

Sami Haahtinen (ressu) wrote :

After a bit of digging around i found this bit in Bug #55150:

-- Snip --
amixer controls %% search the id of IEC-default (at my system 35)
amixer -c 0 cset numid=35 6 %% 6 = 96kHz
-- Snip --

At the moment i don't really understand yet why it works and why things work without pulseaudio even without this setting. It might be that this bug is actually in alsa and not in the way how pulseaudio uses alsa.

Daniel T Chen (crimsun) on 2007-12-23
Changed in pulseaudio:
importance: Undecided → Low
status: New → Incomplete

Assuming that the volume change fixes Bug #178504 it's a different bug.
Playback with full volume can cause such problems too, but this bug is
not caused by high volume. The distortion here sounds like digital
distortion, not analog (like the ones caused by high volume).

Sami Haahtinen <email address hidden>

Jeff (valderrama) wrote :

I've reviewed but 178504 and the "gravelly" or "staticy" description is exactly what I have. I also noted the comment about generated sounds being fine and realized that this is true for me too. Any other sounds are severely distorted and no amount of volume adjustments fixes this. Having said that, I'm not exactly experienced at Linux so there may be more hidden things that I don't know about.

Gary Mansell (garymansell) wrote :

I have experienced sound distortion issues with Hardy that I never had in Gutsy - Presumably due to Pulse Audio....

Does anyone know how to revert to Gutsy's sound sub-system setup until this problem is fixed?



Clifton Mulkey (cmulk) wrote :

Dell Latitude D610 with SigmaTel Audio Card:

I am now having the same problem with Intrepid Ibex Alpha 2. I never had this problem with Gutsy or Hardy like some of the previous posts describe. If I switch the sound driver to 'Intel ICH6' or 'ALSA' in Preferences>Sounds, i no longer have distortion with media playback. However, the distortion on system sounds is the same no matter what driver I switch it to.

Dimitrios Symeonidis (azimout) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Sami Haahtinen (ressu) wrote :

The problem persists with jaunty. The distortion is gone with pulseaudio, but still no sound without the workaround also mentioned above:

amixer cset iface=MIXER,name='IEC958 Playback Default'

This looks more and more like an alsa bug even though the output worked perfectly without tweaking the settings. I haven't tested audio without the manual workaround and without pulseaudio recently, i'll try and get that done during the weekend.

Dimitrios Symeonidis (azimout) wrote :

switching back to confirmed

Changed in pulseaudio:
status: Incomplete → Confirmed
Dimitrios Symeonidis (azimout) wrote :

raising importance from low to medium, this is a serious issue for a limited number of users

Changed in pulseaudio:
importance: Low → Medium

Seconding the issue.

Spheerys (contact-spheerys) wrote :

I have the same problem with my Dell Precision M6300 with the future Ubuntu version : Jaunty Beta
The sound is growing randomly when I'm using the IEC958 output of my docking station

Sorry to be a pest, but I was wondering if any solutions or work-arounds have been found for this bug yet?

Karl Moore (karl-w-moore) wrote :

Thank you for the help. The workaround fixed the distortion problem on the Docking Station with my Dell Latitude 610, running Jaunty Jackalope, but after a while (1 hour?) the sound stops working. Disabling, and then re-enabling the IEC958 in the Alsa mixer starts the sound again. (This was also noted in Bug #55150) Any Ideas?

Karl, what workaround are you referring to?

Karl Moore (karl-w-moore) wrote :

The workaround was the same one that Sami recommended above:

    amixer controls %% search the id of IEC-default (at my system 35)
    amixer -c 0 cset numid=35 6 %% 6 = 96kHz

This workaround works only for a short while... The sound typically runs OK at power-up and sometime later stops... I have not traced the sound stopping to any action.

I have gotten into the habit of plugging my speakers into my headphone jack, so I have not done any further investigation since August.

Evgeniy Kirov (evg.kirov) wrote :

Distortion on volume levels 56% and more.

Collected by ubuntu-bug tools info is there: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/468358/comments/1

David Henningsson (diwic) wrote :

Hi, is this still a problem on modern Ubuntu versions (trusty, vivid)?

Changed in pulseaudio (Ubuntu):
status: Confirmed → Incomplete
Sami Haahtinen (ressu) wrote :

I can't even try to reproduce the problem anymore. The hardware that used to have this problem is loooong gone.

Unless someone else can reproduce it, I think this can be closed.

Launchpad Janitor (janitor) wrote :

[Expired for pulseaudio (Ubuntu) because there has been no activity for 60 days.]

Changed in pulseaudio (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers