Cannot connect to pulseaudio

Bug #1652505 reported by GDR!
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
High
Unassigned

Bug Description

What I expect to happen: audio working like in Ubuntu 14.04

What is happening: programs cannot connect to pulseaudio server, the server itself isn't crashing. For example, pavuctl hangs on "connecting to pulseaudio", and all media applications are doing the same. It sometimes happens that one application (which opened connection to PA earlier) is still playing but new ones can't connect.

pulseaudio -k && pulseaudio

fixes this issue temporarly, until the next time it happens. The problem occurs multiple times per session.

This is happening on 2 systems, one is not my own - a clean xubuntu 16.04 install - and the other is my own, where I tried various tweaks to default.pa to fix the problem. None worked. This happens with a clean default.pa too. I also tried installing oem-audio-hda-daily-lts-xenial-dkms and that did not help either.

The errors reported in pulseaudio stderr are as following:
E: [alsa-sink-ALC892 Analog] alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write.
E: [alsa-sink-ALC892 Analog] alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA developers.
E: [alsa-sink-ALC892 Analog] alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.

==== AUDIO STOPS WORKING BELOW THIS LINE, LONG TIME AFTER THE PREVIOUS LINE IS PRINTED ====

E: [pulseaudio] shm.c: shm_open() failed: No such file or directory
E: [pulseaudio] shm.c: shm_open() failed: No such file or directory
E: [pulseaudio] shm.c: shm_open() failed: No such file or directory
E: [pulseaudio] shm.c: shm_open() failed: No such file or directory
E: [pulseaudio] shm.c: shm_open() failed: No such file or directory
E: [pulseaudio] shm.c: shm_open() failed: No such file or directory
E: [pulseaudio] shm.c: shm_open() failed: No such file or directory
E: [pulseaudio] shm.c: shm_open() failed: No such file or directory
E: [pulseaudio] shm.c: shm_open() failed: No such file or directory
E: [pulseaudio] shm.c: shm_open() failed: No such file or directory
E: [pulseaudio] shm.c: shm_open() failed: No such file or directory
E: [pulseaudio] shm.c: shm_open() failed: No such file or directory
E: [pulseaudio] shm.c: shm_open() failed: No such file or directory
^CE: [pulseaudio] shm.c: shm_unlink(/pulse-shm-3403108683) failed: No such file or directory
E: [pulseaudio] shm.c: shm_unlink(/pulse-shm-1445609972) failed: No such file or directory

lsb_release -rd
Description: Ubuntu 16.04.1 LTS
Release: 16.04

apt-cache policy pulseaudio
pulseaudio:
  Installed: 1:8.0-0ubuntu3.1
  Candidate: 1:8.0-0ubuntu3.1
  Version table:
 *** 1:8.0-0ubuntu3.1 500
        500 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:8.0-0ubuntu3 500
        500 http://pl.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

➜ ~ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
➜ ~ lsmod | grep snd
snd_usb_audio 176128 0
snd_usbmidi_lib 36864 1 snd_usb_audio
snd_hda_codec_hdmi 53248 1
snd_hda_codec_realtek 86016 1
snd_hda_codec_generic 77824 1 snd_hda_codec_realtek
snd_hda_intel 40960 6
snd_hda_codec 135168 4 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel
snd_hda_core 73728 5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hwdep 16384 2 snd_usb_audio,snd_hda_codec
snd_pcm 106496 6 snd_usb_audio,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
snd_seq_midi 16384 0
snd_seq_midi_event 16384 1 snd_seq_midi
snd_rawmidi 32768 2 snd_usbmidi_lib,snd_seq_midi
snd_seq 69632 2 snd_seq_midi_event,snd_seq_midi
snd_seq_device 16384 3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer 32768 3 snd_pcm,snd_seq
snd 81920 23 snd_hda_codec_realtek,snd_usb_audio,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seq_device
soundcore 16384 1 snd

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: pulseaudio 1:8.0-0ubuntu3.1
ProcVersionSignature: Ubuntu 4.4.0-57.78-generic 4.4.35
Uname: Linux 4.4.0-57-generic x86_64
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
ApportVersion: 2.20.1-0ubuntu2.4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC0D0p: gdr 25119 F...m pulseaudio
 /dev/snd/controlC0: gdr 25119 F.... pulseaudio
 /dev/snd/timer: gdr 25119 f.... pulseaudio
CurrentDesktop: XFCE
Date: Sun Dec 25 11:34:30 2016
InstallationDate: Installed on 2016-12-03 (21 days ago)
InstallationMedia: Xubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
SourcePackage: pulseaudio
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/12/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P2.10
dmi.board.name: Z77 Pro3
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP2.10:bd07/12/2013:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnZ77Pro3:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
modified.conffile..etc.pulse.default.pa: [modified]
mtime.conffile..etc.pulse.default.pa: 2016-12-06T14:07:04.202869

Revision history for this message
GDR! (gdr.name) wrote :
Revision history for this message
GDR! (gdr-8) wrote :

Here's a log of pulseaudio -vvvv

Revision history for this message
GDR! (gdr-8) wrote :

Update: this is definitely a Pulseaudio bug. I just built PA 10 from sources and after `sudo make install` and a restart my sound is good as new. On stock kernel and ALSA.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pulseaudio (Ubuntu):
status: New → Confirmed
Changed in pulseaudio (Ubuntu):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers