ubuntu 16.04 pulse crash on running "ubuntu-bug -s audio"

Bug #1605294 reported by Bertrand G on 2016-07-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

I ran "ubuntu-bug -s audio" to report non working sound on my old toshiba satellite P100, clean install of 16.04LTS, and instead of bug report tool I got a notification of crash of pulseaudio.

$ lsb_release -rd
Description: Ubuntu 16.04.1 LTS
Release: 16.04

$ apt-cache policy pulseaudio
pulseaudio:
  Installé : 1:8.0-0ubuntu3

expected: ubuntu bug report tool to gather debug data
happened: crash of pulse and request to report a bug

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: pulseaudio 1:8.0-0ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic i686
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC0D0c: renaud 3708 F...m pulseaudio
 /dev/snd/pcmC0D0p: renaud 3708 F...m pulseaudio
 /dev/snd/controlC0: renaud 3708 F.... pulseaudio
Date: Thu Jul 21 17:09:28 2016
ProcEnviron:
 LANGUAGE=fr_BE:fr
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_BE.UTF-8
 SHELL=/bin/bash
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
SourcePackage: pulseaudio
Symptom: audio
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/07/2006
dmi.bios.vendor: TOSHIBA
dmi.bios.version: V2.30
dmi.board.name: Satellite P100
dmi.board.vendor: TOSHIBA
dmi.board.version: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvrV2.30:bd08/07/2006:svnTOSHIBA:pnSatelliteP100:pvrPSPA0E-039022BT:rvnTOSHIBA:rnSatelliteP100:rvrNotApplicable:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: Satellite P100
dmi.product.version: PSPA0E-039022BT
dmi.sys.vendor: TOSHIBA

Bertrand G (berteh) wrote :
Bertrand G (berteh) wrote :

retried as user, instead of root session... and seemed to work with no problem.

so simply: prevent ubuntu-bug to be run as sudo/root.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers