[Satellite A215, Realtek ALC268, Mic, Internal] No sound at all. My built-in internal mic won't record sounds.

Bug #1591535 reported by richard7893 on 2016-06-11
72
This bug affects 8 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

https://gitlab.freedesktop.org/pulseaudio/pulseaudio/issues/618

---

My built-in internal mic on my Toshiba Satellite-A215 will not pick up sounds. The external speakers work just fine, but once again the mic can't record any sounds. I have an Ubuntu 14.04.4 LTS.

Below is a link of my ALSA "info" that may be useful:

http://www.alsa-project.org/db/?f=10a2337ec9b863d7414121dff10f30ad0cdf430d

I've tried the ALSA DKMS update recommended to me by an ubuntuforums.org user from this link:

https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS

However after following the instructions from the above link, the mic still has not worked.

The same Ubuntu forum user suggested I file a bug. He/she provided me with a link from "an old report from an A215 with the same ALC268 codec":

https://bugs.launchpad.net/ubuntu/+s...r/+bug/1081353

I provided this because it may be helpful in the debug process.

The version of ALSA I have is shown below:
Advanced Linux Sound Architecture Driver Version k3.19.0-61-generic.

Any help would be appreciated, please let me know if you need any additional info.

PS
I've also provided a link below of the ongoing forum discussion I've been having at ubuntuforums.org below:

http://ubuntuforums.org/showthread.php?t=2323851

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: alsa-base 1.0.25+dfsg-0ubuntu4
ProcVersionSignature: Ubuntu 3.19.0-61.69~14.04.1-generic 3.19.8-ckt21
Uname: Linux 3.19.0-61-generic i686
ApportVersion: 2.14.1-0ubuntu3.21
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: richard 1533 F.... pulseaudio
CurrentDesktop: Unity
Date: Sat Jun 11 10:49:01 2016
InstallationDate: Installed on 2016-01-06 (156 days ago)
InstallationMedia: Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta i386 (20150805)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaRecordingTest: ALSA recording test through plughw:SB failed
Symptom_Card: Built-in Audio - HDA ATI SB
Symptom_DevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: richard 1533 F.... pulseaudio
Symptom_Jack: Mic, Internal
Symptom_Type: No sound at all
Title: [Satellite A215, Realtek ALC268, Mic, Internal] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/23/2007
dmi.bios.vendor: TOSHIBA
dmi.bios.version: V1.10
dmi.board.name: IALAA
dmi.board.vendor: TOSHIBA
dmi.board.version: 1.00
dmi.chassis.asset.tag: *
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvrV1.10:bd05/23/2007:svnTOSHIBA:pnSatelliteA215:pvrPSAEGU-01700U:rvnTOSHIBA:rnIALAA:rvr1.00:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: Satellite A215
dmi.product.version: PSAEGU-01700U
dmi.sys.vendor: TOSHIBA
mtime.conffile..etc.modprobe.d.alsa.base.conf: 2016-06-06T05:53:22.078529

richard7893 (richard7893) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
tags: added: cosmic
Changed in pulseaudio (Ubuntu):
status: New → Confirmed

I had the same problem on 2 computers with same chipset.

Russell Treleaven helped me on Alsa bugtracker : https://gitlab.freedesktop.org/pulseaudio/pulseaudio/issues/617
He found that when Pulseaudio Capture level is more than 21%, Line boost, Mic Boost and Internal Mic Boost are always at Max in Alsamixer and then, nothing is recorded.
With Alsamixer or Pavucontrol, it's possible to set correctly all levels and to activate Capture 0 and Capture 1.

But each time I'm using again Linux Mint MATE or Ubuntu sound control panel, if I put Pulseaudio Capture level at more than 21%, capture doesn't work anymore again !

description: updated
tags: removed: cosmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers