Ubuntu

Java crashed when running under padsp

Reported by Alexander Rødseth on 2007-10-29
2
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

There is really only one Java-program I use regularly, and that is Cgoban3 (http://files.gokgs.com/javaBin/cgoban.jnlp).
It's very stable, and I've used it for several years without a hitch.

But, after switching to pulseaudio, I found out I have to run java (or "javaws", like in this case) with padsp in order to get any sound.

Here's the message I got on the commandline when java+Cgoban3 just disappeared:
java: pulsecore/memblock.c:315: pa_memblock_unref: Assertion `pa_atomic_load(&b->_ref) > 0' failed.

Before the crash, I watched a video in Firefox that uses flash that in turn uses the pulseaudio flashsupport so-file that I have installed on my system (which works perfectly fine, btw).
I don't really think that has anything to do with it, though, since I've watched videos in my browser before without anything strange happening to the sound.

Steps I did to produce the crash (which I'm unable to reproduce, unfortunately):
1. Start Cgoban3
2. Watch a flash-video in Firefox with the pulseaudio flash-support library installed (like this one: http://www.youtube.com/watch?v=teMlv3ripSM)
3. Return to Cgoban3 and make it produce a sound
4. Everything should disappear

(Java, flash and cgoban3 are about the only non-open source programs I use on my computer, just for the record ;) )

~% java -version
java version "1.6.0_03"
Java(TM) SE Runtime Environment (build 1.6.0_03-b05)
Java HotSpot(TM) Client VM (build 1.6.0_03-b05, mixed mode, sharing)

From "about:plugins":
    Filnavn: /usr/lib/firefox/plugins/libflashplayer.so
    Shockwave Flash 9.0 r48

~% du -b /usr/lib/libflashsupport.so
15876 /usr/lib/libflashsupport.so

Here's how I run Cgoban3 with the downloaded "cgoban.jnlp" file (http://files.gokgs.com/javaBin/cgoban.jnlp)
padsp javaws cgoban.jnlp

This page has been my guide for setting up pulseaudio:
http://www.pulseaudio.org/wiki/PerfectSetup

Daniel T Chen (crimsun) wrote :

Please see if you can reproduce this symptom in Hardy Alpha 1.

Changed in pulseaudio:
status: New → Incomplete
Alexander Rødseth (alexanro) wrote :

I'll see if I can get around to install Hardy Alpha 1. I use the current install in connection with my work, so it's hard for me to switch over just like that. A plain upgrade to Hardy will probably fail since I've installed some drivers manually.

Other than that, I can report that I've experienced this bug several time. Cgoban has disappeared a total of four times by now. The last time it disappeared, I had started two KDE program in the meantime (kbluetoothd and konqueror) and artsd showed a message saying "cpu overload". Very strange. I don't usually use KDE programs at all and Cgoban still have problems in connection with pulseaudio, so this can't be the fault of artsd, I think.

Anyways, the problem persists here, and I'm unable to try it on Hardy for the time being, but someone else might have that opportunity?

Daniel T Chen (crimsun) wrote :

Alexander, which sound driver is being used? (There's at least one documented issue of an ALSA bug, now fixed, in the ens17xx drivers directly linked to that artsd error.)

Alexander Rødseth (alexanro) wrote :

Here's the information I could dig up about alsa.
Cgoban3 still disappears some times in connection with opening links by clicking on them in Cgoban, but I haven't experienced this sound-problem since I upgraded to Hardy.
Unless someone else experiences this problem in Hardy, I guess we could close it and call it fixed. Yay. :)

Alexander Rødseth (alexanro) wrote :

I guess it's probably safe to close this bug now - works for me. Thanks to the people that fixed it. :-)

Luke Yelavich (themuso) wrote :

Just to clarrify, its working for you in Hardy?

I haven't experienced the crash lately, but I'm not sure if it's my
adjusted behavior or if the crash is fixed.

I will need to double-check by viewing a webpage with flash/audio at
the exact time of getting sound in Cgoban3/Java. I'll try it and then
drop another comment here. Most likely, the bug is fixed.

Alexander Rødseth (alexanro) wrote :

Tested sound with a flash video in the browser and Cgoban3 making sound at the same time. It didn't crash and seems solid now.

I say we declare the bug as fixed. Thanks to the people involved! :)

Alexander Rødseth (alexanro) wrote :

Forgot to say that I've switched over to Hardy Heron now. Thumbs up.

Luke Yelavich (themuso) wrote :

Closing based on comments from affected users that all is well in Hardy.

Changed in pulseaudio:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments