Music playback does not re-route audio when Bluetooth speaker connected/disconnected

Bug #1363083 reported by Richard Huddie on 2014-08-29
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Critical
Ricardo Salveti
ubuntu-touch-session (Ubuntu)
Undecided
Unassigned

Bug Description

krillin ubuntu-rtm/14.09-proposed build 4.
bluez 4.101-0ubuntu19 armhf

SUMMARY:
When a Bluetooth speaker is connected/disconnected to the krillin, the music playback route does not automatically update to accomodate this. The music app must be re-started for the new configuration to work.

STEPS:
1) Pair and connect the Bluetooth speaker (BQ Altavoz Bluetooth Strauss)
2) Start music playback
3) Disconnect the Bluetooth speaker on krillin from the Bluetooth settings

EXPECTED RESULT:
The music should play back through the Bluetooth speaker until it is disconnected. When the speaker is disconnected it should revert to using the krillin loud speaker.

ACTUAL RESULT:
The music plays back through the Bluetooth speaker until it is disconnected. When the speaker is disconnected, there is no music heard from the krillin. The music app is still playing the track as the progress bar is still updating, but there is no sound.

When the music app is re-started, music will play through the krillin loud speaker.

NOTES:
The same problem is observed for the opposite situation where a Bluetooth speaker is connected to the device when it is already playing music through the krillin loud speaker. The Bluetooth speaker will only be used once the music app is restarted.

Changed in bluez (Ubuntu):
status: New → Triaged
Michael Frey (mfrey) on 2014-09-16
Changed in bluez (Ubuntu):
status: Triaged → Confirmed
I Ahmad (iahmad) on 2014-09-17
Changed in bluez (Ubuntu):
importance: High → Critical
Michael Frey (mfrey) on 2014-09-22
Changed in bluez (Ubuntu):
assignee: nobody → Ricardo Salveti (rsalveti)
tags: added: touch-10-09
Michael Frey (mfrey) on 2014-09-23
tags: added: touch-2014-10-09
removed: touch-10-09
affects: bluez (Ubuntu) → pulseaudio (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-touch-session (Ubuntu):
status: New → Confirmed
Ricardo Salveti (rsalveti) wrote :
Changed in pulseaudio (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntu-touch-session (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-touch-session - 0.108+14.10.20141008-0ubuntu1

---------------
ubuntu-touch-session (0.108+14.10.20141008-0ubuntu1) utopic; urgency=low

  [ Ricardo Salveti de Araujo ]
  * touch.pa: fixing loading order and adding default devices (LP:
    #1363083)
 -- Ubuntu daily release <email address hidden> Wed, 08 Oct 2014 05:12:22 +0000

Changed in ubuntu-touch-session (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:4.0-0ubuntu22

---------------
pulseaudio (1:4.0-0ubuntu22) utopic; urgency=medium

  * 0211-module-stream-restore-use-entry_write-when-filling-u.patch =>
    0108-module-stream-restore-use-entry_write-when-filling-u.patch:
    - Renaming as it was accepted upstream
  * 0212-libpulse.vapi-adding-missing-fields-for-sink_input-s.patch:
    - Patch sent upstream, adding link to the thread
  * 0207-Enable-pulseaudio-droid.patch:
    - Fixing route when adding/removing devices (LP: #1363083)
 -- Ricardo Salveti de Araujo <email address hidden> Wed, 08 Oct 2014 02:01:14 -0300

Changed in pulseaudio (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers