Ubuntu

Pulseaudio crash with AMD 7870 XT hdmi

Reported by pnael on 2013-02-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Since I installed the new 7870 XT card (Tahiti based) I had no more sound.

I use the beta AMD drivers for display (steam user).
nael@zeus-linux:~$ dpkg -l | grep fgl
ii fglrx-amdcccle-experimental-9 2:9.010-0ubuntu0.3 Catalyst Control Center for the AMD graphics accelerators
ii fglrx-experimental-9 2:9.010-0ubuntu0.3 Experimental AMD binary Xorg driver and kernel module

Pulseaudio is crashing when I log :

Feb 10 18:44:12 zeus-linux kernel: [ 28.660722] Process pulseaudio (pid: 2172, ti=ec8ca000 task=edb29960 task.ti=ec8ca000)
Feb 10 18:44:12 zeus-linux kernel: [ 28.660723] Stack:
Feb 10 18:44:12 zeus-linux kernel: [ 28.660724] f8a07b73 00000080 ee7cb438 edb4cac0 ee61ee2c ee7cb400 edadb900 ec8cbd88
Feb 10 18:44:12 zeus-linux kernel: [ 28.660728] 00000000 edb29960 ec8cbd54 f8a47fc3 ec8cbd48 edadb900 ee7a0600 00000000
Feb 10 18:44:12 zeus-linux kernel: [ 28.660732] ec8cbd98 f8a480aa ec8cbd88 00000000 00000000 ee7a06f4 ee855000 ee7a06e0
Feb 10 18:44:12 zeus-linux kernel: [ 28.660736] Call Trace:
Feb 10 18:44:12 zeus-linux kernel: [ 28.660740] [<f8a07b73>] ? azx_pcm_open+0x1d3/0x280 [snd_hda_intel]
Feb 10 18:44:12 zeus-linux kernel: [ 28.660746] [<f8a47fc3>] snd_pcm_open_substream+0x53/0x90 [snd_pcm]
Feb 10 18:44:12 zeus-linux kernel: [ 28.660749] [<f8a480aa>] snd_pcm_open+0xaa/0x250 [snd_pcm]
Feb 10 18:44:12 zeus-linux kernel: [ 28.660753] [<c1054130>] ? try_to_wake_up+0x190/0x190
Feb 10 18:44:12 zeus-linux kernel: [ 28.660758] [<f8936044>] ? snd_lookup_minor_data+0x44/0x70 [snd]
Feb 10 18:44:12 zeus-linux kernel: [ 28.660762] [<f8a48302>] snd_pcm_playback_open+0x42/0x60 [snd_pcm]
Feb 10 18:44:12 zeus-linux kernel: [ 28.660766] [<f8936554>] snd_open+0xd4/0x260 [snd]
Feb 10 18:44:12 zeus-linux kernel: [ 28.660769] [<c138857c>] ? kobj_lookup+0xfc/0x1a0
Feb 10 18:44:12 zeus-linux kernel: [ 28.660772] [<c1149175>] chrdev_open+0xb5/0x1e0
Feb 10 18:44:12 zeus-linux kernel: [ 28.660775] [<c114317e>] __dentry_open+0x25e/0x310
Feb 10 18:44:12 zeus-linux kernel: [ 28.660777] [<c11490c0>] ? cdev_put+0x20/0x20
Feb 10 18:44:12 zeus-linux kernel: [ 28.660779] [<c11436fa>] vfs_open+0x3a/0x50
Feb 10 18:44:12 zeus-linux kernel: [ 28.660781] [<c1144629>] nameidata_to_filp+0x39/0x40
Feb 10 18:44:12 zeus-linux kernel: [ 28.660784] [<c1151b57>] do_last+0x367/0x660
Feb 10 18:44:12 zeus-linux kernel: [ 28.660785] [<c1152e84>] path_openat+0xa4/0x350
Feb 10 18:44:12 zeus-linux kernel: [ 28.660789] [<c117cc04>] ? fsnotify_put_event+0x44/0x60
Feb 10 18:44:12 zeus-linux kernel: [ 28.660791] [<c117cc04>] ? fsnotify_put_event+0x44/0x60
Feb 10 18:44:12 zeus-linux kernel: [ 28.660793] [<c1153241>] do_filp_open+0x31/0x80
Feb 10 18:44:12 zeus-linux kernel: [ 28.660796] [<c12b8e68>] ? strncpy_from_user+0x38/0x70
Feb 10 18:44:12 zeus-linux kernel: [ 28.660798] [<c115e863>] ? alloc_fd+0xa3/0xe0
Feb 10 18:44:12 zeus-linux kernel: [ 28.660800] [<c114471d>] do_sys_open+0xed/0x210
Feb 10 18:44:12 zeus-linux kernel: [ 28.660804] [<f893b3c0>] ? snd_ctl_elem_add_user+0x70/0x70 [snd]
Feb 10 18:44:12 zeus-linux kernel: [ 28.660806] [<c114486e>] sys_open+0x2e/0x40
Feb 10 18:44:12 zeus-linux kernel: [ 28.660810] [<c15af55f>] sysenter_do_call+0x12/0x28
Feb 10 18:44:12 zeus-linux kernel: [ 28.660811] Code: Bad EIP value.
Feb 10 18:44:12 zeus-linux kernel: [ 28.660813] EIP: [<00000000>] 0x0 SS:ESP 0068:ec8cbd14
Feb 10 18:44:12 zeus-linux kernel: [ 28.660816] CR2: 0000000000000000
Feb 10 18:44:12 zeus-linux kernel: [ 28.660818] ---[ end trace 9f2b0942f6c31f6f ]---

The workaround I used is to disable to automatic module loading in /etc/pulse/default.pa.
It works now with the workaround.

nael@zeus-linux:/var/log$ lsb_release -rd
Description: Ubuntu 12.04.2 LTS
Release: 12.04

nael@zeus-linux:/var/log$ apt-cache policy pulseaudio
pulseaudio:
  Installé : 1:1.1-0ubuntu15.2
  Candidat : 1:1.1-0ubuntu15.2
 Table de version :
 *** 1:1.1-0ubuntu15.2 0
        500 http://mir2.ovh.net/ubuntu/ precise-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:1.1-0ubuntu15 0
        500 http://mir2.ovh.net/ubuntu/ precise/main i386 Packages
        500 http://archive.ubuntu.com/ubuntu/ precise/main i386 Packages

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: pulseaudio 1:1.1-0ubuntu15.2
ProcVersionSignature: Ubuntu 3.2.0-37.58-generic-pae 3.2.35
Uname: Linux 3.2.0-37-generic-pae i686
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: i386
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/controlC1', '/dev/snd/hwC1D0', '/dev/snd/pcmC1D3p', '/dev/snd/pcmC1D7p', '/dev/snd/pcmC1D8p', '/dev/snd/pcmC1D9p', '/dev/snd/by-path', '/dev/snd/by-id', '/dev/snd/controlC2', '/dev/snd/pcmC2D0c', '/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/pcmC0D1p', '/dev/snd/pcmC0D2c', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe8f8000 irq 43'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,1043829f,00100002'
   Controls : 45
   Simple ctrls : 21
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xfe9fc000 irq 44'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100300'
   Controls : 0
   Simple ctrls : 0
Card1.Amixer.values:

Card2.Amixer.info:
 Card hw:2 'Exchange'/'Guillemot Corporation Hercules Dualpix Exchange at usb-0000:00:1a.7-3, high spe'
   Mixer name : 'USB Mixer'
   Components : 'USB06f8:3005'
   Controls : 2
   Simple ctrls : 1
Card2.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 3328
   Mono: Capture 0 [0%] [18.00dB] [on]
Date: Tue Feb 12 12:12:47 2013
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: pulseaudio
UpgradeStatus: Upgraded to precise on 2012-05-01 (286 days ago)
dmi.bios.date: 10/14/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1201
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5K
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1201:bd10/14/2008:svnSystemmanufacturer:pnP5K:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5K:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5K
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
modified.conffile..etc.pulse.default.pa: [modified]
mtime.conffile..etc.pulse.default.pa: 2013-02-12T11:57:02.065763

pnael (philippe-nael) wrote :
Raymond (superquad-vortex2) wrote :

Default sample spec: s16le 2ch 44100Hz
Default channel map: front-left,front-right
Default sink name: alsa_output.default
Default source name: alsa_input.hw_0_0

post the pulseaudio log

https://wiki.ubuntu.com/PulseAudio/Log

and

your modified default.pa

pnael (philippe-nael) wrote :

Please find he modified default.pa attached. Basically, I stopped automatic module loading.

pnael (philippe-nael) wrote :

Please find attached the pulseaudio log file.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pulseaudio (Ubuntu):
status: New → Confirmed
Raymond (superquad-vortex2) wrote :

[ 8.969179] Too many HDMI devices
[ 8.969181] Too many HDMI devices
[ 8.969182] Too many HDMI devices
[ 8.969183] Too many HDMI devices
[ 8.969184] Too many HDMI devices
[ 8.969184] Too many HDMI devices
[ 8.969185] Too many HDMI devices
[ 8.969186] Too many HDMI devices
[ 8.969276] hda-codec: out of range cmd 0:0:8c34:707:0
[ 8.969278] hda-codec: out of range cmd 0:0:8c34:708:85
[ 8.969517] hda-codec: out of range cmd 0:0:8c34:f00:c
[ 8.969518] hda-codec: out of range cmd 0:0:8c34:709:0
[ 8.969520] hda-codec: out of range cmd 0:0:8c34:f09:0
[ 8.969582] HDMI status: Codec=0 Pin=3 Presence_Detect=0 ELD_Valid=0
[ 8.969599] HDMI status: Codec=0 Pin=5 Presence_Detect=0 ELD_Valid=0
[ 8.969617] HDMI status: Codec=0 Pin=7 Presence_Detect=0 ELD_Valid=0
[ 8.969637] HDMI status: Codec=0 Pin=9 Presence_Detect=0 ELD_Valid=0
[ 8.969659] HDMI status: Codec=0 Pin=35892 Presence_Detect=1 ELD_Valid=1
[ 8.969660] hda-codec: out of range cmd 0:0:8c34:f2e:8
[ 8.969662] hda_codec: cannot build controls for #0 (error -16)

try latest alsa driver

Your Radeon HD 7870 have 6 hdmi convertors and pin complexes

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions