No sound on Dell XPS after suspend (ALC275)

Bug #1066488 reported by Michael on 2012-10-14
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Dell XPS One 2710, Ubuntu 12.04, Kernel 3.2.0.31 or 3.2.0.32 or 3.6.2

Sound works out of the box, until machine is supended to RAM. After suspend and resume, no sound at all.

A suspend to Disk and resume restores sound!

aplay -l:
Karte 0: PCH [HDA Intel PCH], Gerät 0: ALC275 Analog [ALC275 Analog]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: PCH [HDA Intel PCH], Gerät 3: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

lsmod|grep snd:
snd_hda_codec_hdmi 32506 1
snd_hda_codec_realtek 79668 1
snd_hda_intel 34147 3
snd_hda_codec 135374 3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 13668 1 snd_hda_codec
snd_pcm 97661 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_timer 29989 1 snd_pcm
snd 79391 13 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore 15091 1 snd
snd_page_alloc 18572 2 snd_hda_intel,snd_pcm

It is NOT possible to unload snd modules.

sudo /sbin/alsa force-unload:
Unloading ALSA sound driver modules: snd-hda-codec-hdmi snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-seq-midi snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc
(failed: modules still loaded: snd-hda-codec-hdmi snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-timer snd-page-alloc).

All information in the net either is depreciated (using acpi_suspend) or refers to chips that have options (e.g. modprobe snd_hda_intel option=acer). There is NO documentation about options of the ALC275 chip.

Anybody has a solution to this?

Thanks

Michael

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pulseaudio (Ubuntu):
status: New → Confirmed
Mauro (jasmines) wrote :

Same here on 12.10.
I'm on a HP 6730s.

sudo lshw output: http://pastebin.com/vh3SGcZa

Can't sudo modprobe -r snd_hda_intel. It gives FATAL: Module snd_hda_intel is in use

/etc/modprobe.d/alsa-base.conf content: http://pastebin.com/yvArB2ex

In /var/log/syslog I found the following:

kernel: [ 33.847111] pci_pm_runtime_suspend(): azx_runtime_suspend+0x0/0x40 [snd_hda_intel] returns -11

Michael (auslands-kv) wrote :

Just a small update:

Tried kernel 3.7.1, 3.7.2 and 3.8.0-rc3, all with the same result.

It seems there is no chance to get sound working after suspend on ALC275 systems :-(

Raymond (superquad-vortex2) wrote :

post the output of alsa-info.sh before suspend and after resume

diff -u before_suspend_info.txt after_resume_info.txt

https://wiki.ubuntu.com/Audio/AlsaInfo

Afro (amilan-inlogic) wrote :

Please see my diff from your recommended command.

Michael (auslands-kv) wrote :

Hello

good to see that someone is taking care of this bug.

I attached the requested diff.

Hope we can fix it.

Cheers,

Michael

Raymond (superquad-vortex2) wrote :

>kernel: [ 33.847111] pci_pm_runtime_suspend(): azx_runtime_suspend+0x0/0x40 [snd_hda_intel] returns -11

can you post those messages in the system log during the suspend and resume ?

Michael (auslands-kv) wrote :

I guess we probably have two different problems here. I don't have any of these azx_runtime_suspend messages that Mauro has.

I attach alsa-info-after-suspend (which also contains some syslog messages).

Tell me, if you need anything more. I really want to get sound working after suspend.

Thanks

Michael

Raymond (superquad-vortex2) wrote :

both of you only posted the diff

please post the output of alsa-info

Afro (amilan-inlogic) wrote :

Hi Raymond,
see before and after outputs.

Afro (amilan-inlogic) wrote :
Raymond (superquad-vortex2) wrote :

Afro

your alsa-info are missing the output of alsactl which show the state of Jack detecting

Afro (amilan-inlogic) wrote :

Hi Raymond,
i did with alsactl option.

Afro (amilan-inlogic) wrote :
Michael (auslands-kv) wrote :

Please find attached alsa-info-before-suspend.

For alsa-info after suspend please see #8.

Thanks

MIchael

Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu.
Ubuntu 12.04 (precise) reached end-of-life on April 28, 2017.

See this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We appreciate that this bug may be old and you might not be interested in discussing it any more. But if you are then please upgrade to the latest Ubuntu version and re-test.

Changed in pulseaudio (Ubuntu):
status: Confirmed → Incomplete
Jim Hargrove (jhargrove) wrote :

Hi, Daniel,

Appears to be fixed entirely now. I was running Ubuntu 12.04 when I first encountered the bug, and if memory serves it was fixed at least a year or two ago. I'm currently running 16.04.

Thanks for responding.

Launchpad Janitor (janitor) wrote :

[Expired for pulseaudio (Ubuntu) because there has been no activity for 60 days.]

Changed in pulseaudio (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers