ptouch-driver version 1.3-0ubuntu10 failed to build in oneiric

Bug #829446 reported by Matthias Klose on 2011-08-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
foomatic-db (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
ptouch-driver (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

ptouch-driver version 1.3-0ubuntu10 failed to build in oneiric
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2708874

Details about the rebuild:
http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20110816-oneiric.html

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2708874/+files/buildlog_ubuntu-oneiric-i386.ptouch-driver_1.3-0ubuntu10_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Source-dependencies not satisfied'.
Excerpt 637 lines into the build log:

Setting up libgpg-error-dev (1.10-0.3ubuntu1) ...
Setting up libgcrypt11-dev (1.5.0-1) ...
Setting up zlib1g-dev (1:1.2.3.4.dfsg-3ubuntu3) ...
Setting up libtasn1-3-dev (2.9-4) ...
Setting up libgnutls-dev (2.10.5-1ubuntu2) ...
Setting up libkrb5-dev (1.9.1+dfsg-1ubuntu1) ...
Setting up libcups2-dev (1.5.0-2) ...
Setting up libpng12-dev (1.2.46-3ubuntu1) ...
Setting up libjpeg62-dev (6b1-1ubuntu2) ...
Setting up libtiff4-dev (3.9.5-1ubuntu1) ...
Setting up libcupsimage2-dev (1.5.0-2) ...
Setting up quilt (0.48-7) ...
Setting up pyppd (0.4.9-2.1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Checking correctness of source dependencies...
After installing, the following source dependencies are still unsatisfied:
foomatic-db-compressed-ppds(still installed)
Source-dependencies not satisfied; skipping ptouch-driver

Matthias Klose (doko) on 2011-08-19
Changed in ptouch-driver (Ubuntu):
importance: Undecided → High
Matthias Klose (doko) on 2011-08-19
Changed in ptouch-driver (Ubuntu):
status: New → Invalid
Matthias Klose (doko) on 2011-08-19
Changed in ptouch-driver (Ubuntu Oneiric):
milestone: none → ubuntu-11.10-beta-1
status: Invalid → Confirmed
Till Kamppeter (till-kamppeter) wrote :

The foomatic-db package was in Universe and therefore not found by buildds. Moved it back to Main.

Changed in foomatic-db (Ubuntu Oneiric):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ptouch-driver - 1.3-0ubuntu11

---------------
ptouch-driver (1.3-0ubuntu11) oneiric; urgency=low

  * debian/control: Versioned build dependency on foomatic-db to assure that
    the Ubuntu build server installs the physical package foomatic-db and
    not foomatic-db-compressed-ppds which only provides foomatic-db
    (LP: #829446).
  * debian/rules, debian/control: Compress PPD files with pyppd.
  * debian/rules, debian/control, debian/postinst,
    debian/ptouch-driver.ppd-updater: Let automatic update of the PPDs of
    already existing print queues be done by CUPS.
 -- Till Kamppeter <email address hidden> Sat, 20 Aug 2011 00:37:23 +0200

Changed in ptouch-driver (Ubuntu Oneiric):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers