Upgrade printer-driver-ptouch to support Brother QL-570

Bug #1604036 reported by Pander on 2016-07-18
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
hwdata (Ubuntu)
Medium
Unassigned
Xenial
Undecided
Unassigned
ptouch-driver (Ubuntu)
Medium
Unassigned
Xenial
Undecided
Unassigned
usbutils (Ubuntu)
Medium
Unassigned
Xenial
Undecided
Unassigned

Bug Description

Please, upgrade printer-driver-ptouch to support Brother QL-570 P-touch Label Printer. See https://bitbucket.org/philpem/printer-driver-ptouch/issues/2/negativeprint-and-cutmedia-jobend-doesnt (motivate maintainers of printer-driver-ptouch to bump their version number and release a version that supports QL-570) and also upgrade usbutils to include https://usb-ids.gowdy.us/read/UD/04f9/2028

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ptouch-driver (Ubuntu):
status: New → Confirmed
Till Kamppeter (till-kamppeter) wrote :

For the usb.ids problem I added usbutils, hwdata, and libosinfo tasks, as according to "dpkg -S usb.ids" they all provide an usb.ids file.

Changed in libosinfo (Ubuntu):
status: New → Confirmed
Changed in hwdata (Ubuntu):
status: New → Confirmed
Changed in usbutils (Ubuntu):
status: New → Confirmed
Till Kamppeter (till-kamppeter) wrote :

OdyX, can you update ptouch-driver to the newest version, to include the fix? Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ptouch-driver - 1.4-5-gf4ad445-1

---------------
ptouch-driver (1.4-5-gf4ad445-1) unstable; urgency=medium

  * New upstream snapshot
    - Add support for Brother QL-570 (LP: #1604036)

 -- Didier Raboud <email address hidden> Thu, 21 Jul 2016 07:38:59 +0200

Changed in ptouch-driver (Ubuntu):
status: Confirmed → Fix Released
Changed in usbutils (Ubuntu):
importance: Undecided → Medium
Changed in libosinfo (Ubuntu):
importance: Undecided → Medium
Changed in hwdata (Ubuntu):
importance: Undecided → Medium
Changed in ptouch-driver (Ubuntu):
importance: Undecided → Medium
Phil Pemberton (philpem) wrote :

Upstream version bumped to 1.4.1.

Be advised that there's an open ticket on QL-570 support: https://bitbucket.org/philpem/printer-driver-ptouch/issues/2/negativeprint-and-cutmedia-jobend-doesnt

Main issue is that media cutting apparently doesn't work 100% as described on QL printers. Unless/until I can get a QL570 (or someone lets me borrow one for a while), debugging this might be tricky.

Pander (pander) wrote :

Thanks. Already two people have offert their support for debugging that issue on such a printer they own. Hopefully, that can be tackled soon too.

Phil Pemberton (philpem) wrote :

I've managed to source a slightly-used QL-570 for a more reasonable price, along with (apparently) five rolls of labels. That should be arriving "soon-ish".

I'll have a look at the driver when I get a spare moment. As I've said on the upstream ticket, the negative-print bug looks like the thing losing track of a buffer and may be tricky to debug.

Phil Pemberton (philpem) wrote :

I've just released version 1.4.2 which fixes the two QL-570 bugs raised by Ladislav Laska.

Bug #1607917 open to (hopefully) get the upstream packages updated.

Jeremy Bicha (jbicha) wrote :

Till, I don't think this bug has anything to do with libosinfo.

Changed in libosinfo (Ubuntu):
status: Confirmed → Incomplete
Changed in libosinfo (Ubuntu Xenial):
status: New → Incomplete
Changed in ptouch-driver (Ubuntu Xenial):
status: New → Triaged
Pander (pander) on 2016-10-25
tags: added: zesty
Jeremy Bicha (jbicha) on 2016-12-22
no longer affects: libosinfo (Ubuntu)
no longer affects: libosinfo (Ubuntu Xenial)
Pander (pander) on 2018-05-02
tags: added: bionic
Pander (pander) on 2018-05-06
tags: added: cosmic
removed: xenial yakkety zesty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers