Ubuntu

ftbfs with python2.7

Reported by Matthias Klose on 2010-12-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
psyco (Ubuntu)
High
Barry Warsaw
Natty
High
Barry Warsaw

Bug Description

http://launchpadlibrarian.net/60074802/buildlog_ubuntu-natty-i386.psyco_1.6-2build1_FAILEDTOBUILD.txt.gz

building 'psyco._psyco' extension
creating build/temp.linux-i686-2.7
creating build/temp.linux-i686-2.7/c
gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -O2 -fPIC -DALL_STATIC=1 -Ic/i386 -I/usr/include/python2.7 -c c/psyco.c -o build/temp.linux-i686-2.7/c/psyco.o
In file included from c/initialize.h:55:0,
                 from c/psyco.c:14:
c/mergepoints.c:242:3: error: 'JUMP_IF_FALSE' undeclared here (not in a function)
c/mergepoints.c:242:3: error: 'JUMP_IF_TRUE' undeclared here (not in a function)
In file included from c/initialize.h:78:0,
                 from c/psyco.c:14:
c/Objects/compactobject.c: In function 'compacttype_new':
c/Objects/compactobject.c:883:3: warning: dereferencing type-punned pointer will break strict-aliasing rules
c/Objects/compactobject.c: In function 'psyco_compact_init':
c/Objects/compactobject.c:1027:2: warning: dereferencing type-punned pointer will break strict-aliasing rules
c/Objects/compactobject.c:1030:2: warning: dereferencing type-punned pointer will break strict-aliasing rules
c/psyco.c: In function 'init_psyco':
c/psyco.c:1023:3: warning: dereferencing type-punned pointer will break strict-aliasing rules
c/psyco.c: At top level:
c/codegen.c:127:19: warning: 'psyco_source_condition' defined but not used
c/codegen.c:747:10: warning: 'integer_lshift' defined but not used
c/Objects/plistobject.c:115:10: warning: 'PsycoList_SingletonNew' defined but not used
error: command 'gcc' failed with exit status 1
make: *** [build-stamp-2.7] Error 1

Matthias Klose (doko) on 2010-12-04
Changed in psyco (Ubuntu):
importance: Undecided → High
milestone: none → natty-alpha-2
status: New → Confirmed
Matthias Klose (doko) wrote :

these bytecodes don't exist anymore. opcode.h:

-#define JUMP_IF_FALSE 111 /* "" */
-#define JUMP_IF_TRUE 112 /* "" */
-#define JUMP_ABSOLUTE 113 /* Target byte offset from beginning of code */
+
+#define JUMP_IF_FALSE_OR_POP 111 /* Target byte offset from beginning
+ of code */
+#define JUMP_IF_TRUE_OR_POP 112 /* "" */
+#define JUMP_ABSOLUTE 113 /* "" */
+#define POP_JUMP_IF_FALSE 114 /* "" */
+#define POP_JUMP_IF_TRUE 115 /* "" */

Bilal Akhtar (bilalakhtar) wrote :

I made an attempt to fix this bug by renaming the contants in the files, but it didn't work. I am getting the same error again and again, even though I am using the proper constant name (JUMP_IF_FALSE_OR_POP).

Colin Watson (cjwatson) wrote :

Upstream development status seems unclear. There were some commits related to Python 2.7 in February, and a branch for this, but nothing since then.

  http://codespeak.net/svn/psyco/branch/py27/

Barry Warsaw (barry) wrote :

Discussion on #python-dev follows

voidspace == Michael Foord
__ap__ == Antoine Pitrou

<voidspace> barry: pretty much won't happen
<voidspace> barry: at least Armin Rigo won't do it [12:09]
<__ap__> isn't ctismer supposed to work on reviving psyco?
<voidspace> barry: and I don't know the state of Christian Tismer's help at
            the moment - but as far as I *know* no-one is funding him to do it
<__ap__> not that I'm expecting much...
<voidspace> __ap__: he *was*
<voidspace> I don't know about current status
<voidspace> I do know that psyco *doesn't* work with 2.7
<__ap__> psyco is supposed to be unmaintainable and a quick look at the source
         code suggested itw as true :)

I think therefore the best we can do is block the package for Python 2.7. I'll work up a patch for that.

Barry Warsaw (barry) wrote :

From David Malcolm, re Fedora:

https://bugzilla.redhat.com/show_bug.cgi?id=620211

Yeah, psyco's a dead end.

Barry Warsaw (barry) on 2010-12-13
Changed in psyco (Ubuntu Natty):
assignee: nobody → Barry Warsaw (barry)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.