GPG support stopped working

Bug #52113 reported by Oliver Klee on 2006-07-06
6
Affects Status Importance Assigned to Milestone
psi (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: psi

I'm using Kubuntu Dapper i386 upgraded from Breezy on an AMD Athlon 1400 MHz system with 1.5 GB of RAM and an Nvidia graphics card on an Asus A7A266 board.

For some time, I've been using PSI with GPG encryption for some contacts. Usually, PSI asks me first for my Jabber password and then for my GPG passphrase.

For some days now, PSI doesn't ask me for the GPG passphrase anymore, and the button for GPG encryption in the chat window is disabled. In my account setup (details), the complete section "OpenGPG" now is disabled. In addition, a message is displayed in that section: "Unknown key: 10BFA4E2" - which is not my key ID (= the last 4 bytes of my key fingerprint), but the 4 bytes before that.

Sending and receiving signed and encrypted messages still works fine using Thunderbird and Enigmail.

I case this is relevant: I'm usually running kgpg in the background.

In addition, bug 52112 popped up about the same time as this problem, but I'm not sure these problems really are related.

Is there any debug output I could provide to help narrow down the problem?

This definitely is related to bug 52112: After the removal of some keys from my GPG keyring, that bug doesn't occur anymore, and GPG works fine in PSI too.

Lucas Nussbaum (lucas) wrote :

marking fixed, since Oliver fixed it himself :-)

Changed in psi:
status: Unconfirmed → Fix Released

Actually, I haven't fixed the bug but just removed the broken key. GPG support in PSI should still work even if one GPG key (which is not the key used for encrypting Jabber communication) is broken.

LimCore (limcore) wrote :

I have only tow keys and they are not borken.

The bug still occures for me even now (2008-05) on Ubuntu 8.04 (amd64)

seems like the issue in
https://bugs.launchpad.net/ubuntu/+source/psi/+bug/224906

LimCore (limcore) wrote :

Bug exists in ubuntu 8.04

Changed in psi:
status: Fix Released → Confirmed
Andreas Olsson (andol) wrote :

Is this still an issue for anyone? The substantially newer libqca2-plugin-gnupg in Ubuntu 9.10 should have taken care of a lot of Psi gnupg issues.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers