fails to build on all platforms other than 386

Bug #262665 reported by Elliot Murphy
4
Affects Status Importance Assigned to Milestone
protobuf (Ubuntu)
Undecided
Unassigned

Bug Description

This is because the source package has

Build-Depends-Indep: python-support (>= 0.6)

and it apparently should be listed under Build-Depends: instead. I am attaching a patch.

Related branches

Revision history for this message
Elliot Murphy (statik) wrote :
Revision history for this message
Elliot Murphy (statik) wrote :

Ok, attached is a debdiff containing the build fix, and updating Maintainer and Debian-Maintainer per https://wiki.ubuntu.com/DebianMaintainerField.

Revision history for this message
Elliot Murphy (statik) wrote :

Setting to Confirmed and subscribing ubuntu-universe-sponsors per guidelines here: https://wiki.ubuntu.com/MOTU/Contributing

Changed in protobuf:
status: New → Confirmed
Revision history for this message
Elliot Murphy (statik) wrote :

BTW, I'm new to this, and am trying to follow the right procedures, so if I've missed a step or could do something more efficiently, please let me know. I've got this fixed package building successfully in my own PPA here: https://launchpad.net/~statik/+archive

Revision history for this message
Daniel Holbach (dholbach) wrote :

It looks good and works for me. I'd just change a few bits in debian/changelog:
 - change to (LP: #262665) to get the bug automatically closed on upload
 - not mention the Maintainer change, we have to do it anyway for every upload where we differ from Debian

Thanks for your work on this.

Revision history for this message
Daniel Holbach (dholbach) wrote : Unsubscribing Sponsors.

I'm unsubscribing the Sponsors' Team for now.

Revision history for this message
Elliot Murphy (statik) wrote :

Thanks for the advice Daniel, sorry for the delay in responding.

I've reformatted the reference to the launchpad bug, and not mentioned the maintainer change. Updated debdiff is attached. resubscribing the Sponsors team.

Revision history for this message
Daniel Holbach (dholbach) wrote :

It's XSBC-Original-Maintainer instead of Debian-Maintainer (best use the 'update-maintainer' script in ubuntu-dev-tools) - Rationale: https://wiki.ubuntu.com/DebianMaintainerField. I quickly fixed it myself. Apart from that good work. Uploaded.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package protobuf - 2.0.0~b-3ubuntu1

---------------
protobuf (2.0.0~b-3ubuntu1) intrepid; urgency=low

  * Moving python-support from Build-Depends-Indep to Build-Depends to
    fix build failures. (LP: #262665)

 -- Elliot Murphy <email address hidden> Fri, 29 Aug 2008 04:40:28 -0400

Changed in protobuf:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers