package procps 1:3.2.8-11ubuntu2 failed to install/upgrade: start: Unknown parameter: UPSTART_EVENTS

Bug #891369 reported by Jari J. Lehtinen on 2011-11-16
76
This bug affects 12 people
Affects Status Importance Assigned to Milestone
procps (Ubuntu)
Critical
Martin Pitt
Precise
Critical
Martin Pitt

Bug Description

I was doing a partial distributiom upgade of xubuntu 12.04, while I got this error message. I was lead to launchpad automatically. I don't know anything more about this failure.

jallu@xamilo:~$ lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: procps 1:3.2.8-11ubuntu2
ProcVersionSignature: Ubuntu 3.1.0-2.3-generic 3.1.0
Uname: Linux 3.1.0-2-generic i686
ApportVersion: 1.26-0ubuntu1
Architecture: i386
Date: Wed Nov 16 23:27:24 2011
ErrorMessage: ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Xubuntu 9.10 "Karmic Koala" - Release i386 (20091026.3)
SourcePackage: procps
Title: package procps 1:3.2.8-11ubuntu2 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to precise on 2011-11-16 (0 days ago)

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in procps (Ubuntu):
status: New → Confirmed
Michael Bienia (geser) wrote :

The relevant error message from the log:

Setting up procps (1:3.2.8-11ubuntu2) ...
start: Unknown parameter: UPSTART_EVENTS
invoke-rc.d: initscript procps, action "start" failed.
dpkg: error processing procps (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 procps

Martin Pitt (pitti) wrote :

Marking critical because it breaks day-to-day upgrades, which we agreed to not do for extended time periods any more.

summary: - package procps 1:3.2.8-11ubuntu2 failed to install/upgrade:
- ErrorMessage: subprocess installed post-installation script returned
- error exit status 1
+ package procps 1:3.2.8-11ubuntu2 failed to install/upgrade: start:
+ Unknown parameter: UPSTART_EVENTS
Changed in procps (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Critical
Changed in procps (Ubuntu Precise):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
milestone: none → precise-alpha-1
assignee: Canonical Foundations Team (canonical-foundations) → Martin Pitt (pitti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package procps - 1:3.2.8-11ubuntu3

---------------
procps (1:3.2.8-11ubuntu3) precise; urgency=low

  * debian/upstart: Revert previous upload, breaks upgrades. (LP: #891369)
 -- Martin Pitt <email address hidden> Thu, 17 Nov 2011 06:04:10 +0100

Changed in procps (Ubuntu Precise):
status: Triaged → Fix Released
santosh (santoshkumarkonduri) wrote :

Unable to Upgrade Ubuntu machine.

oot@ubuntu:/home/user1# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  linux-headers-generic-lts-quantal linux-image-generic-lts-quantal
The following packages will be upgraded:
  procps
1 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
4 not fully installed or removed.
Need to get 0 B/235 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
Setting up procps (1:3.2.8-11ubuntu6) ...
start: Job failed to start
invoke-rc.d: initscript procps, action "start" failed.
dpkg: error processing procps (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of apport-gtk:
 apport-gtk depends on procps; however:
  Package procps is not configured yet.
dpkg: error processing apport-gtk (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of openvswitch-switch:
 openvswitch-switch depends on procps; however:
  Package procps is not configured yet.
dpkg: error processing openvswitch-switch (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of quantum-plugin-openvswitch-agent:
 quantum-plugin-openvswitch-agent depends on openvswitch-switch; however:
  Package openvswitch-switch is not configured yet.
dpkg: error processing quantum-plugin-openvswitch-agent (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 procps
 apport-gtk
 openvswitch-switch
 quantum-plugin-openvswitch-agent
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@ubuntu:/home/user1#

santosh (santoshkumarkonduri) wrote :

root@ubuntu:/home/user1# cat /etc/sysctl.d/*.conf /etc/sysctl.conf | sysctl -e -p -
kernel.printk = 4 4 1 7
net.ipv6.conf.all.use_tempaddr = 2
net.ipv6.conf.default.use_tempaddr = 2
kernel.kptr_restrict = 1
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.all.rp_filter = 1
net.ipv4.tcp_syncookies = 1
kernel.yama.ptrace_scope = 1
vm.mmap_min_addr = 65536
net.core.wmem_max = 1048576
net.core.rmem_max = 1048576
net.core.wmem_default = 1048576
net.core.rmem_default = 1048576
error: "Invalid argument" setting key "net.ipv4.tcp_mem"
net.ipv4.tcp_rmem = 1048576
net.ipv4.tcp_wmem = 1048576
net.ipv4.ip_forward = 1
root@ubuntu:/home/user1#

Rick Knowles (rick-knowleses) wrote :

Seems to be tied to the iscsitarget sysctl settings. These were previously fine, but something in the new kernel doesn't support the "net.ipv4.tcp_mem" property anymore.

Temporary fix is to comment that line out of the /etc/sysctl.d/30-iscsitarget.conf file (add a # at the beginning of line 7)

net.core.wmem_max=1048576
net.core.rmem_max=1048576
net.core.wmem_default=1048576
net.core.rmem_default=1048576
#net.ipv4.tcp_mem=1048576
net.ipv4.tcp_rmem=1048576
net.ipv4.tcp_wmem=1048576

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers