top crashes on window resize

Bug #24322 reported by Eamonn Sullivan on 2005-10-20
This bug report is a duplicate of:  Bug #19277: top crash with resize at mininum. Edit Remove
4
Affects Status Importance Assigned to Milestone
procps (Debian)
Fix Released
Unknown
procps (Ubuntu)
Medium
Michael Vogt

Bug Description

Resizing a terminal window while running top causes it to crash with:

*** glibc detected *** realloc(): invalid next size: 0x0806dad8 ***

This can take a few resizes to duplicate.

I forgot to add that this is in Breezy.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I was able to reproduce the problem. But it took quite a lot of resizing before
I was able to trigger it. And it dosn't happen when top runs inside a debugger.
Fun :)

It looks like http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=256376

Cheers,
 Michael

Vassilis Pandis (pandisv) wrote :

This still happens with 1:3.2.6-2ubuntu4, on Dapper.

Changed in procps:
status: Unconfirmed → Confirmed
Changed in procps:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.