/etc/rcS.d/S17procps.sh left after upgrade

Bug #228406 reported by hackel on 2008-05-08
10
Affects Status Importance Assigned to Milestone
procps (Ubuntu)
Low
Unassigned
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: procps

At some point /etc/rcS.d/S17procps.sh was renamed to /etc/rcS.d/S17procps, however the former was never removed from my system, leaving behind a broken symlink in /etc/rcS.d. I have just discovered this now (running Ubuntu 8.04), though I do not know at which point this change occurred.

Richard Seguin (sectech) wrote :

Thank you for reporting this issue, in order to triage this bug I need more information.

1) What version of gusty were you upgrading from? 32 bit or 64 bit?
2) What kind of hardware do you have?
3) How would I go about re-creating this bug? Is it just a straight upgrade from gusty?

Thanks in advance,

Changed in procps:
status: New → Incomplete
Richard Seguin (sectech) wrote :

Also could you please attach the files in /var/log/dist-upgrade to this bug report?

Thanks!

hackel (hackel) wrote :

As I said, I am not sure at what point this issue occurred. I've been running hardy (32-bit) for some time now. I only happened to notice the broken symlink by running a find over /etc. It doesn't actually cause any problems, since broken symlinks in /etc/rc*.d are just ignored.

I'm a bit confused as to what possible difference my hardware would make, but this machine is a Compaq M2105US. I haven't investigated re-creating the bug, and I can't even verify that the problem is still present in the current version. I realise that this is of almost no help at all in identifying the issue, I just wanted to get it documented. I'm sorry I don't have more information.

From /var/log/dist-upgrade/apt-term.log (and term.log):
Preparing to replace procps 1:3.2.7-3ubuntu5 (using .../procps_1%3a3.2.7-5ubuntu1_i386.deb) ...
Preparing to remove obsolete, unmodified conffile: /etc/init.d/procps.sh
`/etc/init.d/procps.sh' -> `/etc/init.d/procps.sh.from-preinst'
Unpacking replacement procps ...

Indeed, the /etc/init.d/procps.sh was removed, it's just the symlink in rcS.d that was not.

Mark Moore (mark-moore) wrote :

I can confirm that I had the same problem. To reproduce, you can start with the Grandma's LAMP[1] image and upgrade to hardy according to the steps documented here: http://www.ubuntu.com/getubuntu/upgrading

This error can be seen most easily with "ls --color -l /etc/rc?.d" and look for the red (broken link) entry.

I'm certain this bug can be reproduced when upgrading from any previous Ubuntu release that produces a hit for "dpkg-query -S '/etc/*/procps.sh'". That should be pretty easy to narrow in the change log.

-----
[1] http://canned-os.blogspot.com/2006/10/grandmas-lamp-its-easy-enough-for.html

Richard Seguin (sectech) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in procps:
status: Incomplete → Confirmed
Richard Seguin (sectech) on 2008-06-17
Changed in procps:
importance: Undecided → Low
status: Confirmed → Triaged
Adam Conrad (adconrad) wrote :

For the record, this happens on ALL upgrades, and is a result of us having moved the procps.sh start link from S30 (debian's default) to S17. The postinst attempts to remove S30procps.sh (as well as S05procps.sh, for historical reasons) on upgrade, which fails for Ubuntu:

       # Remove old procps init.d script, if it exists Closes: #55137
       if [ -L /etc/rcS.d/S30procps.sh ]
       then
          update-rc.d -f procps.sh remove >/dev/null
       fi
       # and if that didn't work Closes: #92184 (#234306 with -L )
       if [ -L /etc/rcS.d/S30procps.sh ]
       then
           rm -f /etc/rcS.d/S30procps.sh
       fi
       if [ -L /etc/rcS.d/S05procps.sh ]; then
           rm -f /etc/rcS.d/S05procps.sh
       fi

If one were to add S17procps.sh to this code block as well, it would solve the problem nicely for Ubuntu upgrades.

Adam Conrad (adconrad) wrote :

Here's a debdiff for hardy. I'm uploading the same change to intrepid in a few minutes.

Adam Conrad (adconrad) wrote :

For the record, while the impact of this bug is cosmetic at best, based on the number of subscribers, I suspect I'm not alone in finding rc?.d/* cruft a bit alarming and untidy in a dist-upgrade, hence the nomination for hardy.

Adam Conrad (adconrad) wrote :

Fixed in intrepid in version 3.2.7-8ubuntu2, and uploaded to hardy-proposed as version 3.2.7-5ubuntu3

Adam Conrad (adconrad) wrote :

This is the patch that was uploaded to hardy-proposed

Martin Pitt (pitti) wrote :

procps (1:3.2.7-8ubuntu2) intrepid; urgency=low

  * Remove rcS.d/S17procps.sh on upgrade, eliminating Ubuntu cruft.

 -- Adam Conrad < <email address hidden>> Mon, 30 Jun 2008 15:46:16 -0600

Changed in procps:
status: Triaged → Fix Released
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Adam Conrad (adconrad) wrote :

Well, I suspect I may be the only person "testing" this, but I can verify that it does the right thing on both upgrades and a clean install.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in procps:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers