free command not working with -s flag

Bug #1551731 reported by alireza kaftoosian on 2016-03-01
30
This bug affects 7 people
Affects Status Importance Assigned to Milestone
procps-ng
Fix Released
Unknown
procps (Ubuntu)
Medium
Unassigned

Bug Description

when i enter this command :
free -s 3
or and numbers for seconds , it returns me :
free: seconds argument `3' failed
but i have only this bug in version 3.3.10 and in 3.3.9 it worls normally and refresh free in entered seconds

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: procps 2:3.3.10-4ubuntu2
ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
Uname: Linux 4.4.0-8-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Mar 1 17:00:20 2016
InstallationDate: Installed on 2016-01-24 (36 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160123)
SourcePackage: procps
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in procps (Ubuntu):
status: New → Confirmed
Changed in procps (Ubuntu):
importance: Undecided → Medium
Changed in procps-ng:
status: Unknown → Fix Released
Brian Murray (brian-murray) wrote :

This is fixed in Zesty and later.

 procps | 2:3.3.12-1ubuntu2 | zesty | source, amd64, arm64, armhf, i386, ppc64el, s390x
 procps | 2:3.3.12-1ubuntu2 | artful | source, amd64, arm64, armhf, i386, ppc64el, s390x
 procps | 2:3.3.12-1ubuntu2 | bionic | source, amd64, arm64, armhf, i386, ppc64el, s390x

Changed in procps (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.