top loses track of processes when running a very long time

Bug #1506669 reported by Kevin O'Gorman on 2015-10-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
procps (Ubuntu)
Undecided
Unassigned

Bug Description

I have a pipeline of about 2 dozen commands that I expect will run for 2-3 weeks, with top running concurrently in another window. They are compute-intensive, and there is always at least one one that is running and sometimes more. In spite of this after several days, top stopped reporting any of them, whether or not I have top showing idle tasks (when showing idle tasks, it's possible they scrolled off the screen, when those are not shown, there are only 6 or so processes seen).

I stopped top and restarted, and the 2 running processes immediately appeared. I conclude that for some reason, top had lost track of them in some way.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: procps 1:3.3.9-1ubuntu2.2
ProcVersionSignature: Ubuntu 3.16.0-50.67~14.04.1-generic 3.16.7-ckt16
Uname: Linux 3.16.0-50-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.15
Architecture: amd64
Date: Thu Oct 15 15:48:52 2015
InstallationDate: Installed on 2015-07-06 (101 days ago)
InstallationMedia: Xubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
SourcePackage: procps
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.sysctl.conf: [modified]
mtime.conffile..etc.sysctl.conf: 2015-09-07T13:46:27.714670

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers