killall -e should match process for very long names, but limits to 15 chars

Bug #1029564 reported by Alexandru Zbarcea on 2012-07-26

This bug report was converted into a question: question #204272: killall -e should match process for very long names, but limits to 15 chars.

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
procps (Ubuntu)
Undecided
Unassigned

Bug Description

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise

Linux horus 3.2.0-26-generic #41-Ubuntu SMP Thu Jun 14 17:49:24 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

$ ps -e | grep chromium
19025 ? 00:02:59 chromium-browse

!!! WITHOUT r (chromium-browser)

$ killall -e chromium-browser
chromium-browser: no process found

This bug happens after upgrading from 11.10

Alexandru Zbarcea (zbarcea-a) wrote :

although it seems duplicated to #295876, I thing that it is not, because this bug has to do only with "killall -e"

-e,--exact require exact match for very long names

Changed in procps (Ubuntu):
status: New → Invalid
status: Invalid → New
Robert Roth (evfool) on 2012-07-27
Changed in procps (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers