Please sync privoxy 3.0.10-1 (universe) from Debian unstable (main)

Bug #386219 reported by Paul Drain on 2009-06-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
privoxy (Debian)
Fix Released
Unknown
privoxy (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: privoxy

The debian/postinst file in the recently uploaded version to Karmic (3.012-2) contains a typo:

        [ -f $CONFDIR/matcha-all.action ] \
            && chown privoxy $CONFDIR/match-all.action

Should be:

        [ -f $CONFDIR/match-all.action ] \
            && chown privoxy $CONFDIR/match-all.action

Otherwise, doing a apt-get purge && apt-get install fails to restart Privoxy because of the permissions of the match-all.action file.

Paul Drain (pd) wrote :
Changed in privoxy (Ubuntu):
assignee: nobody → Charlie_Smotherman (porthose) (cjsmo)
status: New → In Progress
Charlie_Smotherman (cjsmo) wrote :

Here is a debdiff for karmic, opening upstream task

Charlie_Smotherman (cjsmo) wrote :

Launchpad won't let me open an upstream task. I have opened BTS #534270. Subscribing universe sponsors.

Changed in privoxy (Ubuntu):
assignee: Charlie_Smotherman (porthose) (cjsmo) → nobody
status: In Progress → New
Changed in privoxy (Ubuntu):
status: New → Confirmed
Daniel Holbach (dholbach) wrote :

It's fixed in Debian now... can you check if we can sync the new version?

Changed in privoxy (Debian):
importance: Undecided → Unknown
status: New → Unknown
Changed in privoxy (Debian):
status: Unknown → Fix Released
Charlie_Smotherman (cjsmo) wrote :

Yes it can be synced.

Please sync privoxy-3.0.13-1 (universe) from Debian unstable (main).

The sync would bring in a new upstream release. The postinst fix mentioned above is now included and upstream has included the 03_ipv6.dpatch patch.

privoxy (3.0.13-1) unstable; urgency=low

  * New upstream version 3.0.13-beta.
  * Adapted all patches to the new upstream version.
  * Removed 03_ipv6, because IPv6 is now supported upstream.
  * Upgrade to Standards-Version 3.8.1 (no changes)
  * Fix matcha-all.action typo in debian/postinst (Closes: #534270).

 -- Roland Rosenfeld <email address hidden> Tue, 23 Jun 2009 15:09:08 +0200

Best regards
Charlie Smotherman

Changed in privoxy (Ubuntu):
status: Confirmed → New
Nick Ellery (nick.ellery) wrote :

ACK

Changed in privoxy (Ubuntu):
status: New → Confirmed
summary: - Typo in post-install script, stops stop/start/restart on Ubuntu
+ Please sync privoxy 3.0.10-1 (universe) from Debian unstable (main)
Steve Langasek (vorlon) wrote :

[Updating] privoxy (3.0.12-2 [Ubuntu] < 3.0.13-1 [Debian])
 * Trying to add privoxy...
  - <privoxy_3.0.13-1.dsc: downloading from http://ftp.debian.org/debian/>
  - <privoxy_3.0.13.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
  - <privoxy_3.0.13-1.diff.gz: downloading from http://ftp.debian.org/debian/>
I: privoxy [universe] -> privoxy_3.0.12-2 [universe].
Connection to cocoplum.canonical.com closed.

Changed in privoxy (Ubuntu):
status: Confirmed → Fix Released
Steve Langasek (vorlon) wrote :

[Updating] privoxy (3.0.12-2 [Ubuntu] < 3.0.13-1 [Debian])
 * Trying to add privoxy...
  - <privoxy_3.0.13-1.dsc: cached>
  - <privoxy_3.0.13.orig.tar.gz: cached>
  - <privoxy_3.0.13-1.diff.gz: cached>
I: privoxy [universe] -> privoxy_3.0.12-2 [universe].
Connection to cocoplum.canonical.com closed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.