package privoxy 3.0.8-1 failed to install/upgrade: Unterprozess post-installation script gab den Fehlerwert 1 zurück

Bug #208313 reported by hiptrop on 2008-03-28
46
This bug affects 4 people
Affects Status Importance Assigned to Milestone
privoxy (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: privoxy

well as the topic says ... privoxy does not install correctly

Richte privoxy ein (3.0.8-1) ...
Starting filtering proxy server: invoke-rc.d: initscript privoxy, action "start" failed.
dpkg: Fehler beim Bearbeiten von privoxy (--configure):
 Unterprozess post-installation script gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 privoxy
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
Architecture: i386
Date: Fri Mar 28 16:43:34 2008
DistroRelease: Ubuntu 8.04
ErrorMessage: Unterprozess post-installation script gab den Fehlerwert 1 zurück
Package: privoxy 3.0.8-1
PackageArchitecture: i386
SourcePackage: privoxy
Title: package privoxy 3.0.8-1 failed to install/upgrade: Unterprozess post-installation script gab den Fehlerwert 1 zurück
Uname: Linux 2.6.24-12-generic i686

hiptrop (lilo5011) wrote :

Same problem here, package won't install:

Get: 1 http://archive.ubuntu.com hardy/universe privoxy 3.0.8-1 [1336kB]
Fetched 1336kB in 3s (392kB/s)
Selecting previously deselected package privoxy.
(Reading database ... 199345 files and directories currently installed.)
Unpacking privoxy (from .../privoxy_3.0.8-1_i386.deb) ...
Setting up privoxy (3.0.8-1) ...
Starting filtering proxy server: invoke-rc.d: initscript privoxy, action "start" failed.
dpkg: error processing privoxy (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 privoxy
E: Sub-process /usr/bin/dpkg returned an error code (1)

Changed in privoxy:
status: New → Confirmed
Jonathan Steinhart (jsteinhart) wrote :

I was having the same problem. I found it to be a problem with an unofficial libpcre package from pgquiles' ppa archive.

To determine if you're having the same problem, you can do this:

$tail /var/log/privoxy/errorfile:

Jun 20 12:34:42.810 Privoxy(b7d696b0) Info: Privoxy version 3.0.8
Jun 20 12:34:42.810 Privoxy(b7d696b0) Info: Program name: /usr/sbin/privoxy
/usr/sbin/privoxy: symbol lookup error: /usr/sbin/privoxy: undefined symbol: pcreposix_regcomp

$ dpkg -l|grep pcre
ii libpcre++0 0.9.5-3 C++ wrapper class for pcre (runtime)
ii libpcre3 7.7-0ubuntuhardy1~pgquiles2 Perl 5 Compatible Regular Expression Library - r
ii libpcrecpp0 7.7-0ubuntuhardy1~pgquiles2 Perl 5 Compatible Regular Expression Library - C

To fix it, here's what I did:
1) sudo dpkg --force-depends --remove libpcre3 libpcrecpp0
2) comment out/disable the pgquiles source in my /etc/apt/source.list file
3) sudo apt-get update
4) sudo apt-get -f install

Now privoxy starts again!

Andreas Moog (ampelbein) wrote :

There have been several improvements made to privoxy including the handling of errors. I'm closing this report, please open a new one if you still have issues.

Changed in privoxy (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers