pristine-tar: command failed when using git-buildpackage on the xz tarball.

Bug #1218197 reported by Shih-Yuan Lee on 2013-08-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pristine-tar (Ubuntu)
High
Shih-Yuan Lee
Precise
Low
Shih-Yuan Lee

Bug Description

[Test Case]
$ git clone https://github.com/fourdollars/x11-touchscreen-calibrator.git
$ cd x11-touchscreen-calibrator
$ git fetch --tags
$ git checkout pristine-tar
$ git checkout debian
$ git-buildpackage --git-pristine-tar --git-debian-branch=debian -S --lintian-opts --profile debian
dh clean
   dh_testdir
   dh_auto_clean
   dh_clean
paranoia check failed on params from delta (-z -6e) at /usr/bin/pristine-xz line 191.
pristine-tar: command failed: pristine-xz --no-verbose --no-debug --no-keep genxz /tmp/pristine-tar.DqIN1ECpg5/wrapper /tmp/pristine-tar.pQefJU7diE/x11-touchscreen-calibrator_0.1.orig.tar.xz.tmp
pristine-tar: failed to generate tarball
gbp:error: /usr/bin/pristine-tar returned 255
gbp:error: Couldn't checkout "x11-touchscreen-calibrator_0.1.orig.tar.xz"
---
ApportVersion: 2.0.1-0ubuntu17.4
Architecture: amd64
DistroRelease: Ubuntu 12.04
MarkForUpload: True
Package: pristine-tar 1.20
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=zh_TW:en
 TERM=screen
 PATH=(custom, no user)
 LANG=zh_TW.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.2.0-52.78-generic 3.2.48
Tags: precise running-unity
Uname: Linux 3.2.0-52-generic x86_64
UpgradeStatus: Upgraded to precise on 2012-04-27 (489 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare vboxusers

apport information

Changed in pristine-tar (Ubuntu):
assignee: nobody → Shih-Yuan Lee (fourdollars)
status: New → In Progress
tags: added: apport-collected running-unity
description: updated
Shih-Yuan Lee (fourdollars) wrote :

The fix of lp:~fourdollars/pristine-tar/lp1218197 is from upstream git repo.

Changed in pristine-tar (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-13.10
Changed in pristine-tar (Ubuntu):
status: In Progress → Fix Released
Changed in pristine-tar (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Low
Changed in pristine-tar (Ubuntu):
milestone: ubuntu-13.10 → none
Changed in pristine-tar (Ubuntu Precise):
status: Confirmed → Incomplete
Dimitri John Ledkov (xnox) wrote :

The branch looks ok, but please adjust the bug description as per
https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

It looks like you have a good test-case to execute the git-buildpackage command, but you are not listing where to clone that repository from.

After that please set the precise task back from "incomplete" to "confirmed".

description: updated
Changed in pristine-tar (Ubuntu Precise):
status: Incomplete → Confirmed
Changed in pristine-tar (Ubuntu Precise):
assignee: nobody → Shih-Yuan Lee (fourdollars)
status: Confirmed → In Progress
Sebastien Bacher (seb128) wrote :

Seems like that one got uploaded (it's in https://launchpad.net/ubuntu/precise/+queue?queue_state=1), unsubscribing sponsors

Hello Shih-Yuan, or anyone else affected,

Accepted pristine-tar into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/pristine-tar/1.20ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in pristine-tar (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Shih-Yuan Lee (fourdollars) wrote :

I have verified pristine-tar 1.20ubuntu1 and it works well.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pristine-tar - 1.20ubuntu1

---------------
pristine-tar (1.20ubuntu1) precise-proposed; urgency=low

  * pristine-xz: Add --check={none,crc32,crc64,sha256}, --block-list and
    compression levels 0 and 0e. (LP: #1218197)
 -- Shih-Yuan Lee (FourDollars) <email address hidden> Thu, 29 Aug 2013 14:05:16 +0800

Changed in pristine-tar (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers