Please remove prevu from precise

Bug #948191 reported by Andrew Starr-Bochicchio on 2012-03-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
prevu (Ubuntu)
Wishlist
Unassigned

Bug Description

Please remove prevu (source and binary) from precise. It is un-maintained, buggy, and superseded by backportpackage from ubuntu-dev-tools. I've asked for anyone to speak up on ubuntu-devel if they reject. See thread:

https://lists.ubuntu.com/archives/ubuntu-devel/2012-February/034845.html

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: prevu (not installed)
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic-pae 3.2.9
Uname: Linux 3.2.0-18-generic-pae i686
ApportVersion: 1.94-0ubuntu2
Architecture: i386
Date: Tue Mar 6 11:52:31 2012
SourcePackage: prevu
UpgradeStatus: Upgraded to precise on 2012-03-01 (4 days ago)

Changed in prevu (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
Jonathan Riddell (jr) on 2012-03-20
Changed in prevu (Ubuntu):
status: Confirmed → Fix Released
Tessa (unit3) wrote :

I just ran into this after updating to 12.04. There's no real docs on how to use backportpackage as a replacement for prevu, I think this should've been done at least on the Ubuntu wiki before completely removing prevu.

I'd expect docs to contain steps on:
- setting up a build chroot
- configuring which GPG key to use, or disabling package signing
- building packported packages into a local backport repo
- adding local backport repo to apt sources

All of this was well automated by prevu and required very little user intervention. Docs to replace all of this with backportpackage equivalents are needed.

Richard Hansen (rhansen) wrote :

I agree with Graeme. I was unpleasantly surprised to see that prevu was abandoned without transition documentation.

A rough version of the info that should go in the documentation, should someone ever create it:

Package signing is no longer required in ubuntu-dev-tools 0.142; see bug #992739. If you are using an older version, you can add the following line to your ~/.devscripts file and then backport the latest ubuntu-dev-tools:
    DEBUILD_DPKG_BUILDPACKAGE_OPTS="-us -uc"

To create a build chroot, run:
    pbuilder --create
(my .pbuilderrc is heavily customized; others may need to pass options to pbuilder to get it to do what they want)

I use the following command to backport a package:
    backportpackage -b -U -w . <package>

To make a local repo, run:
    cd buildresult
    dpkg-scanpackages . >Packages

To add the local repository to your apt sources:
    echo "deb file:$(pwd) ./ #locally backported packages" |
    sudo tee /etc/apt/sources.list.d/localbackports.list

I'm sorry this has inconvenienced some folks with this, but as I've mentioned in the linked email thread on ubuntu-devel, I seem to be the only person to have done an upload of prevu in the past few years. That has only been to make it aware of new release names. It was never updated in oneiric to know about precise and no one seems to have cared enough to file a bug about it. The package is unmaintained. No one is directly subscribed to its bug reports in Ubuntu, and upstream hasn't seen a commit in a long time. As you well know (since you reported the bug a7x), prevu can't handle source version 3 package, which at this point is over 10,000 packages (http://upsilon.cc/~zack/stuff/dpkg-v3/).

If someone wants to step up and take over maintenance of the package, there is no reason that it couldn't be reintroduced to the archive and even backported to 12.04. Though it might be better to extend backportpackage (which is admittedly aimed at developers not end users) to better handle the prevu use case. It is being actively maintained.

The version found in oneiric is installable in precise if you really want it. You can grab it from here:

http://archive.ubuntu.com/ubuntu/pool/universe/p/prevu/prevu_0.5.2-0ubuntu6_all.deb

Thanks for adding this information. I'm sure it will help others. (Though it's also a bit ironic as prevu ships with no documentation what so ever.)

Richard Hansen (rhansen) wrote :

I agree with Graeme. I was unpleasantly surprised to see that prevu was abandoned without transition documentation.

A rough version of the info that should go in the documentation, should someone ever create it:

Package signing is no longer required in ubuntu-dev-tools 0.142; see bug #992739. If you are using an older version, you can add the following line to your ~/.devscripts file and then backport the latest ubuntu-dev-tools:
    DEBUILD_DPKG_BUILDPACKAGE_OPTS="-us -uc"

To create a build chroot, run:
    pbuilder --create
(my .pbuilderrc is heavily customized; others may need to pass options to pbuilder to get it to do what they want)

I use the following command to backport a package:
    backportpackage -b -U -w . <package>

To make a local repo, run:
    cd buildresult
    dpkg-scanpackages . >Packages

To add the local repository to your apt sources:
    echo "deb file:$(pwd) ./ #locally backported packages" |
    sudo tee /etc/apt/sources.list.d/localbackports.list

Richard Hansen (rhansen) wrote :

(Sorry for the accidental double post yestderday!)

I need to amend the above information: If you're running ubuntu-dev-tools 0.142 or newer, you'll want to pass the (undocumented as of 0.142) --dont-sign option to backportpackage.

I'm not criticizing the removal of prevu; now that I know that backportpackage exists and that it's a better option, I'd much rather use it than prevu. I just became worried when the only easy backporting option I knew of vanished. I don't want others to experience that.

What would you think about resurrecting the prevu package, but modify it so that all it does is print an informative message to stderr and exit with a non-zero return code? Perhaps I'll open a new bug report for that and work on it myself, but I'll need someone else to upload the package.

Tina Russell (tinarussell) wrote :

Richard Hansen: “pbuilder create” (or “pbuilder --create”) gives me the error message: “mkdir: cannot create directory '/var/cache/pbuilder/build/13678': Permission denied”. Do I need to run pbuilder as root? Or, is there a setting I should change?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments