Ubuntu

auto url=autoserver fetches wrong preseed file (squeeze, not maverick/natty/oneiric)

Reported by Reinhard Tartler on 2010-11-25
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
preseed (Ubuntu)
Undecided
Unassigned
Maverick
Low
Unassigned
Natty
Low
Unassigned

Bug Description

While experimenting with d-i, I stumpled in the documentation https://help.ubuntu.com/10.10/installation-guide/i386/preseed-using.html#preseed-auto over this part:

<quote>
There are several features of Debian Installer that combine to allow fairly simple command lines at the boot prompt to result in arbitrarily complex customized automatic installs. To illustrate this, here are some examples that can be used at the boot prompt:

  auto url=autoserver

This relies on there being a DHCP server that will get the machine to the point where autoserver can be resolved by DNS, perhaps after adding the local domain if that was provided by DHCP. If this was done at a site where the domain is example.com, and they have a reasonably sane DHCP setup, it would result in the preseed file being retrieved from http://autoserver.example.com/d-i/maverick/./preseed.cfg
</quote>

This, however, is wrong, a tcpdump revealed that the installer tries to download http://autoserver.example.com/d-i/squeeze/./preseed.cfg instead.

Reinhard Tartler (siretart) wrote :

I've now pushed a proposed fix for natty in the linked bzr branch, but I didn't actually test it.

From looking at the source code, I strongly believe that the same problem also exists in maverick and lucid. For maverick the fix is basically the same. However, I don't understand how the url is determined in lucid.

Jayen (jayen) wrote :

Looking at the console when trying this from a maverick cd, it looks like wget simply fetched "autoserver" and didn't prepend "http://" nor append "/d-i/..././preseed.cfg"

Max Bowsher (maxb) wrote :

Jayen:

For me Maverick is behaving per Reinhard's original description of the problem. Perhaps you mistyped something or misinterpreted the console output?

Jayen (jayen) wrote :

Unlikely. wget did save `index.html' and did try to fetch http://autoserver/

Perhaps because I was using the desktop CD and entered "auto url=autoserver" in the boot options? (This is the way I install debian, so I thought it would work the same on ubuntu.)

Max Bowsher (maxb) wrote :

Jayen:

The "auto" boot parameter is only supported by the syslinux or isolinux boot menu configuration files on some install media images. I recommend using the longer form "auto=true" which is directly processed by d-i. (The usual definition of "auto" is actually "auto=true priority=critical", but if a preseed file is in use, it's unlikely the priority change actually affects anything, so I don't bother to add the priority=critical bit.)

summary: - auto url=autoserver fetches wrong pressed file
+ auto url=autoserver fetches wrong preseed file (squeeze, not
+ maverick/natty/oneiric)
Max Bowsher (maxb) wrote :

Hello ~ubuntu-sponsors,

I have updated Reinhard's fix to target oneiric, and request sponsorship.

I've not tested this in oneiric, but I have tested it in natty, by applying the change to an existing d-i mini.iso / initrd.gz.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package preseed - 1.49ubuntu1

---------------
preseed (1.49ubuntu1) oneiric; urgency=low

  [ Max Bowsher ]
  * In 'autoserver' mode, fetch the preseed file for 'oneiric' instead for
    'wheezy'. LP: #681396

  [ Colin Watson ]
  * Change the "keymap" alias to keyboard-configuration/layoutcode, since
    Ubuntu uses console-setup (LP: #74829).
 -- Colin Watson <email address hidden> Wed, 04 May 2011 13:26:42 +0100

Changed in preseed (Ubuntu):
status: New → Fix Released
Jayen (jayen) wrote :

Hi Max,

The "auto" boot parameter seemed to work fine with a full URL, ie: "auto url=http://autoserver/d-i/maverick/preseed.cfg" on the desktop CD. I hit F6 on the boot menu, then ESC, then entered additional kernel parameters. The installer still asked the usual questions but it did seem to pick up settings from the preseed file just fine.

Clint Byrum (clint-fewbar) wrote :

There doesn't seem to be anything to sponsor here just yet. Please prepare a merge proposal against lp:ubuntu/maverick/preseed or lp:ubuntu/natty/preseed according to the SRU process defined here:

https://wiki.ubuntu.com/StableReleaseUpdates

Unsubscribing sponsors.

The bugs are present though, so marking Confirmed. Since there is a workaround, which is just to use a 'squeeze' symlink, I'm setting the importance to Low.

Changed in preseed (Ubuntu Maverick):
status: New → Confirmed
Changed in preseed (Ubuntu Natty):
status: New → Confirmed
Changed in preseed (Ubuntu Maverick):
importance: Undecided → Low
Changed in preseed (Ubuntu Natty):
importance: Undecided → Low
Max Bowsher (maxb) wrote :

Colin Watson sponsored my change into oneiric per comment #7

There is no point fixing this in a maverick or natty SRU, since the fix would need a d-i image respin to take effect, which AFAIK only happens at initial release, and LTS point releases.

On Wed, Jun 08, 2011 at 09:58:31 (CEST), Max Bowsher wrote:

> Colin Watson sponsored my change into oneiric per comment #7
>
> There is no point fixing this in a maverick or natty SRU, since the fix
> would need a d-i image respin to take effect, which AFAIK only happens
> at initial release, and LTS point releases.

Well, can't we get at least only the netboot images fixed? PXE
installation that allow netbooting of several versions of ubuntu and
require seperate configs for different releases seem like a valid use
case to me.

Or does 'd-i images respin' also include the netboot images on the
archive mirrors?

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Max Bowsher (maxb) wrote :

I talked to cjwatson on IRC and apparently it is feasible to have the d-i bits updated, so I've prepared branches with the necessary changes.

No merge proposals, though, because there do not exist ~ubuntu-core-dev preseed branches for released series.

Resubscribing sponsors for the maverick and natty part of this bug.

Stéphane Graber (stgraber) wrote :

Uploaded the maverick one to proposed and commited the changes to the core-dev branch.

Changed in preseed (Ubuntu Maverick):
status: Confirmed → Fix Committed
Stéphane Graber (stgraber) wrote :

Uploaded the natty one to proposed and commited the changes to the core-dev branch.

Changed in preseed (Ubuntu Natty):
status: Confirmed → Fix Committed
Stéphane Graber (stgraber) wrote :

Unsubscribing sponsors from the bug. SRU team will post to this bug when these two packages are accepted.

Just a note, according to our version number policy, I changed your version number from 1.xxubuntu1 to 1.xxubuntu0.1.
https://wiki.ubuntu.com/SecurityTeam/UpdatePreparation#Update%20the%20packaging

I was also wondering if a similar bugfix was needed for Lucid, looking at the comment history it's not very clear.
If it's, it'd be great if you could prepare another debdiff or merge proposal so that can also be uploaded.

Thanks

Accepted preseed into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Chris Halse Rogers (raof) wrote :

Hello Reinhard, or anyone else affected,

Accepted preseed into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Reinhard Tartler (siretart) wrote :

This bug is about an installer component. The wiki page indicates that the components are supposed to be located at http://archive.ubuntu.com/ubuntu/dists/natty-proposed/main/installer-i386. Unfortunately, this location doesn't exist, so verification is not possible at this point.

Collon, can you please check if the wiki page is wrong or if there is a problem with launchpad or the archive?

Colin Watson (cjwatson) wrote :

Reinhard: that location exists now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers