Unmet Dependencies for PrefixSuffix - Not Installable

Bug #689044 reported by jhfhlkjlj on 2010-12-11
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
prefixsuffix (Ubuntu)
High
Unassigned
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
High
Unassigned

Bug Description

[SRU JUSTIFICATION]

1. This bug will impact all users attempting to install the program on 10.10 and 11.04. Not one person will be able to get the program to function: the dependencies are broken. Attempting to install will result in a broken catalogue.

2. The broken dependencies have been fixed. bakery-2.6 is now currently in Oneiric's channels(see comment #5).

3. This program is completely not installable because of broken dependencies in the stock repositories.

TEST CASE:

Running "sudo apt-get install prefixsuffix" will cause apt to announce broken dependencies, then break catalogue.

Regression-potential of fixing: none.

[OLD BUG REPORT]
Binary package hint: software-center

Up to date 10.10 install, only a few PPAs with unaffiliated packages included in my repositories.

Asking the software center to install the program "PrefixSuffix" will cause the software center to announce that unmet dependencies and it cannot be installed. The software center then spams me with an option to repair or not (and doesn't let up nor "repair" it).

Here is the output using apt-get:
-------
cornwall@cornwall-laptop:~$ sudo apt-get install prefixsuffix
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 prefixsuffix : Depends: libbakery-2.4-1 but it is not installable
E: Broken packages
--------

and here is the version of libbakery that ubuntu has:

------
cornwall@cornwall-laptop:~$ apt-cache show libbakery-2.6-1
Package: libbakery-2.6-1
Priority: optional
Section: universe/libs
Installed-Size: 364
Maintainer: Ubuntu MOTU Developers <email address hidden>
Original-Maintainer: Bradley Bell <email address hidden>
Architecture: amd64
Source: bakery2.6
Version: 2.6.3-0ubuntu1
----

I don't know the best COA for solving this but at the current moment this package is a powder keg (and it's featured on my "what's new" section!). It looks like the program depends on an old version of libbakery - Perhaps PrefixSuffix should be removed until it can be sorted out.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: software-center 3.0.7
Uname: Linux 2.6.36-020636-generic x86_64
Architecture: amd64
Date: Sat Dec 11 14:52:49 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: software-center

summary: - Unmet Dependencies for PrefixSuffix - uninstallable [Maverick]
+ Unmet Dependencies for PrefixSuffix - Not Installable [Maverick]
description: updated

this is not a software-center issue, I have reassigned to prefixsuffix package for you

affects: software-center (Ubuntu) → prefixsuffix (Ubuntu)
Changed in prefixsuffix (Ubuntu):
importance: Undecided → Medium
Juan Pablo Arias (j4np0l) wrote :

I get the exact same errors with Ubuntu 10.10 Netbook Edition (I don't have any custom PPAs)

Changed in prefixsuffix (Ubuntu):
status: New → Confirmed
Matthias Klose (doko) wrote :

and ftbfs due to missing b-d on libbakery-2.4-dev
see https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2708694

package should be removed from the archive

Changed in prefixsuffix (Ubuntu):
importance: Medium → High
tags: added: ftbfs oneiric
Ilya Barygin (randomaction) wrote :

I have made an upload of this package switching it to bakery-2.6. The package is functional and need not be removed.

Changed in prefixsuffix (Ubuntu Oneiric):
status: Confirmed → Fix Committed

Should it be removed from the other Ubuntu versions considering their uselessness?

Ilya Barygin (randomaction) wrote :

Fixed in version 0.5.0+cvs.2005.06.18-0ubuntu11.

The fix will be available in Ubuntu 11.10. Earlier versions can be updated through SRU process if necessary.

Changed in prefixsuffix (Ubuntu Oneiric):
status: Fix Committed → Fix Released
description: updated
summary: - Unmet Dependencies for PrefixSuffix - Not Installable [Maverick]
+ Unmet Dependencies for PrefixSuffix - Not Installable

I'm sorry, but how does one nominate nowadays? I can't seem to locate the tool any more.

Changed in prefixsuffix (Ubuntu Maverick):
assignee: nobody → Ilya Barygin (randomaction)
status: New → In Progress
Changed in prefixsuffix (Ubuntu Natty):
assignee: nobody → Ilya Barygin (randomaction)
status: New → In Progress
Ilya Barygin (randomaction) wrote :

Packages uploaded to maverick-proposed and natty-proposed. They only differ by version number. Cleanup changes from Oneiric were dropped.

Changed in prefixsuffix (Ubuntu Maverick):
assignee: Ilya Barygin (randomaction) → nobody
status: In Progress → Triaged
Changed in prefixsuffix (Ubuntu Natty):
assignee: Ilya Barygin (randomaction) → nobody
status: In Progress → Triaged

Hello Chauncellor, or anyone else affected,

Accepted prefixsuffix into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in prefixsuffix (Ubuntu Natty):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in prefixsuffix (Ubuntu Maverick):
status: Triaged → Fix Committed
Clint Byrum (clint-fewbar) wrote :

Hello Chauncellor, or anyone else affected,

Accepted prefixsuffix into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Natty works here. Great!

tags: added: verification-done-natty

Just tested Maverick. All is well.

tags: added: verification-done
removed: verification-done-natty verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package prefixsuffix - 0.5.0+cvs.2005.06.18-0ubuntu10.11.04.1

---------------
prefixsuffix (0.5.0+cvs.2005.06.18-0ubuntu10.11.04.1) natty-proposed; urgency=low

  * Update dependencies of package from bakery-2.4 to bakery-2.6 and
    gnome-vfsmm-2.6. This makes the package installable (LP: #689044).
    - affected files: dependencies.patch, debian/control
 -- Ilya Barygin <email address hidden> Thu, 01 Sep 2011 21:02:39 +0400

Changed in prefixsuffix (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package prefixsuffix - 0.5.0+cvs.2005.06.18-0ubuntu10.10.10.1

---------------
prefixsuffix (0.5.0+cvs.2005.06.18-0ubuntu10.10.10.1) maverick-proposed; urgency=low

  * Update dependencies of package from bakery-2.4 to bakery-2.6 and
    gnome-vfsmm-2.6. This makes the package installable (LP: #689044).
    - affected files: dependencies.patch, debian/control
 -- Ilya Barygin <email address hidden> Thu, 01 Sep 2011 21:24:35 +0400

Changed in prefixsuffix (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers