pptpd on edgy

Bug #62255 reported by Maurizio Merli on 2006-09-25
8
Affects Status Importance Assigned to Milestone
pptpd (Debian)
Fix Released
Unknown
pptpd (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pptpd

I upgrade my distribution to edgy. It's all ok but pptpd!
It doesn't work anymore!

Here my log (/var/log/syslog)

Sep 24 07:16:02 localhost pptpd[7826]: CTRL: Client 192.168.1.2 control connection started
  5 Sep 24 07:16:02 localhost pptpd[7826]: CTRL: Starting call (launching pppd, opening GRE)
  6 Sep 24 07:16:02 localhost pppd[7827]: Plugin /usr/lib/pptpd/pptpd-logwtmp.so is for pppd version 2.4.3, this is 2.4.
  7 Sep 24 07:16:02 localhost pptpd[7826]: GRE: read(fd=7,buffer=8058640,len=8196) from PTY failed: status = -1 error =
  8 Sep 24 07:16:02 localhost pptpd[7826]: CTRL: PTY read or GRE write failed (pty,gre)=(7,8)
  9 Sep 24 07:16:02 localhost pptpd[7826]: CTRL: Reaping child PPP[7827]
 10 Sep 24 07:16:02 localhost pptpd[7826]: CTRL: Client 192.168.1.2 control connection finished

Matti Lindell (mlind) wrote :

This package is in main, which is freezed now. If this prevents the usage of the program, then it's a grave bug and should get attention before Edgy's release.

Debian bug report contains a patch that's supposed to fix this issue, have you tried it?

Changed in pptpd:
status: Unconfirmed → Needs Info

No i haven't try the patch

I prefer to wait for release of the package on apt server

mlind ha scritto:
> This package is in main, which is freezed now. If this prevents the usage of the program, then it's a grave bug and should get attention before Edgy's release.
>
> Debian bug report contains a patch that's supposed to fix this issue,
> have you tried it?
>
>
> ** Changed in: pptpd (Ubuntu)
> Status: Unconfirmed => Needs Info
>
>

Maurizio Merli (maurizio-merli) wrote :

mlind ha scritto:
> This package is in main, which is freezed now. If this prevents the usage of the program, then it's a grave bug and should get attention before Edgy's release.
>
> Debian bug report contains a patch that's supposed to fix this issue,
> have you tried it?
>
>
> ** Changed in: pptpd (Ubuntu)
> Status: Unconfirmed => Needs Info
>
>
Yes with the patch it's work!!!
But I would be better to have the deb package patched with edgy :P

Changed in pptpd:
status: Unknown → Unconfirmed
Matti Lindell (mlind) wrote :

Initial reporter confirms that patch on Debian bugreport fixes this issue on Edgy. Subscribing release team since this probably needs a review and an UVF Exception.

Matt Zimmerman (mdz) wrote :

Please subscribe the release team only when there is a decision ready to be made; otherwise they receive too much discussion traffic.

In this case, the procedure to follow for requesting a freeze exception is documented on http://wiki.ubuntu.com/DeveloperResources

Vangelis Tasoulas (cyberang3l) wrote :

The same problem for me...

Check the following link to see how I solved it...
(Probably not the right way but works now)

http://ubuntuforums.org/showthread.php?t=283067

Changed in pptpd:
status: Unconfirmed → Fix Released

Additionally pptp does not work with edgy. I even tried downgrading kernel pptpconfig ppp to the versions in Dapper with equally poor success. My solution was to re-install dapper (this is a daily use system and I've got to interface with Balmy's World.) WM made no difference.

The problem is not connecting, as it does connect but from command line or using pptpconfig it hangs right at the point where it should be modding route and resolv.conf. No errors no output to log or screen just hangs forever.

Running on a Dell 610 latitude laptop Centrino, 2.4ghz Intel cpu 1G ram The problem exists both wifi and land line.

jboss1995 (justin-rtechguys) wrote :

This is an easy problem to fix thanks to CyberAngle
http://ubuntuforums.org/showthread.php?p=1880664

update the pptpd-1.3.0/plugins/patchlevel.h
to use right kernel

#define VERSION "2.4.4"

Eugene Kravtsoff (ekrava) wrote :

Yes, this patch it work's

I have the same problem in edgy:

May 4 12:16:00 tessier pppd[13798]: Plugin /usr/lib/pptpd/pptpd-logwtmp.so is for pppd version 2.4.
3, this is 2.4.4

Matti Lindell (mlind) on 2007-05-04
Changed in pptpd:
status: Needs Info → Confirmed
Adam Jacob (adamhjk) wrote :

This can also be worked around by simply not logging to wtmp on a successful pptp connection. Comment out the "logwtmp" line in /etc/pptpd.conf, and things will be better.

This only occurred for us after applying updates to edgy; was it fixed and then regressed again later?

This was fixed in 1.3.0-2

Changed in pptpd:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.