status_of_proc lacks a "-p" in /etc/init.d/pptpd

Bug #1296835 reported by Roberto Suárez Soto on 2014-03-24
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
pptpd (Debian)
Fix Released
Unknown
pptpd (Ubuntu)
Medium
Wesley Wiedenmeier
Trusty
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

The "status" target in /etc/init.d/pptpd doesn't work, because the call to status_of_proc lacks a "-p" before "$PIDFILE". Example:

# /etc/init.d/pptpd start
 * Starting PoPToP Point to Point Tunneling Server pptpd [ OK ]
# ps aux | grep pptpd
root 16211 0.0 0.0 10684 680 ? Ss 17:51 0:00 /usr/sbin/pptpd
root 16305 0.0 0.0 18236 904 pts/0 S+ 17:51 0:00 grep --color=auto pptpd
# /etc/init.d/pptpd status
 * /usr/sbin/pptpd is not running

This happens because status_of_proc takes $PIDFILE as $DAEMON, and tries to use the file "/var/run/pptpd.pid.pid" as source for the PID of the program. Adding "-p" solves the problem.

The version tested is 1.3.4+27+gddb30f8-1ubuntu1. Output of lsb_release -rd is:
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pptpd (Ubuntu):
status: New → Confirmed
Vasya Pupkin (shadowlmd) wrote :

I guess this bug is just too hard to fix.

Kanan (yanshekki) wrote :

I had this bug too.

黄伟华 (huang1988519) wrote :

I had this bug , are there same way to solve?

JTProg (p-mail-h) wrote :

I had this bug!

Robie Basak (racb) on 2016-06-09
Changed in pptpd (Ubuntu):
importance: Undecided → Medium
tags: added: bitesize

This was reported on the debian bugtracker here:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=747146

It was patched at debian version 1.4.0-3

Attached is a debdiff to fix the issue in trusty.

There is a package built with the patch in a ppa here:
https://launchpad.net/~wesley-wiedenmeier/+archive/ubuntu/test

Changed in pptpd (Ubuntu):
assignee: nobody → Wesley Wiedenmeier (wesley-wiedenmeier)

The attachment "fix_status_check.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Robie Basak (racb) wrote :

Yakkety has 1.4.0-7; Debian fixed in 1.4.0-3. Therefore Fix Released for Yakkety and an open task for Xenial.

Robie Basak (racb) wrote :

Trusty, sorry. Xenial has 1.4.0-7 and thus is fixed already.

Changed in pptpd (Ubuntu Xenial):
status: New → Fix Released
Changed in pptpd (Ubuntu):
status: Confirmed → Fix Released
Robie Basak (racb) wrote :

I tweaked the version to 1.3.4+27+gddb30f8-1ubuntu1.1. 1.3.4+27+gddb30f8-1ubuntu2 would also work because that version string happens to be unused in any subsequent release, but we prefer the .1 style as it makes it more obvious that it is an SRU.

Uploaded, thanks!

Changed in pptpd (Ubuntu Trusty):
status: New → In Progress
Changed in pptpd (Debian):
status: Unknown → Fix Released

Hello Roberto, or anyone else affected,

Accepted pptpd into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pptpd/1.3.4+27+gddb30f8-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in pptpd (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in pptpd (Ubuntu Trusty):
importance: Undecided → Medium
Changed in pptpd (Ubuntu Xenial):
importance: Undecided → Medium

The version in trusty-proposed looks like it fixes the issue.

ubuntu@ubuntu:~$ apt-cache show pptpd | grep Version
Version: 1.3.4+27+gddb30f8-1ubuntu1
ubuntu@ubuntu:~$ sudo /etc/init.d/pptpd start
ubuntu@ubuntu:~$ sudo /etc/init.d/pptpd status
 * /usr/sbin/pptpd is not running

ubuntu@ubuntu:~$ apt-cache show pptpd | grep Version
Version: 1.3.4+27+gddb30f8-1ubuntu1.1
ubuntu@ubuntu:~$ sudo /etc/init.d/pptpd start
ubuntu@ubuntu:~$ sudo /etc/init.d/pptpd status
 * pptpd is running

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pptpd - 1.3.4+27+gddb30f8-1ubuntu1.1

---------------
pptpd (1.3.4+27+gddb30f8-1ubuntu1.1) trusty; urgency=medium

  * Fix status check in debian/pptpd.init (LP: #1296835):
    - Fix was added at debian version 1.4.0-3 (Closes: #747146)

 -- Wesley Wiedenmeier <email address hidden> Tue, 21 Jun 2016 12:31:10 -0500

Changed in pptpd (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for pptpd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.