package planetpenguin-racer-gimp-dev None [modified: /var/lib/dpkg/info/planetpenguin-racer-gimp-dev.list] failed to install/upgrade: trying to overwrite `/usr/share/gimp/2.0/palettes/PPRacer---Default.gpl', which is also in package extremetuxracer-gimp-dev

Bug #237830 reported by yoda316 on 2008-06-06
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
extremetuxracer (Ubuntu)
High
Guillaume Martres
ppracer (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: planetpenguin-racer-gimp-dev

1) I am using Ubuntu 8.04
2) The version of the package is 0.3.1-10
3) What I expected to happen was for the package to be installed
4) What happened was the fact that the package tried to overwrite a file which is also in another package and failed to install

ProblemType: Package
Architecture: i386
Date: Fri Jun 6 01:51:19 2008
Dependencies:

DistroRelease: Ubuntu 8.04
ErrorMessage: trying to overwrite `/usr/share/gimp/2.0/palettes/PPRacer---Default.gpl', which is also in package extremetuxracer-gimp-dev
NonfreeKernelModules: nvidia
Package: planetpenguin-racer-gimp-dev None [modified: /var/lib/dpkg/info/planetpenguin-racer-gimp-dev.list]
PackageArchitecture: all
SourcePackage: ppracer
Title: package planetpenguin-racer-gimp-dev None [modified: /var/lib/dpkg/info/planetpenguin-racer-gimp-dev.list] failed to install/upgrade: trying to overwrite `/usr/share/gimp/2.0/palettes/PPRacer---Default.gpl', which is also in package extremetuxracer-gimp-dev
Uname: Linux 2.6.24-18-generic i686

yoda316 (allenkruger) wrote :
Ulysses Young (ulyyoung) wrote :

I believe this is simply an error in the .deb file, I'm looking into it. Will post fix when I find it.

description: updated
description: updated

Adding extremetuxracer task.

Changed in ppracer:
status: New → Confirmed
Changed in extremetuxracer:
status: New → Confirmed
importance: Undecided → High
Changed in ppracer:
importance: Undecided → High
Guillaume Martres (smarter) wrote :

In the meantime, you can remove planetpenguin-racer-gimp-dev or extremetuxracer-gimp-dev to be able to use apt again.

Cesare Tirabassi (norsetto) wrote :

May I ask what is the point of having the extremetuxracer-gimp-dev package at all?
Its just a replica of planetpenguin-racer-gimp-dev with different docs.
I would say just remove it as a binary or make it really specific for extremetuxracer.
I'm also markin the ppracer task as invalid since the problem is in extremetuxracer (which is based on ppracer).

Changed in ppracer:
status: Confirmed → Invalid
Changed in extremetuxracer:
status: Confirmed → Incomplete
Guillaume Martres (smarter) wrote :

PlanetPenguin Racer has been unmaintained for ages, ExtremeTuxRacer will eventually replace it completely and ppracer will become just a dummy transition package, so if one of the binary package should be removed, it should be the one from ppracer, not etracer imho.

thank you. I removed the extremetuxracer and left only
planetpenguin.

Your patience was rather well appreciated
--- Cesare Tirabassi <email address hidden>
wrote:

> May I ask what is the point of having the
> extremetuxracer-gimp-dev package at all?
> Its just a replica of planetpenguin-racer-gimp-dev
> with different docs.
> I would say just remove it as a binary or make it
> really specific for extremetuxracer.
> I'm also markin the ppracer task as invalid since
> the problem is in extremetuxracer (which is based on
> ppracer).
>
> ** Changed in: ppracer (Ubuntu)
> Status: Confirmed => Invalid
>
> ** Changed in: extremetuxracer (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> package planetpenguin-racer-gimp-dev None [modified:
>
/var/lib/dpkg/info/planetpenguin-racer-gimp-dev.list]
> failed to install/upgrade: trying to overwrite
>
`/usr/share/gimp/2.0/palettes/PPRacer---Default.gpl',
> which is also in package extremetuxracer-gimp-dev
> https://bugs.launchpad.net/bugs/237830
> You received this bug notification because you are a
> direct subscriber
> of the bug.
>
> Status in “extremetuxracer” source package in
> Ubuntu: Incomplete
> Status in “ppracer” source package in Ubuntu:
> Invalid
>
> Bug description:
> Binary package hint: planetpenguin-racer-gimp-dev
>
> 1) I am using Ubuntu 8.04
> 2) The version of the package is 0.3.1-10
> 3) What I expected to happen was for the package to
> be installed
> 4) What happened was the fact that the package tried
> to overwrite a file which is also in another package
> and failed to install
>
> ProblemType: Package
> Architecture: i386
> Date: Fri Jun 6 01:51:19 2008
> Dependencies:
>
> DistroRelease: Ubuntu 8.04
> ErrorMessage: trying to overwrite
>
`/usr/share/gimp/2.0/palettes/PPRacer---Default.gpl',
> which is also in package extremetuxracer-gimp-dev
> NonfreeKernelModules: nvidia
> Package: planetpenguin-racer-gimp-dev None
> [modified:
>
/var/lib/dpkg/info/planetpenguin-racer-gimp-dev.list]
> PackageArchitecture: all
> SourcePackage: ppracer
> Title: package planetpenguin-racer-gimp-dev None
> [modified:
>
/var/lib/dpkg/info/planetpenguin-racer-gimp-dev.list]
> failed to install/upgrade: trying to overwrite
>
`/usr/share/gimp/2.0/palettes/PPRacer---Default.gpl',
> which is also in package extremetuxracer-gimp-dev
> Uname: Linux 2.6.24-18-generic i686
>
>
>

Cesare Tirabassi (norsetto) wrote :

Not as long as ppracer will be in the archive.
However, if you have good reasons why ppracer should be removed from the archive, feel free to submit a removal request:

https://wiki.ubuntu.com/UbuntuDevelopment/PackageArchive#Removals

Changed in extremetuxracer:
assignee: nobody → smarter
status: Incomplete → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package extremetuxracer - 0.4-1ubuntu1

---------------
extremetuxracer (0.4-1ubuntu1) intrepid; urgency=low

  * Merged from Debian, remaining changes:
    - debian/control:
      + removed implicit build-deps on libglu1-xorg-dev and libsdl1.2-dev
      + replaced "planetpenguin-racer" by "extremetuxracer"
        in the Description fields
      + added back extremetuxracer-gimp-dev
    - debian/copyright:
      + replaced "Upstream Author" by "Upstream Authors"
      + added more complete list of authors
      + changed the Copyright field to a License field, moved src/quadtree.cpp
        license there and changed the GPLv2 text to the standard Debian text
      + added a real Copyright field
      + added a link to the complete GPLv2 text
    - debian/patches/20_german_translation.diff and 30_G++4.1-fix.diff:
      + removed, applied upstream
    - debian/patches/fix_cups_cheat.diff:
      + removed, fixed upstream
    - debian/extremetuxracer.desktop:
      + removed extension from Icon field to comply with desktop file policy
  * debian/extremetuxracer.6[.de].sgml:
    - replaced READMA by README and planetpenguin-racer by extremetuxracer
  * removed debian/etracer[.de].6, they are generated by debian/rules
  * debian/control:
    - added Vcs-* fields
    - added Conflicts/Replaces on planetpenguin-racer-gimp-dev for
      extremetuxracer-gimp-dev (LP: #237830)
    - bumped Standards-Version to 3.8.0
  * debian/planetpenguin-racer-dbg:
    - removed
  * debian/rules:
    - added a link from usr/share/games/extremetuxracer
      to usr/share/games/etracer
      for upgrade from hardy to intrepid
    - fixed lintian warning "debhelper-script-needs-versioned-build-depends
      dh_icons (>= 5.0.51~)"
  * debian/extremetuxracer.menu:
    - capitalized "Racer" in the longtitle field "Extreme Tux Racer"

 -- Guillaume Martres <email address hidden> Sun, 25 May 2008 22:56:48 +0200

Changed in extremetuxracer:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers