Ubuntu

Please merge pppoeconf 1.20 (main) from debian unstable (main)

Reported by Bhavani Shankar on 2011-06-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pppoeconf (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: pppoeconf

Debian changelog:

pppoeconf (1.20) unstable; urgency=low

   * Fix pppoeconf.desktop (Closes: #590202)
   * Drop depends on modconf (Closes: #613284)
     Thanks to Alexander Reichle-Schmehl <email address hidden>
   * Update POT and PO files.
   * Update russian translation (Closes: #562701)
     Thanks to Yuri Kozlov <email address hidden>
   * Update japanese translation (Closes: #622847)
     Thanks to Kenshi Muto <email address hidden>
   * Update french translation
     Thanks to debian-l10n-french team!
   * Update to standards version 3.9.2, no further required changes.

 -- Gregory Colpart <email address hidden> Sat, 23 Apr 2011 11:32:03 +0200

Actually it should be a sync according to d/changelog as it states that debian has fixed desktop file so it validates and installs cleanly and have dropped dependency on modconf from which one can think of overriding ubuntu changes per se, but running latest desktop-file-validate on the desktop file yields:

india@ubuntu11:~/pppoeconf-1.20$ desktop-file-validate pppoeconf.desktop
pppoeconf.desktop: warning: key "Encoding" in group "Desktop Entry" is deprecated

and upon removing the encoding key (debdiff attached) and running desktop-file-install yields no error messages:

india@ubuntu11:~/pppoeconf-1.20$ sudo desktop-file-install pppoeconf.desktop
india@ubuntu11:~/pppoeconf-1.20$

Regards

Related branches

Bhavani Shankar (bhavi) wrote :
Changed in pppoeconf (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Sebastien Bacher (seb128) wrote :

Thank you for your work but it seems the reason Ubuntu doesn't install the desktop is that it was judged that the command line tools was not something that should be listed in a modern desktop menu or equivalent, that didn't seem to have changed so we should still keep it not installed

Sebastien Bacher (seb128) wrote :

(unsubscribing sponsors, please subscribe them back when you update the bug)

tags: added: patch
Bhavani Shankar (bhavi) wrote :

Thanks sebastien,

Attached is the modified diff

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pppoeconf - 1.20ubuntu1

---------------
pppoeconf (1.20ubuntu1) oneiric; urgency=low

  * Merge from debian unstable (LP: #799149). Remaining changes:
    - do not install the desktop file
  * Dropped change (Superceeded in debian)
    - do not depend on modconf

pppoeconf (1.20) unstable; urgency=low

  * Fix pppoeconf.desktop (Closes: #590202)
  * Drop depends on modconf (Closes: #613284)
    Thanks to Alexander Reichle-Schmehl <email address hidden>
  * Update POT and PO files.
  * Update russian translation (Closes: #562701)
    Thanks to Yuri Kozlov <email address hidden>
  * Update japanese translation (Closes: #622847)
    Thanks to Kenshi Muto <email address hidden>
  * Update french translation
    Thanks to debian-l10n-french team!
  * Update to standards version 3.9.2, no further required changes.
 -- Bhavani Shankar <email address hidden> Sun, 03 Jul 2011 13:15:14 +0200

Changed in pppoeconf (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers