ppp does not replace default route

Bug #608372 reported by pramathesh ambasta
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ppp (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Binary package hint: ppp

This seems to be new to Lucid. I have used gnome-ppp and wvdial to successfully connect using a usb modem (Huawei datacard) in the past, while remaining connected to the local LAN through eth0. I needed to set the "defaultroute" and "replacedefaultroute" options in /etc/ppp/peers/wvdial and /etc/ppp/peers/wvdial-pipe and it would work in earlier Ubuntu versions (8.04, 9.04, 9.10).

With Ubuntu 10.04, I have noticed that the default route does not get replaced and I have to disconnect eth0 in order to get ppp0 going. If eth0 and ppp0 are both connected, despite the above options set, the system is unable to connect to the internet. This also happens if I use NetworkManager to connect using the Mobile Broadband option and with the above two options set in /etc/ppp/options.

The default route is replaced only intermittently, and there does not seem to be any logic to why it is happening.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: ppp 2.4.5~git20081126t100229-0ubuntu3 [modified: etc/ppp/options]
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-23-generic i686
Architecture: i386
CheckboxSubmission: ca3facf9929706a49a37a803fd60995f
CheckboxSystem: b845c366ea09c60efa3a45c1b5b21525
Date: Wed Jul 21 22:45:19 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 LANG=C
 SHELL=/bin/bash
SourcePackage: ppp

Revision history for this message
pramathesh ambasta (pramathesh-ambasta) wrote :
Revision history for this message
Harry Sufehmi (harry-sufehmi) wrote :

Hi,

I suffered from same problem, and found the solution here :
http://ubuntu-virginia.ubuntuforums.org/showpost.php?p=7836980&postcount=3

Quoted:

======================================

Adding those two lines to /etc/ppp/peers/wvdial worked perfectly!

defaultroute
replacedefaultroute

======================================

Now pppd always set the default route correctly.

Hope it helps.

Thanks,
Harry

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ppp (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers