Pon/poff don't work as normal user...

Bug #278828 reported by sledgehammer999 on 2008-10-05
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ppp (Ubuntu)
Undecided
Unassigned

Bug Description

I have a Sagem f@st 800 modem which works fine(using this wiki-->https://help.ubuntu.com/community/UsbAdslModem/ueagle-atm). I have installed Intrepid Beta amd64.

Anyways, when I use the "pon" command as a normal user it says : "Error: only members of the 'dip' group can use this command."
I opened System->Administration->Users and Groups. I searched and there wasn't any group named "dip". I created one and added myself. I rebooted but the same problem persists.

Note1: sudo pon works fine
Note2: This problem didn't exist in Feisty/Gutsy/Hardy. So this is definetely a regression.

Just a small update. The same problem persists in 8.10 amd64.

UbuntuB (sinir6-ubuntu) wrote :

I can confirm this issue.

It Looks like the regular user isn't registered with the "dip" group by default.

I tried it this way:

Open terminal.

Add the user to the "dip" group by entering:

sudo adduser USERNAME dip

Log out and in again.

Hope this helps.

(Source: http://www.andreas-janssen.de/debian-tipps-sarge.html.de see: 11. Benutzergruppen )

Thank you it worked!

Note: I had also removed network-manager just before using this. So if this doesn't work try to remove networkmanager too.

hpp3 (hpp3) wrote :

Bug exists in Ubuntu 8.04.1

In a terminal I typed "groups" and I was listed as being part of the 'dip' group.
Typed "adduser <username> dip" and was told I was already part of the dip group.
Removed myself from the dip group and added again, rebooted. Same error.
Rebooted to a Recovery screen and removed/added as Root. Rebooted, same error.
I have done everything I can to get this to work to no avail.
It breaks wvdial as well, because apparently it can't start pppd for the same reason.

Perhaps I'll try removing networkmanager, but I don't see how that would be the reason.

matt (mce230) wrote :

I had the same problem, here's how I fixed it:

tried "adduser <username> dip", but that didn't work
turns out, /etc/ppp/peers and /usr/sbin/pppd are setup to only be executable by users who are members of THE GROUP WITH GROUP ID 30.
Apparently this is supposed to be the "dip" group, but that group wasn't on my system (ubuntu intrepid).
I went to System->Administration->Users and Groups and added a new group called dip which has GID 30 (not 1001 as is the default) and added myself to it.
restarted, and pon works just fine now.

Hope that helps.

hpp3 (hpp3) wrote :

Thanks matt. I'm taking note of your solution as it's far easier than what I ended up doing.
Apparently, permissions on the folders and files is not so kosher either, so I cross-checked all relevant files from an older 6.10 installation that worked, and changed the permissions and owners as listed:
----------------------------------
  rwsr-xr-- root dip /usr/sbin/ppd
  rwxr-xr-x root root /usr/bin/pon

drwxr-xr-x root dip /etc/ppp
drwxr-x--- root dip /etc/ppp/peers
  rw-r----- root dip /etc/ppp/peers/provider
(same for any custom provider entries you may have made with pppconf)
  rw-r--r-- root root /etc/ppp/peers/wvdial
  rw-r--r-- root root /etc/ppp/peers/wvdial-pipe

drwxr-s--- root dip /etc/chatscripts
  rw-r----- root dip /etc/chatscripts/provider
----------------------------------
Either way, I think this bug may be solved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers