systemd 234-2ubuntu9 ADT test failure with linux 4.13.0-9.10

Bug #1715397 reported by Seth Forshee on 2017-09-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
Critical
Canonical Foundations Team
ppc64-diag (Ubuntu)
Critical
Canonical Foundations Team
Trusty
Critical
Unassigned
Xenial
Critical
Unassigned
Seth Forshee (sforshee) on 2017-09-06
tags: added: kernel-adt-failure
Seth Forshee (sforshee) wrote :
Download full text (3.3 KiB)

ep 06 12:23:41 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: Starting ppc64-diag rtas_errd (platform error handling) Service...
Sep 06 12:23:41 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: Started ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: rtas_errd.service: Service hold-off time over, scheduling restart.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: Stopped ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: Starting ppc64-diag rtas_errd (platform error handling) Service...
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: Started ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: rtas_errd.service: Service hold-off time over, scheduling restart.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: Stopped ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: Starting ppc64-diag rtas_errd (platform error handling) Service...
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: Started ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: rtas_errd.service: Service hold-off time over, scheduling restart.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: Stopped ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: Starting ppc64-diag rtas_errd (platform error handling) Service...
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: Started ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: rtas_errd.service: Service hold-off time over, scheduling restart.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: Stopped ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: Starting ppc64-diag rtas_errd (platform error handling) Service...
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: Started ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: rtas_errd.service: Service hold-off time over, scheduling restart.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: Stopped ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: rtas_errd.service: Start request repeated too quickly.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: Failed to start ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare syste...

Read more...

Seth Forshee (sforshee) wrote :

I see adt failures with 4.12 as well, looks like a regression in ppc64-diag. Changing affected package.

affects: systemd (Ubuntu) → ppc64-diag (Ubuntu)
Changed in ubuntu-power-systems:
importance: Undecided → Critical

Barry,

The kernel team discovered a potential regression in ppc64-diag
package. You can find the details in the bug report:
https://launchpad.net/bugs/1715397

Could you please mirror this bug internally and assign it to the
appropriate person at IBM to fix this issue? The upstream maintainer
for this package is https://launchpad.net/~frediz (Frédéric Bonnard).

Thanks
Manoj Iyer

bugproxy (bugproxy) on 2017-09-06
tags: added: architecture-ppc64le bugnameltc-158362 severity-high targetmilestone-inin1710
Manoj Iyer (manjo) on 2017-09-07
Changed in ppc64-diag (Ubuntu):
importance: Undecided → Critical
bugproxy (bugproxy) on 2017-09-07
tags: added: severity-critical
removed: severity-high
Manoj Iyer (manjo) wrote :

Kernel team, IBM is working on a fix with top priority. Please stay tuned for a fix from Fred.

------- Comment From <email address hidden> 2017-09-08 06:59 EDT-------
(In reply to comment #6)
> Kernel team, IBM is working on a fix with top priority. Please stay tuned
> for a fix from Fred.

Very bad :-( accidently I added "=|!" instead of "=|" in upstream which is causing below warnings in syslog.

This is just a warning comes on PowerNV host and safe to ignore.

Below patch should fix this issue . Can you please verify ?

diff --git a/scripts/rtas_errd.service b/scripts/rtas_errd.service
index 5507b8a..8475c3e 100644
--- a/scripts/rtas_errd.service
+++ b/scripts/rtas_errd.service
@@ -1,7 +1,7 @@
[Unit]
Description=ppc64-diag rtas_errd (platform error handling) Service
-ConditionPathExists=|!/proc/ppc64/rtas/error_log
-ConditionPathExists=|!/proc/ppc64/error_log
+ConditionPathExists=|/proc/ppc64/rtas/error_log
+ConditionPathExists=|/proc/ppc64/error_log
After=syslog.target

[Service]

-Vasant

Frédéric Bonnard (frediz) wrote :

Thanks Vasant for double checking the fix.
The patch is in ppc64-diag 2.7.4-2 in Unstable.

F.

Manoj Iyer (manjo) on 2017-09-08
Changed in ppc64-diag (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in ubuntu-power-systems:
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Steve Langasek (vorlon) wrote :

This bug was fixed in the package ppc64-diag - 2.7.4-2

---------------
ppc64-diag (2.7.4-2) unstable; urgency=medium

  * d/patches/fix-rtas_errd-unit.patch : fix rtas_errd being started where it
    should not and being reported by systemd as failing whereas the daemon
    exits as it should (LP: #1715397)

 -- Frédéric Bonnard <email address hidden> Fri, 08 Sep 2017 11:08:42 +0000

Changed in ppc64-diag (Ubuntu):
status: New → Fix Released
Changed in ubuntu-power-systems:
status: New → Fix Released

Hello Seth, or anyone else affected,

Accepted ppc64-diag into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ppc64-diag/2.7.4-2~16.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ppc64-diag (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Seth, or anyone else affected,

Accepted ppc64-diag into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ppc64-diag/2.7.4-2~14.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ppc64-diag (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed-trusty
Changed in ppc64-diag (Ubuntu Trusty):
importance: Undecided → Critical
Changed in ppc64-diag (Ubuntu Xenial):
importance: Undecided → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers