apt-get not used as package manager

Bug #706774 reported by Germán Pabón
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ppa-purge (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ppa-purge

Because of LP: #641142 "aptitude" is now a dependency of ppa-purge. In recent Ubuntu versions, this package is no longer installed by default, because everything it does can be made by apt-get instead.

Now, trying to install ppa purge makes the user install aptitude, even when the program can use apt-get. This behavior should change, and ppa purge should use the package manager that is installed on the system (either aptitude or apt-get, it should check on run time).

Related branches

Revision history for this message
Micah Gersten (micahg) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as Triaged and let them handle it from here. Thanks for taking the time to make Ubuntu better! Please report any other issues you may find.

Changed in ppa-purge (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Revision history for this message
Robert Hooker (sarvatt) wrote :

The reason aptitude is also used is because apt-get can not handle a package existing in the PPA that does not exist in the archive (sudo apt-get install libglapi-mesa/natty for example, libglapi-mesa only existing in ppa:xorg-edgers/ppa at the moment) so it falls back to using aptitude that will work right in that situation. ppa-purge would have to grow some extra logic for removing packages that don't exist from the list to work with only apt-get.

Revision history for this message
Brian Murray (brian-murray) wrote :

This bug is not acceptable for including as a Stable Release Update in 12.04 as it has not been fixed in the development release of Ubuntu. Additionally, this change has not made it into 12.10 so we'd have ppa-purge using aptitude in that release still. I mean would move from using apt-get (12.04) to aptitude (12.10) back to apt-get (13.04).

Revision history for this message
Tim Lunn (darkxst) wrote :

Brian, for the Aptitude version in 12.04, the dependency resolver is completely broken for multi-arch systems (this is fixed in 12.10 aptitude). As a consequence ppa-purge is completely broken on 12.04.

anyway I will ping sarvatt again and try get this merged into raring

Revision history for this message
Chris Halse Rogers (raof) wrote :

I've rejected this from the precise-proposed queue; the upload also claims to fix bug #831768, which isn't a ppa-purge bug.

Once bug #831768 is fixed is there any further reason to SRU the change to use apt-get rather than aptitude? That seems like an unnecessary change.

Revision history for this message
Tim Lunn (darkxst) wrote :

Chris, In theory no, the fixes from bug #892886 and bug #831768, should be enough to get things working properly.

However I do believe xorg-edgers still failed to purge properly without this fix. (However that was on Quantal where both the above bugs are fixed)

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ppa-purge - 0.2.8+bzr63

---------------
ppa-purge (0.2.8+bzr63) xenial; urgency=low

  * Add bash autocompletion and tweak options slightly. (LP: #1064205)
  * Specify removal of packages that don't exist in Ubuntu (LP: #706774)
  * Add some logic to handle packages that have had a soname bump, packages with
    manual renames will still break, however these should be pretty rare. (LP: #1392954)
  * Add Vcs-fields, Thanks Dominique Lasserre

 -- Tim Lunn <email address hidden> Fri, 30 Nov 2012 08:25:57 +1100

Changed in ppa-purge (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Jarno Suni (jarnos) wrote :

Even in case of comment #2, aptitude is not needed to purge packages at least in Ubuntu 14.04, when using ppa-purge - 0.2.8+bzr63. Consequently, I think aptitude is not needed as an alternative in the script. ppa-purge (0.2.8+bzr63) still seems to have aptitude potentially used e.g. in case `apt-get install` fails which may happen, if user answers 'n' to apt-get's prompt!

Revision history for this message
Tim Lunn (darkxst) wrote :

aptitude has a more powerful dependency resolver, if for any reason apt-get can't figure out what to do, then it will fallback to aptitude. This will happen if the revert list sent to apt-get is not 100% correct and complete.

I am not sure if the fallback ever happens now, it certainly shouldnt on simple ppa's but on complex ones that ship lots of core libs (like gnome3-staging) it may. A good test case would be to try pp-purge gnome3-staging on 15.10

Revision history for this message
Jarno Suni (jarnos) wrote :

User should be able to trust apt-get. Is there a bug report for the issues with apt-get?

BTW at least newer releases have command apt in package apt. Is that powerful enough?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers