Ubuntu

Powertop fails to report number of wakeups/events

Reported by Hernando Torque on 2011-08-26
238
This bug affects 43 people
Affects Status Importance Assigned to Milestone
powertop
Fix Released
Unknown
linux (Ubuntu)
Undecided
Seth Forshee
Oneiric
Undecided
Seth Forshee
Precise
Undecided
Seth Forshee
powertop (Ubuntu)
Medium
Unassigned
Oneiric
Undecided
Unassigned
Precise
Medium
Unassigned

Bug Description

Powertop doesn't show any useful information concerning wakeups on two systems (PC, notebook). E.g. I get:

Summary: 0.0 wakeups/second, 0.0 GPU ops/second and 0.0 VFS ops/sec

                Usage Events/s Category Description
            100.0% Device Audio codec hwC0D3: Intel
            100.0% Device Audio codec hwC0D0: Realt
             28.5 ms/s 0.0 Process compiz --replace
             19.0 ms/s 0.0 Process /usr/bin/X :0 vt7 -nolist
             16.1 ms/s 0.0 Process /usr/lib/chromium-browser
             12.8 ms/s 0.0 Process /usr/lib/opera/opera
             12.8 ms/s 0.0 Process /usr/lib/unity/unity-pane

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: powertop 1.97-2
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
Architecture: amd64
Date: Fri Aug 26 15:33:43 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110630)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: powertop
UpgradeStatus: No upgrade log present (probably fresh install)

Hernando Torque (htorque) wrote :
Changed in powertop (Ubuntu):
status: New → Confirmed
Paul Sladen (sladen) wrote :

"Summary: 0.0 wakeups/second, 0.0 GPU ops/second and 0.0 VFS ops/sec" - powertop

Kernel team: could it be that we've dropped a kernel feature/interface that Powertop needs, thus causing Powertop to silently fail?

Changed in powertop (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 834725

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.22.1-0ubuntu2
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sladen 1631 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf8220000 irq 46'
   Mixer name : 'Analog Devices AD1984'
   Components : 'HDA:11d41984,17aa20dd,00100400'
   Controls : 32
   Simple ctrls : 20
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 7RHT16WW-1.02'
   Mixer name : 'ThinkPad EC 7RHT16WW-1.02'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
DistroRelease: Ubuntu 11.10
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=54efcb99-bd31-4d0e-9094-e8ca0bc3b83b
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
IwConfig: Error: [Errno 2] No such file or directory
MachineType: LENOVO 776295G
Package: powertop 1.97-2
PackageArchitecture: i386
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=bb337846-9422-4826-b35c-641bca621295 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-11.17-generic 3.0.4
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-11-generic N/A
 linux-backports-modules-3.0.0-11-generic N/A
 linux-firmware 1.60
RfKill: Error: [Errno 2] No such file or directory
Tags: oneiric running-unity oneiric running-unity
UdevDb: Error: [Errno 2] No such file or directory
Uname: Linux 3.0.0-11-generic i686
UpgradeStatus: Upgraded to oneiric on 2011-08-28 (16 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 07/03/2007
dmi.bios.vendor: LENOVO
dmi.bios.version: 7SET18WW (1.04 )
dmi.board.name: 776295G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7SET18WW(1.04):bd07/03/2007:svnLENOVO:pn776295G:pvrThinkPadX61Tablet:rvnLENOVO:rn776295G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 776295G
dmi.product.version: ThinkPad X61 Tablet
dmi.sys.vendor: LENOVO

tags: added: apport-collected

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

I suspect this is likely due to changes in powertop. The same issue was reported by another user as testing feedback for the powertop 2.0 beta release earlier this year:

http://article.gmane.org/gmane.linux.power-management.powertop/1959

I subsequently tested the Natty powertop-1.13-1.1ubuntu1 while running an Oneiric 3.0.0-11.17 kernel and confirm wakeups are being calculated:

     PowerTOP version 1.13 (C) 2007 Intel Corporation

Cn Avg residency P-states (frequencies)
C0 (cpu running) ( 0.7%) Turbo Mode 5.5%
polling 0.9ms ( 0.0%) 2.80 Ghz 0.0%
C1 mwait 0.5ms ( 0.3%) 2.67 Ghz 0.0%
C2 mwait 0.8ms ( 4.0%) 1.87 Ghz 0.9%
C3 mwait 6.4ms (95.0%) 1197 Mhz 93.6%

Wakeups-from-idle per second : 203.8 interval: 15.0s

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel currently in the release pocket than the one you tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-11.18
Hernando Torque (htorque) wrote :

linux-image-3.0.0-11-generic:
  Installed: 3.0.0-11.18
  Candidate: 3.0.0-11.18

Still an issue.

Also an issue with the mainline kernel from the PPA (201108310919).

I can confirm Leann's finding: Natty's Powertop version works fine in Oneiric.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Hernando Torque (htorque) wrote :

Debin bug at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=620056 suggests Powertop 1.97 having problems with 64-bit systems. Currently cannot test it on a 32-bit system.

As I don't believe this is an issue with the kernel, I'm closing the linux task as Invalid. The powertop task remains open. Thanks.

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Andy Whitcroft (apw) wrote :

@htorque -- i see the same missing stats on a 32 bit install. 0/0 wakeups per second, and no frequency stats.

Changed in powertop:
status: Unknown → New
Changed in powertop:
status: New → Fix Released
Jason Frost (jasonf) wrote :

Bug confirmed in powertop version 1.97-2 and kernel version 3.0.0-12-generic

Christian Mertes (cmertes) wrote :

I'm having the same issue, Idle stats and Frequency stats tabs are completely empty. Occurs on a 64bit Oneiric running on an HP Proliant N36L microserver. I'm attaching the lshw output.

Harry P (hjwp2) wrote :

affects me too. happy to help if any dumps would be helpful?

Hernando Torque (htorque) wrote :

Too bad upstream marks this as fixed without adding some real information. I'm now confirming this for Precise.

Harry P (hjwp2) wrote :

I've just downloaded the latest version, and compiled from source - it works fine.

Hernando Torque (htorque) wrote :

1.13 is not the latest version, though. :-)

Matt Stevenson (saturnreturn) wrote :

Won't the fixed version appear in the Oneiric updates then? Would seem strange to leave 11.10 with a broken version

Jeff Johnson (jeffjohnson0) wrote :

It appears that there are some system files that are not present. Powertop is looking for the following files and not finding them:

"/sys/kernel/debug/tracing/events/power/power_frequency/id"
"/sys/kernel/debug/tracing/events/power/power_frequency/id"
"/sys/kernel/debug/tracing/events/power/power_start/id"
"/sys/kernel/debug/tracing/events/power/power_start/id"
"/sys/kernel/debug/tracing/events/power/power_end/id"
"/sys/kernel/debug/tracing/events/power/power_end/id"
"/sys/kernel/debug/tracing/events/power/power_start/id"
"/sys/kernel/debug/tracing/events/power/power_start/id"
"/sys/kernel/debug/tracing/events/power/power_end/id"
"/sys/kernel/debug/tracing/events/power/power_end/id"
"/sys/kernel/debug/tracing/events/i915/i915_gem_request_submit/id"
"/sys/kernel/debug/tracing/events/i915/i915_gem_request_submit/id"
"/sys/kernel/debug/tracing/events/writeback/writeback_inode_dirty/id"
"/sys/kernel/debug/tracing/events/writeback/writeback_inode_dirty/id"

Incidentally, the following 'id' files are present:
root@Laptop1:/sys/kernel/debug/tracing/events/power# find . -name id -print
./cpu_idle/id
./cpu_frequency/id
./machine_suspend/id
./clock_enable/id
./clock_disable/id
./clock_set_rate/id
./power_domain_target/id

This is using version 1.9.7 on an older HP laptop.

--J

Jeff Johnson (jeffjohnson0) wrote :

It looks like there are some commits to obsolete some of those power events. I can't quite tell if they are supposed to be in the 3.0 kernel or not.

See: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commit;h=25e41933b58777f2d020c3b0186b430ea004ec28

--J

Seth Forshee (sforshee) wrote :

We need to have EVENT_POWER_TRACING_DEPRECATED enabled in the kernel config to get the trace events that powertop is expecting. I've verified that this fixes the issue. powertop needs to be fixed as the tracepoints are going to be removed completely in the near future, but in the interim I'm going to send patches for oneiric and precise to enable the tracepoints.

Changed in linux (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
status: Invalid → In Progress
Seth Forshee (sforshee) on 2011-11-03
Changed in linux (Ubuntu Oneiric):
assignee: nobody → Seth Forshee (sforshee)
status: New → In Progress
Harry P (hjwp2) wrote :

just want to make sure everyone is quite clear: upgrading to the latest version of powertop fixes the problem. (apologies if everyone already knew that, just wanted to make sure no-one was wasting their time, no offense meant etc)

Seth Forshee (sforshee) wrote :

Harry P: Can you clarify what you mean by "latest version"? The latest version in oneiric doesn't seem to have a fix.

Hernando Torque (htorque) wrote :

Given comments #33 and #34, I think he means 1.13, which isn't the latest version (that homepage could do with an update :-)).

Seth Forshee (sforshee) on 2011-11-04
Changed in linux (Ubuntu Oneiric):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in powertop (Ubuntu Oneiric):
status: New → Confirmed
MMlosh (mmlosh) wrote :

found on 32 bit oneric, HP laptop

Andrew Cowie (afcowie) wrote :

Still happening in Oneiric with powertop 1.97; can you tell us which kernel version you committed the fix to?

AfC

On Sat, Nov 19, 2011 at 01:13:59PM -0000, Andrew Cowie wrote:
> Still happening in Oneiric with powertop 1.97; can you tell us which
> kernel version you committed the fix to?

The fix has been comitted but not released, so there is not yet any
version of the kernel for Oneiric which contains the fix. When there's a
build with the fix available for testing a comment will be posted to
this bug.

dino99 (9d9) on 2013-05-18
Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Invalid
Changed in powertop (Ubuntu Oneiric):
status: Confirmed → Invalid
tags: added: precise
removed: oneiric
Julian Wiedmann (jwiedmann) wrote :

Precise, Quantal and Raring all have CONFIG_EVENT_POWER_TRACING_DEPRECATED=y. Regarding Saucy+, these events were removed with 3.9.

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.