Ubuntu

powertop crashed with SIGSEGV in strstr()

Reported by Ryan on 2009-09-12
226
This bug affects 44 people
Affects Status Importance Assigned to Milestone
powertop (Ubuntu)
Medium
James Westby

Bug Description

Binary package hint: powertop

Tried to run - it segfaulted Ubuntu 9.10 alpha - crash data attached.

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Fri Sep 11 21:27:47 2009
Dependencies:
 findutils 4.4.2-1
 gcc-4.4-base 4.4.1-3ubuntu3
 libc6 2.10.1-0ubuntu8
 libgcc1 1:4.4.1-3ubuntu3
 libncursesw5 5.7+20090803-2ubuntu1
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/sbin/powertop
NonfreeKernelModules: nvidia
Package: powertop 1.11-1
ProcCmdline: powertop
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-10.32-generic
SegvAnalysis:
 Segfault happened at: 0x2ac057 <strstr+23>: movzbl (%edx),%eax
 PC (0x002ac057) ok
 source "(%edx)" (0x080e0058) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: powertop
StacktraceTop:
 strstr () from /lib/tls/i686/cmov/libc.so.6
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: powertop crashed with SIGSEGV in strstr()
Uname: Linux 2.6.31-10-generic i686
UserGroups:

Ryan (ubuntu-draziw) wrote :

StacktraceTop:*__GI_strstr (haystack_start=0x80e0058 <Address 0x80e0058 out of bounds>,
suggest_kernel_config (
main (argc=0, argv=0xf200) at powertop.c:1080

Changed in powertop (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Ryan (ubuntu-draziw) on 2009-09-12
visibility: private → public
Simon Olofsson (simono) on 2009-09-18
Changed in powertop (Ubuntu):
status: New → In Progress
assignee: nobody → Simon Olofsson (simono)
Simon Olofsson (simono) wrote :

The linked branch contains a fix for this. I'll soon upload a updated package to my PPA for testing.

Václav Šmilauer (eudoxos) wrote :

Concirming Simon's branch fixes the bug. Please promote to karmic.

Simon Olofsson (simono) wrote :

The package is now available in my PPA. Please test it and report if it works.
Thanks!

Changed in powertop (Ubuntu):
status: In Progress → Incomplete
Fruchtnektar (mail-jan-khan) wrote :

The package, avilable in Simons PPA, fixes my problem. Thank you.

Works OK on my system with NC10 backport kernel from Voria.

On Sat, 19 Sep 2009 12:49:21 -0000, Fruchtnektar <email address hidden> wrote:
> The package, avilable in Simons PPA, fixes my problem. Thank you.

Ryan (ubuntu-draziw) wrote :

Simon: Your version runs great! Would probably be good to label the version as ubuntu2 vs ubuntu1 just so it's easy to see which version is installed.
$ apt-cache policy powertop
powertop:
  Installed: 1.11-1ubuntu1
  Candidate: 1.11-1ubuntu1
  Version table:
 *** 1.11-1ubuntu1 0
        100 /var/lib/dpkg/status
     1.11-1 0
        500 http://archive.ubuntu.com karmic/main Packages

Changed in powertop (Ubuntu):
status: Incomplete → In Progress
Simon Olofsson (simono) wrote :

Thanks for your feedback. I'll subscribe the sponsors, so that this package gets uploaded.
Ryan, 1.11-1ubuntu1 is the correct version, because it's the first Ubuntu specific change in this package.

Changed in powertop (Ubuntu):
status: In Progress → Confirmed
assignee: Simon Olofsson (simono) → nobody

The package from PPA works for me also

James Westby (james-w) wrote :

Taking for sponsorship from the merge request.

Thanks,

James

Changed in powertop (Ubuntu):
assignee: nobody → James Westby (james-w)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package powertop - 1.11-1ubuntu1

---------------
powertop (1.11-1ubuntu1) karmic; urgency=low

  * debian/patches/increase-buffer-for-kernel-config.dpatch:
    - Fix a segfault when kernel config is longer than 5000 lines
      (LP: #428254)

 -- Simon Olofsson <email address hidden> Fri, 18 Sep 2009 14:40:37 +0200

Changed in powertop (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.