Powertop does not display correctly

Bug #1091063 reported by Pierre van Male on 2012-12-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
powertop (Ubuntu)
Undecided
Unassigned

Bug Description

After installation, Powertop was working properly, but soon later, it stopped displaying correctly in the terminal.

All the processes are displayed one after the other like this:
"/lib/x86_64-linux-gnu/libnl-genl-3.so.200.5.2
                                                         7f70d157e000-7f70d157f000 rw-p 00004000 08:01 13491"

and the terminal stopped breaking the line: entering enter does not make the prompt swith to a new line.

Since Powertop was working at first, I expect that I broke it with a later operation. I made some modifications linked to power consumption (including extra parameters for grub), but a priori, I do not see any link.

See the attachement for better understanding...

Best regards,
Pierre

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: powertop 2.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-19.30-generic 3.5.7
Uname: Linux 3.5.0-19-generic x86_64
ApportVersion: 2.6.1-0ubuntu9
Architecture: amd64
Date: Sun Dec 16 21:24:10 2012
EcryptfsInUse: Yes
MarkForUpload: True
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: powertop
UpgradeStatus: No upgrade log present (probably fresh install)

Pierre van Male (vmalep) wrote :
Pierre van Male (vmalep) wrote :

If I am not mistaken, I made the following modifications to the system after having installed and run powertop without problem:
1) added the following parameters to grub: "pcie_aspm=force i915.i915_enable_rc6=1 i915.lvds_downclock=1 i915.i915_enable_fbc=1"
2) installed the following packages: tlp tlp-rdw tp-smapi-dkms smartmontools ethtool

I removed them and restarted the system, but the problem persists.

I am attaching the html output of powertop that shows that powertop works properly (but does not displays properly in the terminal).

BR
Pierre

Pierre van Male (vmalep) wrote :

I tried again today (22.12.2012) and this time, powertop is displayed correctly. I am hence unable to reproduce the bug again and therefore, I moved it to invalid state.

BR
Pierre

Changed in powertop (Ubuntu):
status: New → Invalid
Pierre van Male (vmalep) wrote :

Sorry, the problem reappeared after reboot... Moved to new and waiting instruction to better diagnose it.

Changed in powertop (Ubuntu):
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers