[LTCTest][Opal][OP820] update_flash -d option is throwing /usr/sbin/update_flash_nv: 595: [: x47: unexpected operator

Bug #1599191 reported by bugproxy on 2016-07-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
powerpc-utils (Ubuntu)
Undecided
Taco Screen team
Xenial
Undecided
Unassigned

Bug Description

[SRU Justification]
On an OpenPower system, '/usr/sbin/update_flash_nv -d' will print a gratuitous error message, and will not correctly report failures to query the firmware version.

[Test case]
1. On an OpenPower system (as determined by the presence of the file /proc/device-tree/bmc), run 'sudo update_flash_nv -d'. Observe that an error message is printed before the version information.
2. Install powerpc-utils from xenial-proposed.
3. Run 'sudo update_flash_nv -d' again. Verify that no error message is printed.

[Regression potential]
Minimal. This is a targeted, one-line fix for a bashism in a shell script.

---Problem Description---
update_flash -d option is throwing [: x47: unexpected operator message

---uname output---
Linux ltc-garri2 4.4.0-30-generic #49-Ubuntu SMP Fri Jul 1 10:00:36 UTC 2016 ppc64le ppc64le ppc64le GNU/Linux

Machine Type = P8

---Steps to Reproduce---
 Install a P8 8335-GTB Hardware with Ubuntu 16.04.1 OS.
Then execute the below command to check the version of the firmware installed on the machine.

root@ltc-garri2:~# update_flash -d

/usr/sbin/update_flash_nv: 595: [: x47: unexpected operator
Firmware version:
 Product Name : OpenPOWER Firmware
 Product Version : IBM-garrison-ibm-OP8_v1.9_2.1
 Product Extra : op-build-dcacfac
 Product Extra : buildroot-bc248fa
 Product Extra : skiboot-5f25590
 Product Extra : hostboot-4c63029-6034fa6
 Product Extra : linux-4.4.9-openpower2-ebc7b6d
 Product Extra : petitboot-v1.1.1-fc477ec
 Product Extra : garrison-xml-b453a81
 Product Extra : occ-19a3ebc
 Product Extra : hostboot-binar
root@ltc-garri2:~# echo $?
0

root@ltc-garri2:~# which update_flash
/usr/sbin/update_flash

root@ltc-garri2:~# dpkg -S /usr/sbin/update_flash
powerpc-ibm-utils: /usr/sbin/update_flash
root@ltc-garri2:~# dpkg --list | grep powerpc-ibm-utils
ii powerpc-ibm-utils 1.3.1-2 ppc64el utilities for maintenance of IBM PowerPC platforms

Userspace tool common name: /usr/sbin/update_flash

The userspace tool has the following bit modes: 64-bit

Userspace package: powerpc-ibm-utils

Below upstream patch fixes this issue:

commit c3269d4e3d4882fd931d1df6aece0bec86fb6734
Author: Vasant Hegde <email address hidden>
Date: Thu Jun 30 10:26:58 2016 -0400

    update_flash: Fix bashism issue in opp_display_current_fw_version()

    Ubuntu uses dash, not bash. We hit below warning on Ubuntu system.

    root@abc:/sys/firmware/devicetree/base/ibm,opal/sensors# update_flash -d
    /usr/sbin/update_flash_nv: 595: [: x43: unexpected operator
    Firmware version:
    ....
    ....

    == is a bashism. Replace it with =.

    Fixes: 767e3dd7 (update_flash: Add support for OpenPower system)
    Signed-off-by: Vasant Hegde <email address hidden>

-Vasant

bugproxy (bugproxy) on 2016-07-05
tags: added: architecture-ppc64le bugnameltc-143371 severity-high targetmilestone-inin16041
Changed in ubuntu:
assignee: nobody → Taco Screen team (taco-screen-team)
affects: ubuntu → powerpc-ibm-utils (Ubuntu)
Steve Langasek (vorlon) on 2016-07-05
affects: powerpc-ibm-utils (Ubuntu) → powerpc-utils (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package powerpc-utils - 1.3.1-2ubuntu1

---------------
powerpc-utils (1.3.1-2ubuntu1) yakkety; urgency=medium

  * debian/patches/bashisms.patch: Fix bashism in update_flash_nv.
    Closes LP: #1599191.

 -- Steve Langasek <email address hidden> Tue, 05 Jul 2016 15:52:05 -0700

Changed in powerpc-utils (Ubuntu):
status: New → Fix Released

Hello bugproxy, or anyone else affected,

Accepted powerpc-utils into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/powerpc-utils/1.3.1-2ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in powerpc-utils (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) on 2016-07-06
description: updated

------- Comment From <email address hidden> 2016-07-07 00:22 EDT-------
I have installed the proposed powerpc-utils package from the link provided:
https://launchpad.net/ubuntu/xenial/ppc64el/powerpc-ibm-utils/1.3.1-2ubuntu0.1

root@ltc-garri2:~# dpkg --list | grep powerpc-utils
ii powerpc-utils 1.3.1-2ubuntu0.1 ppc64el utilities for maintenance of PowerPC platforms (metapackage)

root@ltc-garri2:~# which update_flash
/usr/sbin/update_flash
root@ltc-garri2:~# dpkg -S /usr/sbin/update_flash
powerpc-ibm-utils: /usr/sbin/update_flash

root@ltc-garri2:~# update_flash -d

Firmware version:
Product Name : OpenPOWER Firmware
Product Version : IBM-garrison-ibm-OP8_v1.9_2.1
Product Extra : op-build-dcacfac
Product Extra : buildroot-bc248fa
Product Extra : skiboot-5f25590
Product Extra : hostboot-4c63029-6034fa6
Product Extra : linux-4.4.9-openpower2-ebc7b6d
Product Extra : petitboot-v1.1.1-fc477ec
Product Extra : garrison-xml-b453a81
Product Extra : occ-19a3ebc
Product Extra : hostboot-binar

The issue is resolved with the powerpc-utils_1.3.1-2ubuntu0.1 package.

tags: added: verification-done
removed: verification-needed
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2016-07-11 02:34 EDT-------
(In reply to comment #7)
> I have installed the proposed powerpc-utils package from the link provided:
> https://launchpad.net/ubuntu/xenial/ppc64el/powerpc-ibm-utils/1.3.1-2ubuntu0.
> 1
>
> root@ltc-garri2:~# dpkg --list | grep powerpc-utils
> ii powerpc-utils 1.3.1-2ubuntu0.1
> ppc64el utilities for maintenance of PowerPC platforms (metapackage)
>
> root@ltc-garri2:~# which update_flash
> /usr/sbin/update_flash
> root@ltc-garri2:~# dpkg -S /usr/sbin/update_flash
> powerpc-ibm-utils: /usr/sbin/update_flash
>
> root@ltc-garri2:~# update_flash -d
>
> Firmware version:
> Product Name : OpenPOWER Firmware
> Product Version : IBM-garrison-ibm-OP8_v1.9_2.1
> Product Extra : op-build-dcacfac
> Product Extra : buildroot-bc248fa
> Product Extra : skiboot-5f25590
> Product Extra : hostboot-4c63029-6034fa6
> Product Extra : linux-4.4.9-openpower2-ebc7b6d
> Product Extra : petitboot-v1.1.1-fc477ec
> Product Extra : garrison-xml-b453a81
> Product Extra : occ-19a3ebc
> Product Extra : hostboot-binar
>
> The issue is resolved with the powerpc-utils_1.3.1-2ubuntu0.1 package.

Thanks. Closing this bug.

-Vasant

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package powerpc-utils - 1.3.1-2ubuntu0.1

---------------
powerpc-utils (1.3.1-2ubuntu0.1) xenial; urgency=medium

  * debian/patches/bashisms.patch: Fix bashism in update_flash_nv.
    Closes LP: #1599191.

 -- Steve Langasek <email address hidden> Tue, 05 Jul 2016 15:52:05 -0700

Changed in powerpc-utils (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for powerpc-utils has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

bugproxy (bugproxy) on 2016-07-21
affects: powerpc-utils (Ubuntu) → powerpc-ibm-utils (Ubuntu)
Steve Langasek (vorlon) on 2016-07-21
affects: powerpc-ibm-utils (Ubuntu) → powerpc-utils (Ubuntu)
bugproxy (bugproxy) on 2016-07-21
affects: powerpc-utils (Ubuntu) → powerpc-ibm-utils (Ubuntu)
Adam Conrad (adconrad) on 2016-07-22
affects: powerpc-ibm-utils (Ubuntu) → powerpc-utils (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers