logout dialog does not offer suspend/hibernate

Bug #118537 reported by Peter Clifton on 2007-06-03
62
Affects Status Importance Assigned to Milestone
powermanagement-interface (Ubuntu)
High
Unassigned
Declined for Gutsy by Daniel Holbach
Gutsy
High
Unassigned

Bug Description

Binary package hint: gnome-session

In Gutsy, with the latest update to gnome-power-manager 2.19, the DBUS name which g-p-m can be accessed has changed. The following diff fixes a long (nearly a minute) hang before the logout window appears with the new g-p-m.

We should really ensure that the absence of g-p-m does not cause this hang anyway!

--- gnome-session-2.19.2/debian/patches/11_session_dialog.patch 2007-06-03 19:30:31.000000000 +0100
+++ gnome-session-2.19.2-pcjc2/debian/patches/11_session_dialog.patch 2007-06-03 19:08:57.000000000 +0100
@@ -76,9 +76,9 @@
  #define FADE_DURATION 1500.0
  #define SATURATION_TARGET 0.5

-+#define GPM_DBUS_SERVICE "org.gnome.PowerManager"
-+#define GPM_DBUS_PATH "/org/gnome/PowerManager"
-+#define GPM_DBUS_INTERFACE "org.gnome.PowerManager"
++#define GPM_DBUS_SERVICE "org.freedesktop.PowerManagement"
++#define GPM_DBUS_PATH "/org/freedesktop/PowerManagement"
++#define GPM_DBUS_INTERFACE "org.freedesktop.PowerManagement"
 +
  static void
  get_current_frame (FadeoutData *fadeout,

Peter Clifton (pcjc2) wrote :

Here is a more complete fix (which actually allows suspend and resume again). The method names were changed when standardising.

Daniel Holbach (dholbach) wrote :

Thanks for writing the patch. I'll make sure it gets uploaded after Tribe1 freeze. Thanks again.

Changed in gnome-session:
assignee: nobody → dholbach
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Daniel Holbach (dholbach) wrote :

My version of the patch was doing the same that your version 1 did, but the second patch is much more complete. Thanks for that.

Martin Pitt (pitti) wrote :

The current version does not hang any more, but still does not give hibernate and suspend options. This should be fixed by Tribe-2 and release-noted for Tribe-1.

Changed in gnome-session:
importance: Medium → High
Peter Clifton (pcjc2) wrote :

Thanks for the credit in the changelog, but I just grabbed the package and it doesn't work.

The line changed:

+#define GPM_DBUS_INTERFACE "org.freedesktop.PowerManagement.Inhibit"

instead of my patches:

+#define GPM_DBUS_INTERFACE "org.freedesktop.PowerManagement"

Perhaps we need to use both, depending on what we're doing.

I'll investigate and try to work up a new patch.

Peter Clifton (pcjc2) wrote :

No - I can't see any of the Inhibit methods needed by gnome-session.

if you untar gnome-power-manager, you can see the interfaces and methods supported under gnome-power-manager-2.19.2/src/dbus/*.xml

Was the ".Inhibit" on the GPM_DBUS_INTERFACE just a mistake, or am I missing something here?

Daniel Holbach (dholbach) wrote :

I hope it's fixed with 2.19.3-0ubuntu2.

Please reopen if there are still problems.

Changed in gnome-session:
status: Confirmed → Fix Released
Jos Dehaes (jos-dehaes) wrote :

fixed for me with said version.

Bart Samwel (bart-samwel) wrote :

As I said in #118819 (a duplicate of this bug), it's not fixed for me. I still get a one-minute delay the first time. If I cancel and try again, the quit dialog appears pretty much immediately. Interesting thing: the inhibit applet shows a different icon before the hang and after. Before the hang it shows something with an exclamation mark, but after the hang it starts to function properly! (Gutsy, up to date as of 2007-August-11, Dell Inspiron 9400.)

Bart Samwel (bart-samwel) wrote :

Now _this_ is weird. Apparently gnome-power-manager was disabled somehow in my session. Might have been my own doing too, I don't remember. Now that I've re-enabled it, things work as expected again. Disregard my last note...

Luis Mondesi (lemsx1) wrote :

rm -fr ~/.config/autostart/

That fixed things for me. You can go back to System->Preferences->Sessions and re-enabled (or add) whatever services you need.

Laszlo T. (tlacix) wrote :

There is no hibernate button, but there is suspend button in my logout dialog.

The hibernating works with:
sudo /etc/acpi/hibernate.sh

The Gutsy is up to date.

 lshal | grep can_suspend
  power_management.can_suspend = true (bool)
  power_management.can_suspend_hybrid = false (bool)
  power_management.can_suspend_to_disk = true (bool)
  power_management.can_suspend_to_ram = true (bool)

 gconftool-2 -g /apps/gnome-power-manager/general/can_hibernate
true

gconftool-2 -g /apps/gnome-power-manager/general/can_suspend
true

I use a swapfile.

Laszlo T. (tlacix) on 2008-01-22
Changed in gnome-session:
status: Fix Released → New
Changed in gnome-session:
assignee: dholbach → nobody
assignee: dholbach → nobody
Laszlo T. (tlacix) wrote :

I removed form fstab:

/swapfile none swap sw 0 0

and after reboot the hibernate button appeared. But it does not work without swap.

Package: powermanagement-interface
Architecture: amd64
Version: 0.3.17

Ben Klein (kleinb1) wrote :

I'm having a similar problem using Hardy from an Unpriviledged user account.

Paul Ostby (postby) wrote :

I just encountered this in Ubuntu/Gutsy after a long set of updates including a kernel upgrade from 2.6.22-14 to 2.6.22-15. After reading Bart Samwel's 2007-08-19 comment above, I navigated to System->Preferences->Sessions and found "Power Manager" was not enabled. Not sure when this got disabled. But enabling Power Manager resolved the issue for me.

Keith (keith-gsps) wrote :

Tentative success:
AT Groote Schuur Primary School I decided to upgrade to Hardy Heron followed by an LTSP install on our system and to my disappointment the Quit button did not work - same old pause for a minute and even freezing up. So I went back to these pages and read around a bit and did an apt-get install gnome-power-manager. It seems to have solved the problem. Even Hibernate works - so far. I'm not getting carried away yet - I'll give it time and report back but so far so good.

The question is: Why should one have to do this in the first place?

Sergio Zanchetta (primes2h) wrote :

The 18 month support period for Gutsy Gibbon 7.10 has reached its end of life -
http://www.ubuntu.com/news/ubuntu-7.10-eol . As a result, we are closing the
Gutsy task.

Changed in powermanagement-interface (Ubuntu Gutsy):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers