powerline fails to render with newest psutil

Bug #1379929 reported by Chris J Arges on 2014-10-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
powerline (Ubuntu)
Low
Chris J Arges

Bug Description

[Impact]
Users won't be able to use bash powerline integration.

[Test Case]
Install powerline, use bash, and do:
source /usr/lib/python2.7/dist-packages/powerline/bindings/bash/powerline.sh

[Regression Potential]
This fix is from upstream:
https://github.com/Lokaltog/powerline/commit/ecf26dfbc65e0c39001e8283e776c50899f90e1b

Chris J Arges (arges) wrote :
Chris J Arges (arges) on 2014-10-10
Changed in powerline (Ubuntu):
importance: Undecided → Low
status: New → In Progress
assignee: nobody → Chris J Arges (arges)
tags: added: patch
Chris J Arges (arges) wrote :

This patch needs something else in addition to it as it causes testcases to fail.

Chris J Arges (arges) wrote :

@jcharaoui:

Thanks that's the other commit I was missing! I've uploaded a fix with your patch.
--chris

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package powerline - 0~20140216-1ubuntu1

---------------
powerline (0~20140216-1ubuntu1) utopic; urgency=medium

  [ Jerome Charaoui ]
  * Fix powerline fails to render with newest psutil (LP: #1379929)
    - d/p/update-for-new-psutil.patch: Fixes powerline for use with psutil 2.x
    - d/p/update-tests-for-new-psutil.patch : Update tests for new psutil
 -- Chris J Arges <email address hidden> Wed, 22 Oct 2014 08:12:29 -0500

Changed in powerline (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers