MX4 ubuntu version screen won't auto-lock

Bug #1471597 reported by maarten klop
This bug affects 1 person
Affects Status Importance Assigned to Milestone
powerd (Ubuntu)

Bug Description

I'm running 15.04 r2. Initially, the screen locked nicely, but I turned that off for a while (for USB access etc). Now it's turned back on again, and it seems not to lock automatically anymore. Due to battery consumption this is a pretty annoying bug.

I ran powerd-cli test: all passed except the first:

Test: checkForDbusName(test_dbusname, 0, requests, TRUE)
    result: FAILED

Attached is the full output and the syslog entries for a period where I turn on the screen, wait for 2 minutes, and turn it off again. (lock time is 1 minute. Also doesn't turn off after 1hr)

What does it mean that testdbus_name is failing? What should happen when screen autolocks?

Revision history for this message
maarten klop (mjdklop) wrote :
affects: gnome-desktop3 (Ubuntu) → powerd (Ubuntu)
description: updated
Revision history for this message
maarten klop (mjdklop) wrote :

Ah, also the weird thing is the phone does wake up for notifications and such, so I think the monitor is still working, just neglects to turn off after stay awake time runs out.

Revision history for this message
maarten klop (mjdklop) wrote :

Actually this is also a security issue, if someone forgets to manually lock his phone, the phone will stay unlocked!

Revision history for this message
maarten klop (mjdklop) wrote :

I did a factory reset to resove this issue. That worked. I'll report back if I manage to reproduce, but I'm not shooting for that right now. As noone else is affected, that's not so productive, and I actually prefer an autolocking phone.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.