Screen doesn't auto-blank with mako during first boot (since #43)

Bug #1257048 reported by Alan Pope 🍺🐧🐱 πŸ¦„ on 2013-12-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
powerd (Ubuntu)
Undecided
Unassigned
unity-mir (Ubuntu)
Undecided
Unassigned

Bug Description

Flashed #43 (trusty-proposed) on mako.
Left phone alone for 2 hours and the screen never dimmed or went blank.

Touch phone briefly and it then goes blank after the usual 30s or so timeout.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: powerd 0.13+13.10.20131010-0ubuntu1
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.7-0ubuntu1
Architecture: armhf
Date: Mon Dec 2 20:06:54 2013
InstallationDate: Installed on 2013-12-02 (0 days ago)
InstallationMedia: Ubuntu Trusty Tahr (development branch) - armhf (20131202.2)
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 SHELL=/bin/bash
SourcePackage: powerd
UpgradeStatus: No upgrade log present (probably fresh install)

Ricardo Salveti (rsalveti) wrote :

Are you able to reproduce this issue after a reboot? Flashed #43 a few times (also did a few reboots), and unable to reproduce it locally.

Anything at /var/crash?

It only happens after you flash the phone and don't touch it. Just re-flashed the device with #43 again and sure enough it sits there with the display on permanently. No recent crashes in /var/crash

dmesg: http://paste.ubuntu.com/6513505/
process list: http://paste.ubuntu.com/6513511/

Just confirmed it happens with #45 too.

Ursula Junque (ursinha) on 2013-12-03
tags: added: r43
Ricardo Salveti (rsalveti) wrote :

Thanks for providing the logs, seems this is actually a bug in Unity8.

From your syslog, this is where the problem happens:
Dec 3 14:14:42 ubuntu-phablet powerd[851]: screen power setting failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name com.canonical.Unity.Screen was not provided by any .service files
Dec 3 14:14:42 ubuntu-phablet powerd[851]: failed to set display power mode, not clearing state

And from powerd:
"""
    case DISPLAY_STATE_OFF:
        if (actual_screen_state == DISPLAY_STATE_OFF) {
            /* Nothing to do */
            return;
        }

        powerd_debug("turning off display");
        if (using_ab)
            powerd_autobrightness_disable();
        powerd_set_brightness(0);
        if (!display_set_power_mode(0, "off")) {
            powerd_warn("failed to set display power mode, not clearing state");
            return;
        }
"""

This basically means that powerd tried to deactivate the display, but the needed Unity8 interface wasn't available at that time (name com.canonical.Unity.Screen). You also said that it works fine after interacting with the display, so I wonder if something changed in Unity8 that made the service to not be necessarily up right after the boot.

The interesting thing here is that I'm unable to reproduce it locally, and tried many times already.

affects: unity8 (Ubuntu) → unity-mir (Ubuntu)
summary: - Screen doesn't blank with #43 on mako
+ Screen doesn't auto-blank with mako during first boot (since #43)

Just updated to #63 and this still happens.

Just updated to #181 and this still happens. I did an over the air update, and once it rebooted the screen permanently shows the welcome screen. I just tapped the screen and that triggers it to go to sleep some seconds later.

http://paste.ubuntu.com/6937415/ is my dmesg output.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers