psql warnings (version 122)

Bug #860552 reported by gpredrag on 2011-09-27
56
This bug affects 9 people
Affects Status Importance Assigned to Milestone
postgresql-common (Ubuntu)
Medium
Martin Pitt
Oneiric
Medium
Martin Pitt
Precise
High
Martin Pitt

Bug Description

On Ubuntu oneiric, starting psql gives following warning:

Can't exec "dpkg-architecture": No such file or directory at /usr/bin/psql line 103.
Use of uninitialized value $multiarch in scalar chomp at /usr/bin/psql line 104.

Ubuntu version:
Description: Ubuntu oneiric (development branch)
Release: 11.10

postgresql-common version
122

psql is stil functional but error persist.
I gues one could install dpkg-dev but that has lot of additional dependencies that are not needed on server.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in postgresql-common (Ubuntu):
status: New → Confirmed
Jacob Fogg (jacobfogg) wrote :

Ubuntu: 10.04.3 LTS
psql: 9.1.1
postgresql-common: 122

I am having the same issue, being this is a local dev server I installed dpkg-dev and am now getting this error:

DEB_HOST_MULTIARCH is not a supported variable name at /usr/bin/dpkg-architecture line 214.

Jamie Strandboge (jdstrand) wrote :

I see this too doing 11.10 testing: http://iso.qa.ubuntu.com/qatracker/result/6986/205. This does not appear fatal, but does seem important to fix as the error is scary looking. Installing dpkg-dev does work fine on 11.10.

tags: added: iso-testing
Martin Pitt (pitti) wrote :

This is fully fixed in version 124 in Sid. For oneiric we don't actually need the multiarch check, as our libreadline is not multiarched yet. So for oneiric I'll upload a very simple fix which just disables this.

Changed in postgresql-common (Ubuntu Precise):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
status: New → Fix Committed
Changed in postgresql-common (Ubuntu Oneiric):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
status: Confirmed → In Progress
Mark Lakewood (markl-f) wrote :

Hi all,

I get this as well when installing postgresql 9.0 from the ppa for 10.04.

I imagine the changes for oneiric and Precise will fix those of us using Postgres 9.0 etc on 10.04?

Cheers

Mark

Martin Pitt (pitti) wrote :

Uploaded to oneiric-proposed queue, waiting for SRU team to review.

Changed in postgresql-common (Ubuntu Oneiric):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Yes, the fix applies to all postgresql-X.Y versions.

Hello gpredrag, or anyone else affected,

Accepted postgresql-common into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Migs de Villa (jc-devilla) wrote :

Installed the just 5 minutes ago all ok.

Prior to running the upgrade, I uninstalled dpkg-dev first and tried using psql to make sure it wasn't around anymore. I got the error message as earlier messages. Then I installed the propsed fix and the message no longer appears.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-common - 122ubuntu1

---------------
postgresql-common (122ubuntu1) oneiric-proposed; urgency=low

  * pg_wrapper: Disable searching of multiarched libreadline. libreadline is
    not multiarched yet in oneiric, so this is not yet necessary. The complete
    fix in version 124 is more intrusive and not appropriate/necessary for an
    SRU. (LP: #860552)
 -- Martin Pitt <email address hidden> Wed, 12 Oct 2011 07:28:42 +0200

Changed in postgresql-common (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in postgresql-common (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers