package postgresql-common (not installed) failed to install/upgrade: il sottoprocesso nuovo pacchetto postgresql-common script pre-installation ha restituito lo stato di errore 2

Bug #1904481 reported by valerio cogrossi
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
postgresql-common (Ubuntu)
Expired
Undecided
Unassigned

Bug Description

non e chiaro

ProblemType: Package
DistroRelease: Ubuntu 20.10
Package: postgresql-common (not installed)
ProcVersionSignature: Ubuntu 5.8.0-26.27-generic 5.8.14
Uname: Linux 5.8.0-26-generic x86_64
ApportVersion: 2.20.11-0ubuntu50.1
Architecture: amd64
CasperMD5CheckResult: skip
Date: Mon Nov 16 17:24:24 2020
ErrorMessage: il sottoprocesso nuovo pacchetto postgresql-common script pre-installation ha restituito lo stato di errore 2
InstallationDate: Installed on 2020-11-13 (3 days ago)
InstallationMedia: Lubuntu 20.10 "Groovy Gorilla" - Release amd64 (20201022)
Python3Details: /usr/bin/python3.8, Python 3.8.6, python3-minimal, 3.8.6-0ubuntu1
PythonDetails: N/A
RelatedPackageVersions:
 dpkg 1.20.5ubuntu2
 apt 2.1.11
SourcePackage: postgresql-common
Title: package postgresql-common (not installed) failed to install/upgrade: il sottoprocesso nuovo pacchetto postgresql-common script pre-installation ha restituito lo stato di errore 2
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
valerio cogrossi (v-cogr1949) wrote :
Revision history for this message
Sergio Durigan Junior (sergiodj) wrote :

Thank you for taking the time to file a bug report.

Based on the logs attached to the bug, it seems to me that this is a local configuration issue. Do you have any other instance of Postgresql running? Based on the log below:

Preparativi per estrarre .../24-postgresql-common_216_all.deb...
Viene aggiunto "deviazione di /usr/bin/pg_config in /usr/bin/pg_config.libpq-dev da postgresql-common"
dpkg-divert: errore: la rinomina comprende il sovrascrivere "/usr/bin/pg_config.libpq-dev" con
   il file "/usr/bin/pg_config", non consentito
dpkg: errore nell'elaborare l'archivio /tmp/apt-dpkg-install-JGVG7f/24-postgresql-common_216_all.deb (--unpack):
 il sottoprocesso nuovo pacchetto postgresql-common script pre-installation ha restituito lo stato di errore 2

dpkg was unable to manipulate "/usr/bin/pg_config" properly, which can mean that you already have another version of the file installed.

Since it seems likely to me that this is a local configuration problem,
rather than a bug in Ubuntu, I am marking this bug as 'Incomplete'.

However, if you believe that this is really a bug in Ubuntu, then we would
be grateful if you would provide a more complete description of the problem
with steps to reproduce, explain why you believe this is a bug in Ubuntu
rather than a problem specific to your system, and then change the bug
status back to "New".

For local configuration issues, you can find assistance here:
http://www.ubuntu.com/support/community

Changed in postgresql-common (Ubuntu):
status: New → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for postgresql-common (Ubuntu) because there has been no activity for 60 days.]

Changed in postgresql-common (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers