Transition from src:postgresql-9.5 to src:postgresql-9.6

Bug #1666566 reported by Nish Aravamudan
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
postgresql-9.5 (Ubuntu)
Undecided
Unassigned
postgresql-9.6 (Ubuntu)
Undecided
Unassigned
postgresql-filedump (Ubuntu)
Undecided
Unassigned
postgresql-multicorn (Ubuntu)
Undecided
Unassigned
postgresql-plproxy (Ubuntu)
Undecided
Unassigned

Bug Description

Transitioning to PostgreSQL 9.6 will require some coordination among several packages and after discussion on the Server Team (along with Martin Pitt), we have decided to defer PostgreSQL 9.6 to z+1, however it is already in z-p due to the sync from Debian.

Please remove the src package from z-p so we can not block any other PostgreSQL packages and dependencies for z itself.

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

This includes also some "no-change-rebuilds for 9.6".
They are in update excuses depending on postgres - please let us know if we shall create a list of those.

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

Jbicha will add some details but it seems we try to make it pass and then remove 9.5 from zesty.

Super-raw overview of remaining regressions:
- postgresql-plproxy
- posgresql-multicorn
- posgresql-filedump

Revision history for this message
Jeremy Bicha (jbicha) wrote :

I understand if you don't want to commit to maintaining 9.6 for zesty, but my first impression was that there was confusion about how close this transition was to being complete.

Will 18.04 LTS use 9.6 or 10 (10 is expected in 3rd Quarter 2017 according to https://www.postgresql.org/developer/roadmap/ ) ? Especially if 18.04 LTS uses 9.6 then it seems the maintenance burden might not be too bad since Debian Stretch is shipping 9.6 too and most of these packages are synced with Debian.

postgresql-plproxy's autopkgtest failures are not new (they failed in yakkety with 9.5 too) but I don't know about the other two autopkgtest regressions.

Nish Aravamudan (nacc)
summary: - Please remove postgresql-9.6 from zesty-proposed
+ Transition from src:postgresql-9.5 to src:postgresql-9.6
Revision history for this message
Nish Aravamudan (nacc) wrote :

postgresql-filedump 9.6.0-1build1 passes tests.

Changed in postgresql-filedump (Ubuntu):
status: New → Fix Committed
Revision history for this message
Nish Aravamudan (nacc) wrote :

postgresql-plproxy 2.7-1ubuntu1 passes tests locally. Submitted delta to Debian.

Changed in postgresql-plproxy (Ubuntu):
status: New → Fix Committed
Changed in postgresql-filedump (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Nish Aravamudan (nacc) wrote :

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=856423 is the Debian report for the plproxy fix.

Revision history for this message
Nish Aravamudan (nacc) wrote :

Thanks to Jeremy's digging, postgresql-multicorn has been failing for years in both Debian and Ubuntu. We just need to update the excuses hints at https://bazaar.launchpad.net/~ubuntu-release/britney/hints-ubuntu/view/head:/pitti#L164

Changed in postgresql-multicorn (Ubuntu):
status: New → Won't Fix
Revision history for this message
Nish Aravamudan (nacc) wrote :

plproxy does pass the tests now, but newpid fails to install under LXD. We can either mark this as ignoreable if it's a LXD bug or we can add a machine-isolation restriction if it's something fundamental. Verifying this on IRC and will update.

Revision history for this message
Nish Aravamudan (nacc) wrote :

16:39 < stgraber> nacc: it's attempting to set fs capabilities, that's not
                  supported inside user namespaces by the kernel
16:40 < stgraber> nacc: most other packages fallback to setuid when that
                  happens (ping for example)
16:40 < stgraber> we also have a kernel fix for this but it's not been merged
                  mainline yet
16:42 < stgraber> hallyn wrote the patch and has been trying to get it merged
                  upstream for a while now

Revision history for this message
Nish Aravamudan (nacc) wrote :

Based upon stgraber's input, switching the test dep to util-linux & unshare.

Revision history for this message
Nish Aravamudan (nacc) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-plproxy - 2.7-1ubuntu2

---------------
postgresql-plproxy (2.7-1ubuntu2) zesty; urgency=medium

  * d/t/control: the newpid package fails to install in LXD
    environments (relies on fs capabilities which are disallowed by the
    kernel in user namespaces), so use unshare instead (LP: #1666566).

 -- Nishanth Aravamudan <email address hidden> Tue, 28 Feb 2017 16:28:57 -0800

Changed in postgresql-plproxy (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Nish Aravamudan (nacc) wrote :

src:postgresql-9.6 has transitioned, so now it's just removal of src:postgresql-9.5.

$ rmadison search -S postgresql-9.5 -s zesty | awk '{ print $1; }' | xargs -n1 reverse-depends | grep '^\*' | awk '{ print $2 }' | sort | uniq | xargs -n1 chdist bin2src zesty-proposed |sort | uniq
barman
postgresql-9.5
repmgr
$ rmadison search -S postgresql-9.5 -s zesty | awk '{ print $1; }' | xargs -n1 reverse-depends -b | grep '^\*' | awk '{ print $2 }' | sort | uniq | xargs -n1 chdist bin2src zesty-proposed |sort | uniq

barman recommends:

Recommends: openssh-server, openssh-client, postgresql-client | postgresql-client-9.6 | postgresql-client-9.5 | postgresql-client-9.4 | postgresql-client-9.3 | postgresql-client-9.2

So it is fine to leave as-is

repmgr (3.3.2):

Depends: postgresql-9.6-repmgr | postgresql-9.5-repmgr | postgresql-9.4-repmgr | postgresql-9.3-repmgr | postgresql-9.2-repmgr | postgresql-9.1-repmgr | postgresql-9.0-repmgr

but repmgr 3.1.5-1 is also in zesty. It shows up at
http://people.canonical.com/~ubuntu-archive/nbs.html and I think we need to manually delete the old binary package.

Changed in postgresql-9.6 (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

repmgr NBS binaries removed. This could've been auto-reaped, if the repmgr package didn't declare an alternate dep on binaries that it no longer builds.

Revision history for this message
Steve Langasek (vorlon) wrote :
Download full text (3.9 KiB)

Removing packages from zesty:
 postgresql-9.5 9.5.5-0ubuntu1 in zesty
  postgresql-9.5 9.5.5-0ubuntu1 in zesty amd64
  postgresql-9.5 9.5.5-0ubuntu1 in zesty arm64
  postgresql-9.5 9.5.5-0ubuntu1 in zesty armhf
  postgresql-9.5 9.5.5-0ubuntu1 in zesty i386
  postgresql-9.5 9.5.5-0ubuntu1 in zesty powerpc
  postgresql-9.5 9.5.5-0ubuntu1 in zesty ppc64el
  postgresql-9.5 9.5.5-0ubuntu1 in zesty s390x
  postgresql-9.5-dbg 9.5.5-0ubuntu1 in zesty amd64
  postgresql-9.5-dbg 9.5.5-0ubuntu1 in zesty arm64
  postgresql-9.5-dbg 9.5.5-0ubuntu1 in zesty armhf
  postgresql-9.5-dbg 9.5.5-0ubuntu1 in zesty i386
  postgresql-9.5-dbg 9.5.5-0ubuntu1 in zesty powerpc
  postgresql-9.5-dbg 9.5.5-0ubuntu1 in zesty ppc64el
  postgresql-9.5-dbg 9.5.5-0ubuntu1 in zesty s390x
  postgresql-client-9.5 9.5.5-0ubuntu1 in zesty amd64
  postgresql-client-9.5 9.5.5-0ubuntu1 in zesty arm64
  postgresql-client-9.5 9.5.5-0ubuntu1 in zesty armhf
  postgresql-client-9.5 9.5.5-0ubuntu1 in zesty i386
  postgresql-client-9.5 9.5.5-0ubuntu1 in zesty powerpc
  postgresql-client-9.5 9.5.5-0ubuntu1 in zesty ppc64el
  postgresql-client-9.5 9.5.5-0ubuntu1 in zesty s390x
  postgresql-contrib-9.5 9.5.5-0ubuntu1 in zesty amd64
  postgresql-contrib-9.5 9.5.5-0ubuntu1 in zesty arm64
  postgresql-contrib-9.5 9.5.5-0ubuntu1 in zesty armhf
  postgresql-contrib-9.5 9.5.5-0ubuntu1 in zesty i386
  postgresql-contrib-9.5 9.5.5-0ubuntu1 in zesty powerpc
  postgresql-contrib-9.5 9.5.5-0ubuntu1 in zesty ppc64el
  postgresql-contrib-9.5 9.5.5-0ubuntu1 in zesty s390x
  postgresql-doc-9.5 9.5.5-0ubuntu1 in zesty amd64
  postgresql-doc-9.5 9.5.5-0ubuntu1 in zesty arm64
  postgresql-doc-9.5 9.5.5-0ubuntu1 in zesty armhf
  postgresql-doc-9.5 9.5.5-0ubuntu1 in zesty i386
  postgresql-doc-9.5 9.5.5-0ubuntu1 in zesty powerpc
  postgresql-doc-9.5 9.5.5-0ubuntu1 in zesty ppc64el
  postgresql-doc-9.5 9.5.5-0ubuntu1 in zesty s390x
  postgresql-plperl-9.5 9.5.5-0ubuntu1 in zesty amd64
  postgresql-plperl-9.5 9.5.5-0ubuntu1 in zesty arm64
  postgresql-plperl-9.5 9.5.5-0ubuntu1 in zesty armhf
  postgresql-plperl-9.5 9.5.5-0ubuntu1 in zesty i386
  postgresql-plperl-9.5 9.5.5-0ubuntu1 in zesty powerpc
  postgresql-plperl-9.5 9.5.5-0ubuntu1 in zesty ppc64el
  postgresql-plperl-9.5 9.5.5-0ubuntu1 in zesty s390x
  postgresql-plpython-9.5 9.5.5-0ubuntu1 in zesty amd64
  postgresql-plpython-9.5 9.5.5-0ubuntu1 in zesty arm64
  postgresql-plpython-9.5 9.5.5-0ubuntu1 in zesty armhf
  postgresql-plpython-9.5 9.5.5-0ubuntu1 in zesty i386
  postgresql-plpython-9.5 9.5.5-0ubuntu1 in zesty powerpc
  postgresql-plpython-9.5 9.5.5-0ubuntu1 in zesty ppc64el
  postgresql-plpython-9.5 9.5.5-0ubuntu1 in zesty s390x
  postgresql-plpython3-9.5 9.5.5-0ubuntu1 in zesty amd64
  postgresql-plpython3-9.5 9.5.5-0ubuntu1 in zesty arm64
  postgresql-plpython3-9.5 9.5.5-0ubuntu1 in zesty armhf
  postgresql-plpython3-9.5 9.5.5-0ubuntu1 in zesty i386
  postgresql-plpython3-9.5 9.5.5-0ubuntu1 in zesty powerpc
  postgresql-plpython3-9.5 9.5.5-0ubuntu1 in zesty ppc64el
  postgresql-plpython3-9.5 9.5.5-0ubuntu1 in zesty s390x
  postgresql-pltcl-9.5 9.5.5-0ubuntu1 in zesty amd64
  postgresql-pltcl-...

Read more...

Changed in postgresql-9.5 (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.