New upstream microreleases 9.3.19, 9.5.9 and 9.6.5

Bug #1713979 reported by Christian Ehrhardt  on 2017-08-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
postgresql-9.3 (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
postgresql-9.5 (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
postgresql-9.6 (Ubuntu)
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
Undecided
Unassigned

Bug Description

Update to the new set of releases as per the standing micro-release exception these should land in stable Ubuntu releases.

Curren versions in releases:
 postgresql-9.3 | 9.3.18-0ubuntu0.14.04.1 | trusty-security | source, amd64, arm64, armhf, i386, powerpc, ppc64el
 postgresql-9.5 | 9.5.8-0ubuntu0.16.04.1 | xenial-security | source, amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
 postgresql-9.6 | 9.6.4-0ubuntu0.17.04.1 | zesty-security | source, amd64, arm64, armhf, i386, ppc64el, s390x
 postgresql-9.6 | 9.6.4-1 | artful | source, amd64, arm64, armhf, i386, ppc64el, s390x

This was a double bump within 2 weeks.
As the last had upgrade regressions.
But the Security Team already did the Bump on the latest so we effectively have
the potential upgrade regression in the field and need to bump again.

Last stable updates
PostgreSQL 9.6.5, 9.5.9, 9.4.14, 9.3.19, 9.2.23

So the todo is to pick:
MRE: Trusty 9.3.19 from https://www.postgresql.org/ftp/source/v9.3.19/
MRE: Xenial 9.5.9 from https://www.postgresql.org/ftp/source/v9.5.9/
MRE: Zesty 9.6.5 from https://www.postgresql.org/ftp/source/v9.6.5/
Sync: Artful 9.6.5 from https://www.postgresql.org/ftp/source/v9.6.5/

Consider last updates as template:
- pad.lv/1637236
- pad.lv/1664478
- pad.lv/1690730

no longer affects: postgresql-9.3 (Ubuntu Xenial)
no longer affects: postgresql-9.3 (Ubuntu Zesty)
no longer affects: postgresql-9.3 (Ubuntu Artful)
no longer affects: postgresql-9.5 (Ubuntu Trusty)
no longer affects: postgresql-9.5 (Ubuntu Artful)
no longer affects: postgresql-9.5 (Ubuntu Zesty)
no longer affects: postgresql-9.6 (Ubuntu Xenial)
no longer affects: postgresql-9.6 (Ubuntu Trusty)
Changed in postgresql-9.3 (Ubuntu Trusty):
status: New → Triaged
Changed in postgresql-9.5 (Ubuntu Xenial):
status: New → Triaged
Changed in postgresql-9.6 (Ubuntu Zesty):
status: New → Triaged
Changed in postgresql-9.6 (Ubuntu Artful):
status: New → Triaged
Changed in postgresql-9.5 (Ubuntu):
status: New → Invalid
Changed in postgresql-9.3 (Ubuntu):
status: New → Invalid

This is (so far) based on the staging area, but that is usually ending up being
just an archive copy. So we should be good to start now.
Sniffing started in a Bileto Ticket:
- Trusty: https://bileto.ubuntu.com/#/ticket/2932
- Xenial, Zesty: https://bileto.ubuntu.com/#/ticket/2933
- Artful will be a sync once Debian picked 9.6.5-1 (which was uploaded yesterday)

The release officially is at: https://www.postgresql.org/about/news/1777/

kicked the sync for artful

The bileto sniffs for zesty and trusty were good (except the known armhf in T).
Xenial was a bit odd, but none of the issues seen were due to the updates and from past MREs we know this has a few dep8 fals-positives.
Waiting for the sync to migrate and then considering pushing the actual MRE for consideration.

This bug was fixed in the package postgresql-9.6 - 9.6.5-1

---------------
postgresql-9.6 (9.6.5-1) unstable; urgency=medium

  * Team upload.
  * New upstream version.

 -- Christoph Berg <email address hidden> Tue, 29 Aug 2017 12:15:37 +0200

Changed in postgresql-9.6 (Ubuntu):
status: Triaged → Fix Released

With the change in Artful being released and all else prepared/sniffed I pushed the MRE updates for SRU review.

Changed in postgresql-9.6 (Ubuntu Zesty):
status: Triaged → In Progress
Changed in postgresql-9.5 (Ubuntu Xenial):
status: Triaged → In Progress
Changed in postgresql-9.3 (Ubuntu Trusty):
status: Triaged → In Progress

Hello ChristianEhrhardt, or anyone else affected,

Accepted postgresql-9.6 into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/postgresql-9.6/9.6.5-0ubuntu0.17.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in postgresql-9.6 (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-zesty
Changed in postgresql-9.5 (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello ChristianEhrhardt, or anyone else affected,

Accepted postgresql-9.5 into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/postgresql-9.5/9.5.9-0ubuntu0.16.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in postgresql-9.3 (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed-trusty
Brian Murray (brian-murray) wrote :

Hello ChristianEhrhardt, or anyone else affected,

Accepted postgresql-9.3 into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/postgresql-9.3/9.3.19-0ubuntu0.14.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

All good, some dep8's are known to be failing, quoting Pitti from [1]

"These are fallout from moving from LXC to LXD. For devel I fixed the latter in https://anonscm.debian.org/cgit/pkg-postgresql/postgresql-common.git/commit/?id=fc40fc34ce -- functionally everything is correct, the test just failed on unexpected stderr output from a warning in netstat."

So ignoring these as acceptable issues:
- T: pgsql armhf failures due to lxc/lxd (ok)
- X: pgsql armhf/s390x failures due to lxc/lxd (ok)
- X: mimeo armhf failures due to lxc/lxd (ok)

Also the i386 libreoffice regression I've seen on xenial is known to be flaky since [1] and unrelated to the upload. But that can be re-tried until it is green if needed.

With that in mind all tests are good.
I also did a minor check install/upgrade and reuse of DB which was good.
The Mini Test that I did on top of the self tests the build and dep8 already exercises:
# Env prep
git clone https://github.com/akopytov/sysbench.git
apt install build-essential
apt-get build-dep sysbench
cd sysbench/
./autogen.sh
./configure --with-pgsql
make
make install

#psql setup
postgres=# CREATE USER sbtest WITH PASSWORD 'sbtest';
CREATE ROLE
postgres=# CREATE DATABASE sbtest;
CREATE DATABASE
postgres=# GRANT ALL PRIVILEGES ON DATABASE sbtest to sbtest;

# Then run
/usr/local/bin/sysbench oltp_read_only --db-driver=pgsql --pgsql-password="sbtest" prepare
/usr/local/bin/sysbench oltp_read_only --db-driver=pgsql --pgsql-password="sbtest" run

# Now upgrade postgresql - the DB should still be intact for a re-run
/usr/local/bin/sysbench oltp_read_only --db-driver=pgsql --pgsql-password="sbtest" run
# If this does not work either the DB took damage on upgrade or the server didn't restart properly

That said setting verification-done (for only known issues being left) as on past MREs

[1]: https://bugs.launchpad.net/ubuntu/+source/postgresql-9.5/+bug/1637236/comments/8

tags: added: verification-done verification-done-trusty verification-done-xenial verification-done-zesty
removed: verification-needed verification-needed-trusty verification-needed-xenial verification-needed-zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-9.6 - 9.6.5-0ubuntu0.17.04

---------------
postgresql-9.6 (9.6.5-0ubuntu0.17.04) zesty; urgency=medium

  * New upstream release (LP: #1713979)
    - fix upgrade regressions of the former security release
    - Details about other changes at full changelog:
      https://www.postgresql.org/docs/9.6/static/release-9-6-5.html

 -- Christian Ehrhardt <email address hidden> Wed, 30 Aug 2017 13:01:24 +0200

Changed in postgresql-9.6 (Ubuntu Zesty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for postgresql-9.6 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-9.5 - 9.5.9-0ubuntu0.16.04

---------------
postgresql-9.5 (9.5.9-0ubuntu0.16.04) xenial; urgency=medium

  * New upstream release (LP: #1713979)
    - fix upgrade regressions of the former security release
    - Details about other changes at full changelog:
      https://www.postgresql.org/docs/9.5/static/release-9-5-9.html

 -- Christian Ehrhardt <email address hidden> Wed, 30 Aug 2017 13:01:13 +0200

Changed in postgresql-9.5 (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-9.3 - 9.3.19-0ubuntu0.14.04

---------------
postgresql-9.3 (9.3.19-0ubuntu0.14.04) trusty; urgency=medium

  * New upstream release (LP: #1713979)
    - fix upgrade regressions of the former security release
    - Details about other changes at full changelog:
      https://www.postgresql.org/docs/9.3/static/release-9-3-19.html

 -- Christian Ehrhardt <email address hidden> Wed, 30 Aug 2017 13:00:40 +0200

Changed in postgresql-9.3 (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers