package postgresql-client-9.1 9.1.3-0ubuntu0.11.10 failed to install/upgrade: trying to overwrite '/usr/lib/postgresql/9.1/bin/pg_basebackup', which is also in package postgresql-9.1 9.1.3-0ubuntu0.11.10

Bug #944632 reported by Thierry Mallard on 2012-03-02
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
postgresql-9.1 (Ubuntu)
Undecided
Martin Pitt

Bug Description

After updating to 12.04 beta 1 *and* rebooting.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: postgresql-client-9.1 9.1.3-0ubuntu0.11.10
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
Date: Fri Mar 2 07:38:58 2012
DpkgHistoryLog:
 Start-Date: 2012-03-02 07:35:22
 Commandline: aptdaemon role='role-commit-packages' sender=':1.44'
 Upgrade: libgtk2.0-common:amd64 (2.24.10-0ubuntu4, 2.24.10-0ubuntu5), libtwolame0:amd64 (0.3.13-1, 0.3.13-1build1), libjavascriptcoregtk-3.0-0:amd64 (1.7.5-0ubuntu3, 1.7.90-0ubuntu1), gthumb:amd64 (2.14.1-1, 2.14.2-1), vim-common:amd64 (7.3.346-1ubuntu1, 7.3.429-2ubuntu1), postgresql-9.1:amd64 (9.1.3-0ubuntu0.11.10, 9.1.3-1), libgail18:amd64 (2.24.10-0ubuntu4, 2.24.10-0ubuntu5), libgail18:i386 (2.24.10-0ubuntu4, 2.24.10-0ubuntu5), libv4l-0:amd64 (0.8.5-6ubuntu1, 0.8.6-1ubuntu1), libv4l-0:i386 (0.8.5-6ubuntu1, 0.8.6-1ubuntu1), libsane-hpaio:amd64 (3.12.2-1, 3.12.2-1ubuntu1), poppler-utils:amd64 (0.18.4-1ubuntu1, 0.18.4-1ubuntu2), hplip-cups:amd64 (3.12.2-1, 3.12.2-1ubuntu1), twolame:amd64 (0.3.13-1, 0.3.13-1build1), pulseaudio:amd64 (1.1-0ubuntu10, 1.1-0ubuntu11), gthumb-data:amd64 (2.14.1-1, 2.14.2-1), libnm-util2:amd64 (0.9.2.0+git201202161854.8572ecf-0ubuntu4, 0.9.2.0+git201202161854.8572ecf-0ubuntu5), hpijs:amd64 (3.12.2-1, 3.12.2-1ubuntu1), gnome-sudoku:amd64 (3.3.5-0ubuntu1, 3.3.5-0ubuntu2), libwebkitgt k-1.0-common:amd64 (1.7.5-0ubuntu3, 1.7.90-0ubuntu1), hplip:amd64 (3.12.2-1, 3.12.2-1ubuntu1), pulseaudio-module-x11:amd64 (1.1-0ubuntu10, 1.1-0ubuntu11), xfdesktop4-data:amd64 (4.8.3-2ubuntu3, 4.8.3-2ubuntu4), gir1.2-gtk-2.0:amd64 (2.24.10-0ubuntu4, 2.24.10-0ubuntu5), libwebkitgtk-3.0-0:amd64 (1.7.5-0ubuntu3, 1.7.90-0ubuntu1), libv4lconvert0:amd64 (0.8.5-6ubuntu1, 0.8.6-1ubuntu1), libv4lconvert0:i386 (0.8.5-6ubuntu1, 0.8.6-1ubuntu1), vim-tiny:amd64 (7.3.346-1ubuntu1, 7.3.429-2ubuntu1), libjavascriptcoregtk-1.0-0:amd64 (1.7.5-0ubuntu3, 1.7.90-0ubuntu1), network-manager:amd64 (0.9.2.0+git201202161854.8572ecf-0ubuntu4, 0.9.2.0+git201202161854.8572ecf-0ubuntu5), libhpmud0:amd64 (3.12.2-1, 3.12.2-1ubuntu1), pulseaudio-esound-compat:amd64 (1.1-0ubuntu10, 1.1-0ubuntu11), libnm-glib-vpn1:amd64 (0.9.2.0+git201202161854.8572ecf-0ubuntu4, 0.9.2.0+git201202161854.8572ecf-0ubuntu5), libgdome2-0:amd64 (0.8.1+debian-4.1, 0.8.1+debian-4.1build1), libnm-glib4:amd64 (0.9.2.0+git201202161854.8572ecf-0ubuntu4, 0.9.2.0+git20120 2161854.8572ecf-0ubuntu5), libpulse-mainloop-glib0:amd64 (1.1-0ubuntu10, 1.1-0ubuntu11), libpulse-mainloop-glib0:i386 (1.1-0ubuntu10, 1.1-0ubuntu11), libxcb-keysyms1:amd64 (0.3.8-1, 0.3.8-1build1), libpoppler-glib8:amd64 (0.18.4-1ubuntu1, 0.18.4-1ubuntu2), libgail-common:i386 (2.24.10-0ubuntu4, 2.24.10-0ubuntu5), postgresql-client-9.1:amd64 (9.1.3-0ubuntu0.11.10, 9.1.3-1), nautilus-data:amd64 (3.3.90-0ubuntu2, 3.3.90-0ubuntu4), vim:amd64 (7.3.346-1ubuntu1, 7.3.429-2ubuntu1), xfdesktop4:amd64 (4.8.3-2ubuntu3, 4.8.3-2ubuntu4), libcdaudio1:amd64 (0.99.12p2-10, 0.99.12p2-10build1), printer-driver-hpcups:amd64 (3.12.2-1, 3.12.2-1ubuntu1), gtk2-engines-pixbuf:amd64 (2.24.10-0ubuntu4, 2.24.10-0ubuntu5), gtk2-engines-pixbuf:i386 (2.24.10-0ubuntu4, 2.24.10-0ubuntu5), vim-runtime:amd64 (7.3.346-1ubuntu1, 7.3.429-2ubuntu1), libwebkitgtk-1.0-0:amd64 (1.7.5-0ubuntu3, 1.7.90-0ubuntu1), quadrapassel:amd64 (3.3.5-0ubuntu1, 3.3.5-0ubuntu2), mahjongg:amd64 (3.3.5-0ubuntu1, 3.3.5-0ubuntu2), libpq5:amd64 (9.1.3-0ubuntu0.11.10, 9.1.3-1), gnome-games-data:amd64 (3.3.5-0ubuntu1, 3.3.5-0ubuntu2), libpulse0:amd64 (1.1-0ubuntu10, 1.1-0ubuntu11), libpulse0:i386 (1.1-0ubuntu10, 1.1-0ubuntu11), libpulsedsp:amd64 (1.1-0ubuntu10, 1.1-0ubuntu11), libpulsedsp:i386 (1.1-0ubuntu10, 1.1-0ubuntu11), gir1.2-webkit-3.0:amd64 (1.7.5-0ubuntu3, 1.7.90-0ubuntu1), libgtk2.0-bin:amd64 (2.24.10-0ubuntu4, 2.24.10-0ubuntu5), libnautilus-extension1a:amd64 (3.3.90-0ubuntu2, 3.3.90-0ubuntu4), libpoppler19:amd64 (0.18.4-1ubuntu1, 0.18.4-1ubuntu2), libwebkitgtk-3.0-common:amd64 (1.7.5-0ubuntu3, 1.7.90-0ubuntu1), libgtk2.0-0:amd64 (2.24.10-0ubuntu4, 2.24.10-0ubuntu5), libgtk2.0-0:i386 (2.24.10-0ubuntu4, 2.24.10-0ubuntu5), pulseaudio-utils:amd64 (1.1-0ubuntu10, 1.1-0ubuntu11), gir1.2-javascriptcoregtk-3.0:amd64 (1.7.5-0ubuntu3, 1.7.90-0ubuntu1), printer-driver-hpijs:amd64 (3.12.2-1, 3.12.2-1ubuntu1), hplip-data:amd64 (3.12.2-1, 3.12.2-1ubuntu1), gnomine:amd64 (3.3.5-0ubuntu1, 3.3.5-0ubuntu2)
DuplicateSignature:
 Unpacking replacement postgresql-client-9.1 ...
 dpkg: error processing /var/cache/apt/archives/postgresql-client-9.1_9.1.3-1_amd64.deb (--unpack):
  trying to overwrite '/usr/lib/postgresql/9.1/bin/pg_basebackup', which is also in package postgresql-9.1 9.1.3-0ubuntu0.11.10
ErrorMessage: trying to overwrite '/usr/lib/postgresql/9.1/bin/pg_basebackup', which is also in package postgresql-9.1 9.1.3-0ubuntu0.11.10
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
SourcePackage: postgresql-9.1
Title: package postgresql-client-9.1 9.1.3-0ubuntu0.11.10 failed to install/upgrade: trying to overwrite '/usr/lib/postgresql/9.1/bin/pg_basebackup', which is also in package postgresql-9.1 9.1.3-0ubuntu0.11.10
UpgradeStatus: Upgraded to precise on 2012-03-02 (0 days ago)

tags: removed: need-duplicate-check
Martin Pitt (pitti) on 2012-03-03
Changed in postgresql-9.1 (Ubuntu):
status: New → Fix Committed
assignee: nobody → Martin Pitt (pitti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-9.1 - 9.1.3-2

---------------
postgresql-9.1 (9.1.3-2) unstable; urgency=low

  * debian/control, debian/rules: Support and prefer dpkg-buildflags when
    building with dpkg-dev >= 1.16.1~. Fall back to hardening-wrapper
    otherwise, to keep supporting backports.
  * debian/rules: Build with "-z now" for some extra hardening. We can't use
    the full "hardening=+all", as PIE causes build failures.
  * debian/copyright: Fix syntax for copyright format 1.0.
  * debian/control: Bump Breaks/Replaces versions to current binary version,
    so that e. g. the moved pg_basebackup does not cause upgrade errors when
    upgrading from higher point releases in previous distro releases.
    (LP: #944632)
 -- Martin Pitt <email address hidden> Tue, 06 Mar 2012 11:55:57 +0100

Changed in postgresql-9.1 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers