New upstream microreleases 9.1.24, 9.3.15, 9.5.5

Bug #1637236 reported by Martin Pitt on 2016-10-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
postgresql-9.1 (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Trusty
Undecided
Unassigned
postgresql-9.3 (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
postgresql-9.5 (Ubuntu)
Undecided
Martin Pitt
Xenial
Undecided
Unassigned
Yakkety
Undecided
Martin Pitt
Zesty
Undecided
Martin Pitt

Bug Description

https://www.postgresql.org/about/news/1712/

As per the standing micro-release exception these should land in stable Ubuntu releases.

Martin Pitt (pitti) wrote :

9.5.5 should hit Debian unstable RSN, will sync from there to zesty.

Changed in postgresql-9.5 (Ubuntu Zesty):
status: New → Fix Committed
no longer affects: postgresql-9.1 (Ubuntu Zesty)
no longer affects: postgresql-9.1 (Ubuntu Yakkety)
no longer affects: postgresql-9.1 (Ubuntu Xenial)
Changed in postgresql-9.1 (Ubuntu):
status: New → Invalid
no longer affects: postgresql-9.3 (Ubuntu Precise)
no longer affects: postgresql-9.3 (Ubuntu Xenial)
no longer affects: postgresql-9.3 (Ubuntu Yakkety)
no longer affects: postgresql-9.3 (Ubuntu Zesty)
Changed in postgresql-9.3 (Ubuntu):
status: New → Invalid
no longer affects: postgresql-9.5 (Ubuntu Precise)
no longer affects: postgresql-9.5 (Ubuntu Trusty)
Martin Pitt (pitti) on 2016-10-27
Changed in postgresql-9.5 (Ubuntu Zesty):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) on 2016-10-27
Changed in postgresql-9.5 (Ubuntu Xenial):
status: New → In Progress
Martin Pitt (pitti) wrote :

Actually no, we can't sync zesty, it'll require a proper upload as Debian already moved to 9.6.

Changed in postgresql-9.5 (Ubuntu Zesty):
assignee: Martin Pitt (pitti) → nobody
status: Fix Committed → In Progress
Martin Pitt (pitti) on 2016-10-27
Changed in postgresql-9.5 (Ubuntu Zesty):
status: In Progress → Fix Committed
assignee: nobody → Martin Pitt (pitti)
Changed in postgresql-9.5 (Ubuntu Yakkety):
status: New → In Progress
assignee: nobody → Martin Pitt (pitti)
Changed in postgresql-9.3 (Ubuntu Trusty):
status: New → In Progress
Changed in postgresql-9.1 (Ubuntu Trusty):
status: New → In Progress
Martin Pitt (pitti) on 2016-10-27
Changed in postgresql-9.1 (Ubuntu Precise):
status: New → In Progress

Hello Martin, or anyone else affected,

Accepted postgresql-9.5 into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/postgresql-9.5/9.5.5-0ubuntu0.16.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in postgresql-9.5 (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in postgresql-9.5 (Ubuntu Xenial):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Martin, or anyone else affected,

Accepted postgresql-9.5 into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/postgresql-9.5/9.5.5-0ubuntu0.16.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in postgresql-9.3 (Ubuntu Trusty):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Martin, or anyone else affected,

Accepted postgresql-9.3 into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/postgresql-9.3/9.3.15-0ubuntu0.14.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in postgresql-9.1 (Ubuntu Trusty):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Martin, or anyone else affected,

Accepted postgresql-9.1 into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/postgresql-9.1/9.1.24-0ubuntu0.14.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in postgresql-9.1 (Ubuntu Precise):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Martin, or anyone else affected,

Accepted postgresql-9.1 into precise-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/postgresql-9.1/9.1.24-0ubuntu0.12.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Martin Pitt (pitti) wrote :

http://people.canonical.com/~ubuntu-archive/proposed-migration/xenial/update_excuses.html#postgresql-9.5
http://people.canonical.com/~ubuntu-archive/proposed-migration/yakkety/update_excuses.html#postgresql-9.5

All pass except for mimeo/armhf and postgresql-9.5/armhf. These are fallout from moving from LXC to LXD. For devel I fixed the latter in https://anonscm.debian.org/cgit/pkg-postgresql/postgresql-common.git/commit/?id=fc40fc34ce -- functionally everything is correct, the test just failed on unexpected stderr output from a warning in netstat.

Yakkety also has a libreoffice regression on i386, but this test is flaky.

http://people.canonical.com/~ubuntu-archive/proposed-migration/trusty/update_excuses.html#postgresql-9.3

All good except for postgresql-9.3 on armhf, same issue as before (the netstat 2>&/dev/null should be backported to postgresql-common to fix that).

http://people.canonical.com/~ubuntu-archive/proposed-migration/precise/update_excuses.html#postgresql-9.1

This never succeeded on precise, but it gets as far as the previous versions.

Thus stable updates are verified.

zesty shows a lot of regressions as postgresql-common claims that 9.6 is the supported version, due to a missing 17.04 entry in supported-versions. I just uploaded a fix (together with the fix for the netstat noise), so it'll still be a day or two until the machinery catches up.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-9.5 - 9.5.5-0ubuntu1

---------------
postgresql-9.5 (9.5.5-0ubuntu1) zesty-proposed; urgency=medium

  * New upstream bug fix release (LP: #1637236)
    - Fix WAL-logging of truncation of relation free space maps and visibility
      maps.
      It was possible for these files to not be correctly restored during
      crash recovery, or to be written incorrectly on a standby server. Bogus
      entries in a free space map could lead to attempts to access pages that
      have been truncated away from the relation itself, typically producing
      errors like "could not read block XXX: read only 0 of 8192 bytes".
      Checksum failures in the visibility map are also possible, if
      checksumming is enabled.

      Procedures for determining whether there is a problem and repairing it
      if so are discussed at
         https://wiki.postgresql.org/wiki/Free_Space_Map_Problems.

    - Details about other changes:
      http://www.postgresql.org/docs/9.5/static/release-9-5-5.html

 -- Martin Pitt <email address hidden> Thu, 27 Oct 2016 17:51:11 +0200

Changed in postgresql-9.5 (Ubuntu Zesty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for postgresql-9.1 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-9.1 - 9.1.24-0ubuntu0.14.04

---------------
postgresql-9.1 (9.1.24-0ubuntu0.14.04) trusty-proposed; urgency=medium

  * New upstream bug fix release (LP: #1637236). No effective changes for
    PL/Perl, the version must just be higher than the one in precise, to not
    break upgrades.

 -- Martin Pitt <email address hidden> Thu, 27 Oct 2016 21:26:48 +0200

Changed in postgresql-9.1 (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-9.3 - 9.3.15-0ubuntu0.14.04

---------------
postgresql-9.3 (9.3.15-0ubuntu0.14.04) trusty-proposed; urgency=medium

  * New upstream bug fix release (LP: #1637236)
    - Fix WAL-logging of truncation of relation free space maps and visibility
      maps.
      It was possible for these files to not be correctly restored during
      crash recovery, or to be written incorrectly on a standby server. Bogus
      entries in a free space map could lead to attempts to access pages that
      have been truncated away from the relation itself, typically producing
      errors like "could not read block XXX: read only 0 of 8192 bytes".
      Checksum failures in the visibility map are also possible, if
      checksumming is enabled.

      Procedures for determining whether there is a problem and repairing it
      if so are discussed at
         https://wiki.postgresql.org/wiki/Free_Space_Map_Problems

    - Details about other changes:
      http://www.postgresql.org/docs/9.3/static/release-9-3-15.html

 -- Martin Pitt <email address hidden> Thu, 27 Oct 2016 21:20:52 +0200

Changed in postgresql-9.3 (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-9.5 - 9.5.5-0ubuntu0.16.04

---------------
postgresql-9.5 (9.5.5-0ubuntu0.16.04) xenial-proposed; urgency=medium

  * New upstream bug fix release (LP: #1637236)
    - Fix WAL-logging of truncation of relation free space maps and visibility
      maps.
      It was possible for these files to not be correctly restored during
      crash recovery, or to be written incorrectly on a standby server. Bogus
      entries in a free space map could lead to attempts to access pages that
      have been truncated away from the relation itself, typically producing
      errors like "could not read block XXX: read only 0 of 8192 bytes".
      Checksum failures in the visibility map are also possible, if
      checksumming is enabled.

      Procedures for determining whether there is a problem and repairing it
      if so are discussed at
         https://wiki.postgresql.org/wiki/Free_Space_Map_Problems.

    - Details about other changes:
      http://www.postgresql.org/docs/9.5/static/release-9-5-5.html

 -- Martin Pitt <email address hidden> Thu, 27 Oct 2016 18:03:43 +0200

Changed in postgresql-9.5 (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-9.5 - 9.5.5-0ubuntu0.16.10

---------------
postgresql-9.5 (9.5.5-0ubuntu0.16.10) yakkety; urgency=medium

  * New upstream bug fix release (LP: #1637236)
    - Fix WAL-logging of truncation of relation free space maps and visibility
      maps.
      It was possible for these files to not be correctly restored during
      crash recovery, or to be written incorrectly on a standby server. Bogus
      entries in a free space map could lead to attempts to access pages that
      have been truncated away from the relation itself, typically producing
      errors like "could not read block XXX: read only 0 of 8192 bytes".
      Checksum failures in the visibility map are also possible, if
      checksumming is enabled.

      Procedures for determining whether there is a problem and repairing it
      if so are discussed at
         https://wiki.postgresql.org/wiki/Free_Space_Map_Problems.

    - Details about other changes:
      http://www.postgresql.org/docs/9.5/static/release-9-5-5.html

 -- Martin Pitt <email address hidden> Thu, 27 Oct 2016 17:51:11 +0200

Changed in postgresql-9.5 (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-9.1 - 9.1.24-0ubuntu0.12.04

---------------
postgresql-9.1 (9.1.24-0ubuntu0.12.04) precise-proposed; urgency=medium

  * New upstream bug fix release (LP: #1637236)
   - Details: https://www.postgresql.org/docs/9.1/static/release-9-1-24.html

 -- Martin Pitt <email address hidden> Thu, 27 Oct 2016 21:33:45 +0200

Changed in postgresql-9.1 (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers