New bug fix releases: 9.1.6, 8.4.14, 8.3.21

Bug #1055944 reported by Martin Pitt on 2012-09-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
postgresql-8.3 (Ubuntu)
Undecided
Unassigned
postgresql-8.4 (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Natty
Undecided
Unassigned
postgresql-9.1 (Ubuntu)
Undecided
Martin Pitt
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

PostgreSQL announced new microreleases yesterday: http://www.postgresql.org/about/news/1416/

-9.1 includes a rather serious data loss fix and thus should get into stables as soon as possible. -8.4 is less urgent, but still has a number of nice bug fixes. PostgreSQL has a standing SRU microrelease exception.

Martin Pitt (pitti) wrote :

I uploaded 9.1.6-1 into Debian unstable and will sync it tomorrow.

Changed in postgresql-9.1 (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: New → Fix Committed
no longer affects: postgresql-8.4 (Ubuntu Oneiric)
no longer affects: postgresql-8.4 (Ubuntu Precise)
Changed in postgresql-8.4 (Ubuntu):
status: New → Invalid
description: updated
no longer affects: postgresql-9.1 (Ubuntu Hardy)
no longer affects: postgresql-9.1 (Ubuntu Lucid)
no longer affects: postgresql-9.1 (Ubuntu Natty)
Martin Pitt (pitti) on 2012-09-25
Changed in postgresql-9.1 (Ubuntu Precise):
status: New → In Progress
Changed in postgresql-9.1 (Ubuntu Oneiric):
status: New → In Progress
Martin Pitt (pitti) on 2012-09-25
summary: - New bug fix releases: 9.1.6, 8.4.14
+ New bug fix releases: 9.1.6, 8.4.14, 8.3.21
Changed in postgresql-8.4 (Ubuntu Natty):
status: New → In Progress
Changed in postgresql-8.4 (Ubuntu Lucid):
status: New → In Progress
Martin Pitt (pitti) wrote :

The postgresql-8.3 task is for hardy, but I'm unable to add a proper hardy task for it.

no longer affects: postgresql-8.4 (Ubuntu Hardy)

Hello Martin, or anyone else affected,

Accepted postgresql-9.1 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/postgresql-9.1/9.1.6-0ubuntu12.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in postgresql-9.1 (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

All uploaded to unapproved queues, now ready for SRU team review.

Changed in postgresql-8.3 (Ubuntu):
status: New → In Progress
Chris Halse Rogers (raof) wrote :

Hello Martin, or anyone else affected,

Accepted postgresql-9.1 into oneiric-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/postgresql-9.1/9.1.6-0ubuntu11.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in postgresql-9.1 (Ubuntu Oneiric):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

9.1/precise verified, upstream and postgresql-common tests all pass.

tags: added: verification-done-precise
Martin Pitt (pitti) wrote :

9.1/oneiric verified, upstream and postgresql-common tests all pass.

tags: added: verification-done-oneiric
Scott Kitterman (kitterman) wrote :

Hello Martin, or anyone else affected,

Accepted postgresql-8.4 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/postgresql-8.4/8.4.14-0ubuntu10.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Scott Kitterman (kitterman) wrote :

Hello Martin, or anyone else affected,

Accepted postgresql-8.3 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/postgresql-8.3/8.3.21-0ubuntu8.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Scott Kitterman (kitterman) wrote :

Hello Martin, or anyone else affected,

Accepted postgresql-8.4 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/postgresql-8.4/8.4.14-0ubuntu11.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Martin Pitt (pitti) on 2012-09-27
Changed in postgresql-8.4 (Ubuntu Natty):
status: In Progress → Fix Committed
Changed in postgresql-8.4 (Ubuntu Lucid):
status: In Progress → Fix Committed
Changed in postgresql-8.3 (Ubuntu):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Upstream test suites all succeeded as all updates built on all architectures. The only exception is hardy's postgresql-8.3 on lpia, as we currently do not have any lpia builder:

  https://launchpad.net/ubuntu/+source/postgresql-8.3/8.3.21-0ubuntu8.04/+build/3857919

I ran the p-common test suite against the packages in -proposed on lucid, hardy, and natty, and they all pass.

So verification is complete for all releases, barring the missing lpia build.

tags: added: verification-done
removed: verification-done-oneiric verification-done-precise verification-needed
Martin Pitt (pitti) wrote :

I recruited an i386 builder (aatxe) to build it. So this is all good to go now.

Martin Pitt (pitti) wrote :

Synced 9.1.6-1 into Quantal.

Changed in postgresql-9.1 (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

I forgot that precise/postgresql-8.4 also needs to be updated. I cannot add a precise task here any more,and the upgrade bug was filed in bug 1058218, so let's track that part there then.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-9.1 - 9.1.6-0ubuntu12.04

---------------
postgresql-9.1 (9.1.6-0ubuntu12.04) precise-proposed; urgency=low

  * New upstream bug fix release: (LP: #1055944)
    - Fix persistence marking of shared buffers during WAL replay.
      This mistake can result in buffers not being written out during
      checkpoints, resulting in data corruption if the server later
      crashes without ever having written those buffers. Corruption can
      occur on any server following crash recovery, but it is
      significantly more likely to occur on standby slave servers since
      those perform much more WAL replay. There is a low probability of
      corruption of btree and GIN indexes. There is a much higher
      probability of corruption of table "visibility maps". Fortunately,
      visibility maps are non-critical data in 9.1, so the worst
      consequence of such corruption in 9.1 installations is transient
      inefficiency of vacuuming. Table data proper cannot be corrupted by
      this bug.
      While no index corruption due to this bug is known to have occurred
      in the field, as a precautionary measure it is recommended that
      production installations "REINDEX" all btree and GIN indexes at a
      convenient time after upgrading to 9.1.6.
      Also, if you intend to do an in-place upgrade to 9.2.X, before
      doing so it is recommended to perform a "VACUUM" of all tables
      while having vacuum_freeze_table_age set to zero. This will ensure
      that any lingering wrong data in the visibility maps is corrected
      before 9.2.X can depend on it. vacuum_cost_delay can be adjusted to
      reduce the performance impact of vacuuming, while causing it to
      take longer to finish.
    - See HISTORY/changelog.gz for the other bug fixes.
 -- Martin Pitt <email address hidden> Tue, 25 Sep 2012 07:21:13 +0200

Changed in postgresql-9.1 (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-9.1 - 9.1.6-0ubuntu11.10

---------------
postgresql-9.1 (9.1.6-0ubuntu11.10) oneiric-proposed; urgency=low

  * New upstream bug fix release: (LP: #1055944)
    - Fix persistence marking of shared buffers during WAL replay.
      This mistake can result in buffers not being written out during
      checkpoints, resulting in data corruption if the server later
      crashes without ever having written those buffers. Corruption can
      occur on any server following crash recovery, but it is
      significantly more likely to occur on standby slave servers since
      those perform much more WAL replay. There is a low probability of
      corruption of btree and GIN indexes. There is a much higher
      probability of corruption of table "visibility maps". Fortunately,
      visibility maps are non-critical data in 9.1, so the worst
      consequence of such corruption in 9.1 installations is transient
      inefficiency of vacuuming. Table data proper cannot be corrupted by
      this bug.
      While no index corruption due to this bug is known to have occurred
      in the field, as a precautionary measure it is recommended that
      production installations "REINDEX" all btree and GIN indexes at a
      convenient time after upgrading to 9.1.6.
      Also, if you intend to do an in-place upgrade to 9.2.X, before
      doing so it is recommended to perform a "VACUUM" of all tables
      while having vacuum_freeze_table_age set to zero. This will ensure
      that any lingering wrong data in the visibility maps is corrected
      before 9.2.X can depend on it. vacuum_cost_delay can be adjusted to
      reduce the performance impact of vacuuming, while causing it to
      take longer to finish.
    - See HISTORY/changelog.gz for the other bug fixes.
 -- Martin Pitt <email address hidden> Tue, 25 Sep 2012 07:25:37 +0200

Changed in postgresql-9.1 (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-8.4 - 8.4.14-0ubuntu11.04

---------------
postgresql-8.4 (8.4.14-0ubuntu11.04) natty-proposed; urgency=low

  * New upstream bug fix release: (LP: #1055944)
    - Fix planner's assignment of executor parameters, and fix executor's
      rescan logic for CTE plan nodes.
      These errors could result in wrong answers from queries that scan
      the same WITH subquery multiple times.
    - Improve page-splitting decisions in GiST indexes.
      Multi-column GiST indexes might suffer unexpected bloat due to this
      error.
    - Fix cascading privilege revoke to stop if privileges are still held.
      If we revoke a grant option from some role "X", but "X" still holds
      that option via a grant from someone else, we should not
      recursively revoke the corresponding privilege from role(s) "Y"
      that "X" had granted it to.
    - Fix handling of SIGFPE when PL/Perl is in use.
      Perl resets the process's SIGFPE handler to SIG_IGN, which could
      result in crashes later on. Restore the normal Postgres signal
      handler after initializing PL/Perl.
    - Prevent PL/Perl from crashing if a recursive PL/Perl function is
      redefined while being executed.
    - Work around possible misoptimization in PL/Perl.
      Some Linux distributions contain an incorrect version of
      "pthread.h" that results in incorrect compiled code in PL/Perl,
      leading to crashes if a PL/Perl function calls another one that
      throws an error.
 -- Martin Pitt <email address hidden> Tue, 25 Sep 2012 07:34:06 +0200

Changed in postgresql-8.4 (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-8.4 - 8.4.14-0ubuntu10.04

---------------
postgresql-8.4 (8.4.14-0ubuntu10.04) lucid-proposed; urgency=low

  * New upstream bug fix release: (LP: #1055944)
    - Fix planner's assignment of executor parameters, and fix executor's
      rescan logic for CTE plan nodes.
      These errors could result in wrong answers from queries that scan
      the same WITH subquery multiple times.
    - Improve page-splitting decisions in GiST indexes.
      Multi-column GiST indexes might suffer unexpected bloat due to this
      error.
    - Fix cascading privilege revoke to stop if privileges are still held.
      If we revoke a grant option from some role "X", but "X" still holds
      that option via a grant from someone else, we should not
      recursively revoke the corresponding privilege from role(s) "Y"
      that "X" had granted it to.
    - Fix handling of SIGFPE when PL/Perl is in use.
      Perl resets the process's SIGFPE handler to SIG_IGN, which could
      result in crashes later on. Restore the normal Postgres signal
      handler after initializing PL/Perl.
    - Prevent PL/Perl from crashing if a recursive PL/Perl function is
      redefined while being executed.
    - Work around possible misoptimization in PL/Perl.
      Some Linux distributions contain an incorrect version of
      "pthread.h" that results in incorrect compiled code in PL/Perl,
      leading to crashes if a PL/Perl function calls another one that
      throws an error.
 -- Martin Pitt <email address hidden> Tue, 25 Sep 2012 07:38:24 +0200

Changed in postgresql-8.4 (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-8.3 - 8.3.21-0ubuntu8.04

---------------
postgresql-8.3 (8.3.21-0ubuntu8.04) hardy-proposed; urgency=low

  * New upstream bug fix release: (LP: #1055944)
    - Improve page-splitting decisions in GiST indexes.
      Multi-column GiST indexes might suffer unexpected bloat due to this
      error.
    - Fix cascading privilege revoke to stop if privileges are still held.
      If we revoke a grant option from some role "X", but "X" still holds
      that option via a grant from someone else, we should not
      recursively revoke the corresponding privilege from role(s) "Y"
      that "X" had granted it to.
    - Fix handling of SIGFPE when PL/Perl is in use.
      Perl resets the process's SIGFPE handler to SIG_IGN, which could
      result in crashes later on. Restore the normal Postgres signal
      handler after initializing PL/Perl.
    - Prevent PL/Perl from crashing if a recursive PL/Perl function is
      redefined while being executed.
    - Work around possible misoptimization in PL/Perl.
      Some Linux distributions contain an incorrect version of
      "pthread.h" that results in incorrect compiled code in PL/Perl,
      leading to crashes if a PL/Perl function calls another one that
      throws an error.
 -- Martin Pitt <email address hidden> Tue, 25 Sep 2012 07:45:57 +0200

Changed in postgresql-8.3 (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-8.4 - 8.4.14-0ubuntu12.04.1

---------------
postgresql-8.4 (8.4.14-0ubuntu12.04.1) precise-proposed; urgency=low

  * debian/postgresql-8.4.preinst: Do not only clean up the old -8.4 specific
    init script when upgrading from << 8.4.4-2, as we have newer upstream
    versions in lucid-updates. Instead, remove the version specific init
    script if we have the versionless one from postgresql-common. This fixes
    postgresql-8.4 not restarting after the upgrade. (LP: #1058218)

postgresql-8.4 (8.4.14-0ubuntu12.04) precise-proposed; urgency=low

  * New upstream bug fix release: (LP: #1058218, #1055944)
    - Fix planner's assignment of executor parameters, and fix executor's
      rescan logic for CTE plan nodes.
      These errors could result in wrong answers from queries that scan
      the same WITH subquery multiple times.
    - Improve page-splitting decisions in GiST indexes.
      Multi-column GiST indexes might suffer unexpected bloat due to this
      error.
    - Fix cascading privilege revoke to stop if privileges are still held.
      If we revoke a grant option from some role "X", but "X" still holds
      that option via a grant from someone else, we should not
      recursively revoke the corresponding privilege from role(s) "Y"
      that "X" had granted it to.
    - Fix handling of SIGFPE when PL/Perl is in use.
      Perl resets the process's SIGFPE handler to SIG_IGN, which could
      result in crashes later on. Restore the normal Postgres signal
      handler after initializing PL/Perl.
    - Prevent PL/Perl from crashing if a recursive PL/Perl function is
      redefined while being executed.
    - Work around possible misoptimization in PL/Perl.
      Some Linux distributions contain an incorrect version of
      "pthread.h" that results in incorrect compiled code in PL/Perl,
      leading to crashes if a PL/Perl function calls another one that
      throws an error.
 -- Martin Pitt <email address hidden> Thu, 04 Oct 2012 08:47:19 +0200

Changed in postgresql-8.4 (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers